О программе

 Top Next

О программе

Программа "Аппаратный журнал UR5EQF_LOG"

Владимира Николаевича Ковриженко UR5EQF

"UR5EQF_log v.3 - это программа для ведения аппаратного журнала любительской радиостанции. Имеет удобный интерфейс, большой набор инструментов; может выполнять следующие функции:

·управление трансивером,

·работа цифровыми видами связи,

·работа с DX-кластером.

Может взаимодействовать с {CwType }, {CwGet }, {TrueTTY }, {AAVoice }, {MixW2 }, {MMSSTV }, {Band Master }, {CW Skimmer},{jt-65 },{Ros },{Digital master } и многими другими радиолюбительскими программами.

Основные функции: Хранение нескольких логов для одной станции как единого лога. Для примера, можно вести один лог для повседневной работы, и несколько логов для различных контестов. Хранение логов разных радиостанций с описанием каждого лога. Если в Вашей семье больше одного радиолюбителя, или программа используется в клубе, то UR5EQF_log позволит каждому из пользователей вести статистику по дипломам, независимо друг от друга."

В.Ковриженко


Регистрация

 Top Previous Next

В настоящее время регистрация пользователей программы UR5EQF_LOG не осуществляется.

Если после первоначальной установке полной версии лога появляется окно "Регистрация" при запуске Telnet, то нужно установить это обновление:

Update3.31-60f или Update3.31-60h

В этих обновлениях Олегом (US-E-12) решена проблема с регистрацией.

Кликните кнопкой мышки по кнопке "Register":

в дальнейшем окно с напоминанием о регистрации появляться не будет и кнопка "Register" будет неактивна.


Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

"Программа UR5EQF_log распространяется по принципу "как есть". При этом не предусматривается никаких гарантий, явных или подразумеваемых. Вы используете ее на свой собственный риск." (Из лицензионного соглашения)

О нумерации версий лога

Каталог UR5EQF_Log3.1

Установка полной версии (SetUp)

Установка обновления версии (UpDate)

Обновление до версии v.3.31-61

Запуск лога

Поиск обновлений

Деинсталляция лога

Если возникли проблемы при установке или при работе с логом...


О нумерации версий лога

Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

О нумерации версий лога

п. 14436. RM4Y (ex. RZ1OM): Коллеги, хочу напомнить, что в нумерации версии лога после "тире" стоИт номер релиза... чтобы было понятнее... например, сейчас тестовая версия 3.27-1, релиз 1 ...

Последняя полная версия, написанная Владимиром - 3.31 Full version 3.31 Setup_ur5eqf_log_v3.31.exe

Последнее обновление - до тестовой версии 3.31-60d (06.11.2013)

Update UR5EQF_Log v3.31-60d.exe


Каталог UR5EQF_Log3.1_2_2

Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Каталог UR5EQF_Log3.1

(Папки и файлы программы лога)

Пример установки лога на диск D:


Установка полной версии (SetUp)

Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Установка полной версии (SetUp)

Setup_ur5eqf_log_v3.31.exe

Создать новый журнал?

Как определить свои географические координаты?

Параллельня установка версий

См.ещё (раздел "Регистрация")


Setup_ur5eqf_log_v3.31.exe

Установка полной версии (SetUp)

 Top Previous Next

Setup_ur5eqf_log_v3.31.exe

Установка полной версии UR5EQF_Log_v3.31.

Скачать с сайта UX8IW.UCOZ.COM инсталляционный файл полной версии «Setup_ur5eqf_log_v3.31.exe».

Закрыть все программы и запустить инсталяционный файл:

После запуска файла откроется окно выбора языка инсталляции

(При инсталляции лог определяет, есть ли установленным на компьютере русский язык, если есть, то язык установки - русский):

В выпадающем меню можно выбрать необходимый язык Мастера установки UR5EQF_Log. Нажать ОК, появится следующее диалоговое окно:

Если вы принимаете условия лицензинного соглашения нажмите "Согласен", программа продолжит дальнейшую установку лога:

В следующем окне необходимо выбрать каталог Настройки лога, нажать "Обзор" :

При установке лога в корень выбранного диска, имя диска можно изменить вручную.

При установке в другой каталог нажать обзор выбрать нужный каталог и нажать клавишу "Создать папку":

Присвоить папке имя UR5EQF_Log3.1. В эту папку будет осуществляться установка программы лога. Нажать кнопк "Создать" - появится следующее окно:

Следующее инсталяционное окно:

После первоначального запуска программы UR5EQF_Log появится диалоговое окно "Создать новый журнал?":


Создать новый журнал?

Установка полной версии (SetUp)

 Top Previous Next

Создать новый журнал?

При первоначальной установке программы необходимо создать журнал, для этого нажать клавишу "Yes" в этом окне:

При первоначальной установке новой версии будет выведено диалоговое окно "Новый журнал":

В это окно вносим свои реквизиты:

Заполнение окна "Новый журнал" нужно производить в следующей последовательности (переход по полям заполнения осуществляется по клавише "TAB"):

·Заполнять начинаем с блока "Информация":

1. Позывной

2. QTH

3. Имя

·Далее курсор перейдет в блок "Координаты местоположения":

Заполняем свои значения в поля:

4. Зона ITU

5. Зона CQ

·Заполнение полей "Локатор", "Широта", "Долгота" имеет свои особенности:

1. Если знаете свой локатор, достачно ввести его значение в соответствующее поле. По клавише "Таб" поля "Широта" и "Долгота" заполнятся автоматически.

2. Если знаете свои координаты и локатор: Заполняете поля "Широта" и "Долгота" - по клавише "Таб" поле "Локатор" заполнится автоматически.

Следует имет в ввиду, что Координаты вводятся, только в десятичном формате, т.е., если широта равна, например: 64 градуса 31 минута 16 секунд, то в десятичном формате это будет 64,52 градуса... восточная долгота вводится также в десятичном формате, только со знаком "минус".

3. Если не знаете свои координаты и локатор:

Координаты своего местоположения можно определить по карте в интернете: http://3planeta.com/googlemaps/karty-google-maps.html.

По этой карте координаты определяются в десятичном формате, что удобно для ввода.

·Поле "QSL info (default). Информация из этого поля используется при печати на QSL-карточках. При желании её можно удалить или сделать свой вариант. Эта информация так же автоматически заносится в поле "QSL info" окна "Редактор QSO":

·Нажать клавиши "Создать" и "Закрыть".

Откроется интерфейс журнала UR5EQF_LOG или основное окно

При первоначальном запуске достачно создать один журнал.

Программа лога готова к работе.


Как определить свои географические координаты?

Установка полной версии (SetUp)

 Top Previous Next

Как определить свои географические координаты?

Если не знаете свои координаты и локатор, то координаты своего местоположения можно определить по карте в интернете: http://3planeta.com/googlemaps/karty-google-maps.html.

(Определение географических координат, адреса и высоты местности над уровнем моря по картам Google)


Параллельня установка версий.

Установка полной версии (SetUp)

 Top Previous Next

Параллельня установка версий

На одном компьютере можно устанавливать параллельно несколько версий, как одинаковых по номеру версии и дате её создания, так и разные версии.

Устанавливать можно как на разные диски, так и на один диск, но в разные каталоги, например:

При параллельной установке второй версии программы на другой диск, нужно устанавливать только полную версию.

Если устанавлить несколько одинаковых версий, то достаточно установить одну. Затем скопировать папку с программой лога UR5EQF_Log3.1, и установить копию на любой диск или в любой каталог. Можно скопировать лог и на флешку. На флешке удобно хранить как резервную копию на случай "форсмажора".


Установка обновления версии (UpDate)

Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Установка обновления версии (UpDate)

Обновление (апгрейт) версий 3.ХХ

Последовательность операций по установке обновления версии 3.ХХ

См. ещё (раздел " Автоматический поиск обновления версий")


Обновление (апгрейт) версий 3.ХХ

Установка обновления версии (UpDate)

 Top Previous Next

Обновление (апгрейт) версий 3.ХХ.

Обновление версий, т.е. переход на версию со следущим порядковым номером (например: с v3.21 на v3.22), в настоящее время можно осуществлять только одним способом:

1. Скачать файл для обновления с сайта UX8IW.UCOZ.COM и запустить этот файл, начнется процедура обновления.

Последнее обновление - до тестовой версии 3.31-60d (06.11.2013)

Update UR5EQF_Log v3.31-60d.exe

Обновления к логу, с некоторыми доработками можно скачать на сайте UR5EQF.RU

Остальные три способа в настоящее время не работают:

2. В главном меню программы в меню "Инфо" выбрать опцию "Проверить наличие обновлений"

3. В режиме автоматического поиска обновления версий.

4. Запустить из каталога лога файл "UR5EQF_updater.exe":

В качестве обновления можно ставить полную версию, при этом все настройки и данные не изменятся. Удалять старую версию не нужно. Новая версия устанавливается поверх старой.


Установить обновление версии 3.ХХ.

Установка обновления версии (UpDate)

 Top Previous Next

Последовательность операций по установке обновления версии 3.31

Операции по установке обновления рассмотрим на примере запуска ранее скаченного файла обновления:

Открываем папку, в которую сохранили файл, и запускаем его.

Первым на экран монитора будет выведено диалоговое окно выбора языка инсталляции...

Из выпадающего списка выбираем язык Мастера установки UR5EQF_Log.

Обновление производится в такой же последовательности, что и первоначальная установка:

При обновлении версии 3.хх нужно указывать ту папку, где установлена программа лога. В данном примере это диск C, папка UR5EQF_Log3.1

Нажать клавишу "Установить" - начнется процесс установки обновления:

При установке обновления могут появлятся такие окна (обновление файлов используемых языков):

При обновлении желательно нажимать клавиши "Заменить" или "Заменить все".

Если после установки обновления нет необходимости запускать лог или посещать сайт программы - уберите соответствующие флаги.

Начало запуска обновленной версии:


Обновление до версии v.3.31-61

Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Обновление до версии v.3.31-61

1. Устанавливааем полную версию v.3.31 (Setup_ur5eqf_log_v3.31.exe)

2. Устанавливаем обновление Update3.31-61

Обновление Update3.31-61 (от 28.11.2015) написано Олегом US-E-12, включает в себя все обновления, выпущенные Автором для полной версии v.3.31, а так же обновления v3.31-60e - v3.31-60h, которые так же написаны Олегом US-E-12.

С содержанием обновлений можно подробнее ознакомиться на сайте UR5EQF.RU.

Таким образом, что бы установить версию лога v.3.31-61 достаточно к установленной полной версии v.3.31 сделать только одно обновление - Update3.31-61.

Скачать Update3.31-61


Запуск лога

Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Запуск лога

Запуск лога после установки полной версии или обновления происходит автоматически, если установлен соответствующий флаг "Запустить UR5EQF_Log":

Если флаг не устанавливать, то запуск лога можно осуществить или из каталога лога:

двойным кликом по файлу UR5EQF_Log3 или по иконке на рабочем столе:


Поиск обновлений

Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Поиск обновлений

Для автопроверки поиска обновлений необходимо настроить форму в Меню "Настройки" - "Получить информацию из интернета":

Включить автопроверку - установит чек-бокс. Отключит ь автопроверку - снять чек-бокс.

При запуске Лога программа ищет в интернете те обновления, которые отмечены чекбоксом.

С помощью этой платформы осуществляется поиск следующих обновлений:

·Проверка обновления Лога - в настоящее время поиск обновлений Лога не осуществляется.

·Внешние базы позывных

·Территория (Страна)

·QSL Manager

·Перечень дипломов

·Список модуляций

·Поиск обновлений LotW пользователей и eQSL пользователей

При установленном чекбоксе программа осуществляет поиск в интернете обновлений LotW и eQSL пользователей:

Чек-бокс "Автозагрузка" позволяет осуществлять загрузку в автоматическом режиме.

Можно заменить адрес сайта HB9BZA (http://www.hb9bza.net/lotw/lotw.txt) на адрес сайта WD5EAE (http://www.wd5eae.org/LoTW1.txt) - он оперативнее реагирует на обновление списка LoTW.


Деинсталляция лога

Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Деинсталляция лога

Где найти деинсталлятор лога

Порядок деинсталляции лога

Как удалить настройки из реестра

Как полностью удалить любую программу правильно и начисто


Где найти деинсталлятор лога

Деинсталляция лога

Где найти деинсталлятор лога

В папке с программой лога:


Порядок деинсталляции лога.

Деинсталляция лога

Порядок деинсталляции лога

Перед полным удалением лога из компьютера, необходимо сделать:

1. Резервную копию всей папки с логом

2. Копии папок: DB, MAPS, Image, Download, Plugins, которые затем можно будет вставить в переустановленную программу лога.

3. Для сохранения настроек и базы данных использовать утилиту UR5EQF_backup

После этого можно переходить к деинсталляции лога:

1. Запустить из каталога программы деинсталлятор:

2.Появится следующее окно:

Перед тем как нажать удалить, нужно подумать, для чего это делается, так как вся папка с логом будет безвозвратно утеряна. Не факт, что удасться восстановить из корзины...

идет процесс деинсталляции:

Завершение деинсталляции:

См. ещё (раздел "Как удалить настройки из реестра")


Как удалить настройки из реестра

Деинсталляция лога

Как удалить настройки из реестра

п.14060. RZ1OM: Цитата:

Насчет файла конфигурации - я имел ввиду где сохраняются все настройки лога.
Полностью удалил все папки и файлы лога, скачал и установил новую версию, а все установки и настройки остались прежними...

Настройки сохраняются в реестре операционной системы в ветках HKEY_CURRENT_USER\Software\UR5EQF_Log3 и HKEY_USERS\S-1-5-21-3670359125-1677409870-1074678452-1001\Software\UR5EQF_Log3 ...

Чтобы полностью "вычистить" систему от "хвостов" лога, нужно кроме удаления папки с программой лога удалить ветки реестра... кнопка "Пуск" -> "Выполнить", далее вводим в строку "regedit" (без кавычек) и нажимаем ОК... откроется редактор реестра... в меню "Правка" нужно выбрать "Найти", затем в строке набрать "UR5EQF_log3" (без кавычек)... ниже напротив всех пунктов нужно поставить галочки и нажать "Найти далее"... после нахождения раздела UR5EQF_log3 нажмите правую кнопку мышки и выберите "Удалить"... раздел реестра будет удален... далее на клавиатуре нажмите кнопку F3, чтобы продолжить поиск... точно также нужно удалить все разделы с именем UR5EQF_log3...

операции с удалением данных из реестра делайте на свой страх и риск, так как при неправильной работе с редактором реестра можете просто "уронить" систему, т.е. могут возникать постоянные ошибки Windows или она вообще может не загрузиться...


Как полностью удалить любую программу правильно и начисто

Деинсталляция лога

Как полностью удалить любую программу правильно и начисто

В этом поможет бесплатная программа Revo Uninstaller.

Эта программа позволяет удалить любые программы вместе со всеми созданными и забытыми стандартным деинсталятором записями в реестре, папками, настройками и прочим мусором.

Скачать программу Revo Uninstaller можно на этом сайте:

sonikelf.ru

Я пользуюсь программой Your Uninstaller.


Если возникли проблемы при установке или при работе с логом..._2

Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Если возникли проблемы при установке или при работе с логом...

1. Самый оптимальный вариант, чтобы не допускать таких проблем, это использование утилиты UR5EQF_BackUp, которая как нельзя лучше подходит для этого случая.

При использовании ее Вы в течении нескольких секунд восстанавливаете все настройки и данные в Вашем логе.

2. Если п.1. не выполнять, то в качестве скорой помощи ранее можно было использовать файлы Сергея RM4Y:

·База данных лога - внутренний справочник (DB.mdb)

·Файл дипломных программ (awards.mdb)

·Таблица префиксов (Province.xml, UniqueCalls.xml, CountryDataEx.xml)

Скопировать эти файлы в папку \UR5EQF_Log 3\db\ ... должно помочь...

так как сайт Сергея не рабочий, можно попробовать использовать мои файлы

Скачивать здесь

Иногда при установке лога могут возникать следующие ситуации, когда :

Не указывается ни расстояние до корреспондента, ни направление

Сообщения: "Класс не зарегистрирован" и " база не инсталирована"...

Ошибка приложения: "Неизвестное программное исключение (0х0eedfade)"...

При обновлении версии выскакивает окно "Произошла ошибка копирования файла ..."

При установке лога на флешку выдается ошибка - ModCalcDll.dll не устанавливается.

Перестал открываться лог. Появляется табличка с версией программы и не исчезает

Процесс остановлен ядром базы данных Microsoft Jet...

Не создается новый журнал...

Программа каждый раз предлагает зарегистрироваться на сайте

В Windows 7 при установке лога Omni.rig выдает ошибку...

Запуск программы сильно тормозит

Если лог не запускается

Часть интерфейса лога на русском, все остальное - кракозяблики

Где скачать рабочую базу для папки DB?

Установка лога без инсталляции


Не указывается ни расстояние до корреспондента, ни направление

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Не указывается ни расстояние до корреспондента, ни направление

1. Если установлена ОС 32-х разрядная (Win х84):

п.13886. Что-то сразу не заметил, а потребовалось и обратил внимание. После переустановки Windows в программе не указывается расстояние до корреспондента, ни направление.

п.13887. RZ1OM: В папке с программой лога есть папка с именем Reg ... в ней есть файл Register Libraries.bat ... запустите его, все будет ок...

п.17475. UT5HCW: Даже на стационарном компе, где установлена эта версия лога и все отлично работает, такой папки и файла с таким названиет нет..

п.17476. RM4Y: Забирайте файл, разархивируйте его в папку с логом...

Reg.rar (205.8 Кб) либо скачать здесь

2. Если установлена ОС 64-х разрядная (Win х64):

1.Скачайте другой файл:

Reg_OCx64.rar (222.31 Кб)

2.Разархивируйте его в папку с логом.

3.Запустите файл Register Libraries.bat ..."

После регистрации библиотек определение расстояния до корреспондента, его координат и азимута восстанавливается


Сообщения: "Класс не зарегистрирован" и " база не инсталирована"...

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Сообщения: "Класс не зарегистрирован" и " база не инсталирована"...

п.16367. UR5EQF: Цитата:

Переустановил систему, запускаю лог и получаю при загрузке "Класс не зарегистрирован" (впервые столкнулся с таким сообщением) и следом пишет что база не инсталирована. Далее журнал открывается, но в нем ни одной связи и ни одного лога что были ранее. Пробовал удалять лог и ставить по новой, тот же результат.

После переустановки системы нужно лог тоже инсталлировать (устанавливать полную версию), а если без инсталляции, то нужно выполнить такие действия:

В корневом каталоге программы есть папка Reg, а в ней файл Register Libraries.bat

-Запустите его.

c:\Program Files\UR5EQF\UR5EQF_Log3.1\Reg\Register Libraries.bat


Ошибка приложения: "Неизвестное программное исключение (0х0eedfade)"...

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Ошибка приложения: "Неизвестное программное исключение (0х0eedfade)"...

п.12518. При открытии журнала комп выдает Ошибку приложения :
"Исключение неизвестное программное исключение (0х0eedfade) в приложении по адресу 0x7c812aeb"

Столкнулся с такой ошибкой после установки версии 3.19, переустановка программы и установка базы данных от RZ1OM ничего не дала.

П.12524. RZ1OM: Скорее всего, стоИт "зверевская" сборка винды, на ней часто такие глюки бывают... и на вирус нужно проверить, как вариант... дело не в программе лога, это проблема в операционке или в драйверах...


При обновлении версии выскакивает окно "Произошла ошибка копирования файла ..."

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

При обновлении версии выскакивает окно "Произошла ошибка копирования файла ..."

п.11801. При обновлении версии 3.18 файлом "Update_ur5eqf_log_v3.18_05_02_2010.exe", выскакивает окно. Лог закрыт:

П.11802. UR5EQF: Это говорит о том, что программа запущена. Откройте диспетчер задач, и завершите процесс UR5EQF_log.exe.
По какой то причине программа осталась в памяти..........

п.12577.RZ1OM:Такая ситуация может быть в том случае, если программа лога закрыта, а файл UR5EQF_Log3.exe еще остается запущенным в "Диспетчере задач"... как-то давно пару раз встречался с такой проблемой... нужно "убить" этот процесс и можно обновляться, без перезагрузки системы...


При установке лога на флешку выдается ошибка - ModCalcDll.dll не устанавливается.

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

При установке лога на флешку выдается ошибка - ModCalcDll.dll не устанавливается.

п.11558. UR5EQF: Цитата:

Пытался установить лог (3.14 и 3.17) на флешку выдает ошибку - ModCalcDll.dll не устанавливается.

Похоже Вы устанавливаете обновление, а не полную версию. А на счет установки на флешку, программа все равно должна быть инсталлирована на компьютере, к которому подключается флешка.

См. ещё (раздел "Копирование лога на другой диск")


Перестал открываться лог. Появляется табличка с версией программы и не исчезает.

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Перестал открываться лог. Появляется табличка с версией программы и не исчезает

П.8837: … перестал открываться лог. Появляется табличка с версией программы и не исчезает. Произошло это после обновления до версии 3.6. Ничего не изменилось и после переустановки системы. Но ставил версию 3.5. Выскакивает табличка с версией и все. Настройки журнала не работают. … что можно сделать?

П.8838, п.9824: RZ1OM:Попробуйте скачать рабочую базу для версии 3.хх и установить на свой лог - http://rm4y.ru ... вроде пока всем помогало

так как сайт Сергея не рабочий, можно попробовать использовать мои файлы

Скачивать здесь


Процесс остановлен ядром базы данных Microsoft Jet...

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Процесс остановлен ядром базы данных Microsoft Jet...

п.11472. Что бы это значило?

При старте процесс запуска программы прерывается вот таким сообщением. И - "самый полный стоп!"

П.11473. RZ1OM: Сначала нужно сделать резервную копию всей программы лога... затем скачать рабочие базы по ссылке - http://rm4y.ru и скопировать файл DB.mdb (и возможно awards.mdb) в папку \UR5EQF_Log 3\db\ ... может быть поможет...

П.11474. UR5EQF: Это говорит, что базы данных уже открыты. Самое логичное Ваше действие перезагрузить компьютер.

ссылка - http://rm4y.ru не рабочая см. здесь (раздел "Где скачать рабочую базу")


Не создается новый журнал…

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Не создается новый журнал...

П.8308: установил версию 3.4 - не хочет создаваться новый журнал:

Введите свои координаты: "Широта", "Долгота" или Локатор.


Программа каждый раз предлагает зарегистрироваться на сайте

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Программа каждый раз предлагает зарегистрироваться на сайте

п.15963. UA9JEC: Цитата:

Программа каждый раз предлагает зарегистрироваться на сайте

Ответ см. здесь (раздел "Регистрация")


В Windows 7 при установке лога Omni.rig выдает ошибку...

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

В Windows 7 при установке лога Omni.rig выдает ошибку...

п.16890. RU4AX: ... установлен вместо Windows XP Windows 7, теперь при установке программы получается вот что:

Что надо сделать?

п.п.16891,16897. RM4Y (ex. RZ1OM):

Ничего не нужно делать... закройте окно и работайте дальше... это сама программа Omni-Rig при инсталляции в Win7 выдает такой фортель... закрываешь окно - все дальше работает нормально, проверено

...Win7 работает лучше и стабильнее, чем WinXP... только лучше использовать 32-х битную версию, меньше гемора с драйверами и совместимостью некоторых программ... за полтора года нет никаких проблем, все замечательно работает...


Запуск программы сильно тормозит

Запуск лога

Запуск программы сильно тормозит

Причины:

1.Не настроен интернет эксплорер IE

2."Медленный" интернет - отключить обновления

3."Разрушена" база лога - восстановить базу - выполнить "сжатие и восстановление базы данных":


Если лог не запускается

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Если лог не запускается

Как вариант, может возникнуть такая ситуация:

п.17079. UX2KA: Загружаю программу, все грузится, потом все выключается. Попробовал пару раз - все так же. Сделал возврат на 3.29.8 - тоже не помогло.

Управление компьютером - Просмотр событий - Код 7000. Сбой при запуске службы "LPT port direct access service" из-за ошибки Системе не удается найти указанный путь.

При закрытии лога никаких сообщений не выдает.

п.17099. UX2KA: Проблема решилась очень просто - заменой моего подпорченного файла awards.mdb на "правильный". Я в программе лога пытался добавить Ю.Судан в списки по DXCC и что-то не то нажал.

1. Самый оптимальный вариант, чтобы не допускать таких проблем, прислушаться к совету Владимира:

п.17104. UR5EQF:. Не воспринимайте как рекламу, но эта утилита UR5EQF_BackUp, как нельзя больше подходит для этого случая.

При использовании ее Вы бы в течении нескольких секунд восстановили бы все настройки и данные в Вашем логе.

2. Если п.1. не выполнять, то в качестве скорой помощи можно использовать файлы Сергея RM4Y:

База данных лога (DB.mdb)

Файл дипломных программ (awards.mdb)

Таблица префиксов (Province.xml, UniqueCalls.xml, CountryDataEx.xml)

Скачивать здесь (раздел "Где скачать рабочую базу")

Следует учесть, что таблицу префиксов можно обновить (перезагрузить) и из интернета

См.ещё (раздел "Процесс остановлен ядром базы данных Microsoft Jet...")


Часть интерфейса лога на русском, все остальное - кракозяблики

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Часть интерфейса лога на русском, все остальное - кракозяблики

Если часть интерфейса лога в самом верху на русском, а все остальное - кракозяблики:

Попробуйте в настройках системы изменить текущий язык на русский:

если не помогло, сделайте ещё раз: Панель управления -> Регион -> Дополнительно -> Язык программ не поддерживающих Юникод.

Измените на Английский, перезагрузитесь, затем верните на Русский и снова перезагрузитесь.

если не помогло, попробуйте изменить в реестре

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage] эти файлы:

на следующие значения:

"1250"="c_1251.nls"

"1251"="c_1251.nls"

"1252"="c_1251.nls"

"1253"="c_1251.nls"

и сделайте ещё раз: Панель управления -> Регион -> Дополнительно -> Язык программ не поддерживающих Юникод.

Измените на Английский, перезагрузитесь, затем верните на Русский и снова перезагрузитесь.

если не помогло: сделать все файлы с_1250, с_1252, ..., с_1255 такими же самыми, как файл С_1251. Для этого можно скопировать файл C_1251 из C:/Windows/system32 на рабочий стол например, удалить файлы с_1250, с_1252, ..., с_1255 (винда не даст это просто так сделать, нужно назначать полные права на эти файлы в свойствах файлов или использовать утилитку Unlocker, что проще), и поочерёдно переименовывать С_1251 в с_1250, потом в с_1252 и т.д., каждый раз после переименования копируя с рабочего стола обратно в C:/Windows/system32. Потом перезагрузка. Если система 64-битная, то данные операции нужно проделать и с такими же файлами в папке C:/Windows/syswow64

и сделайте ещё раз: Панель управления -> Регион -> Дополнительно -> Язык программ не поддерживающих Юникод.

Измените на Английский, перезагрузитесь, затем верните на Русский и снова перезагрузитесь.

Либо ещё раз переустановить систему, желательно, что бы система была лицензионная.


Где скачать рабочую базу для папки DB?

Если возникли проблемы при установке или при работе с логом...

 Top Previous Next

Где скачать рабочую базу для папки DB?

П.8838: RZ1OM: Скачать рабочую базу для версии 3.хх - http://rm4y.ru

в качестве скорой помощи ранее можно было использовать файлы Сергея RM4Y:

·База данных лога (DB.mdb)

·Файл дипломных программ (awards.mdb)

·Таблица префиксов (Province.xml, UniqueCalls.xml, CountryDataEx.xml)

так как сайт Сергея не рабочий, можно попробовать использовать мои файлы

Скачивать здесь


Установка лога без инсталляции

1.Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Установка лога без инсталляции

п.16442. RM4Y (ex: RZ1OM):

Могу предложить еще один вариант - установить программу лога без инсталляции, простым копированием:

Скачайте файл UR5EQF_Log3.rar по этой ссылке - UR5EQF_Log3.rar (около 50 Мб).

Разархивируйте его и папку UR5EQF_Log 3 просто скопируйте в любое место на диске (у меня лог на диске D:, к примеру).

В папке \UR5EQF_Log 3\tmp\ есть два файла реестра - UR5EQF_server_Registry.reg и ur5eqf3_Registry.reg, поочередно запустите их, чтобы добавить информацию в реестр Windows.

Запустите программу лога и в меню "Журнал", "Операции с журналом", "Конфигурация журнала":

измените данные во всех полях на свои.

Лог должен заработать 100%... версия 3.30-8 от 04 декабря 2011года... естественно, это "пустой" лог, но с крайними обновлениями (по 1 мая 11года) справочника позывных, территорий и менеджеров... остается только сделать импорт adif-файла и можно работать.

Сергей RM4Y больше не поддерживает работу своего сайта. Поэтому после установки этой версии нужно сделать обновление лога. См. здесь (раздел “Установка обновления версии (UpDate)”).


Настройка лога

4.Настройка лога

Выбор языка интерфейса лога (interface language)

Основные настройки

Сохранение настроек лога

Сброс настроек лога к первоначальным настройкам *


Выбор языка интерфейса лога (interface language)

Настройка лога

Выбор языка интерфейса лога (interface language)

После первоначальной установки программы UR5EQF_Log - язык интерфейса лога по умолчанию - английский (English).

Выбор языка интерфейса осуществляется в меню "Settings" - "Program settings" - "interface language":

Выбираем, например: "Русский" - прогамма перезагрузится, язык интерфейса обновится. В данной конфигурации логом уже можно пользоваться.


Основные настройки

Настройка лога

Основные настройки

1. Меню "Журнал"

В этом меню можно:

·создать новый журнал

·изменить конфигурацию журнала (в т.ч. ввести пароли для связи лога с внешними ресурсами - eQSL, HRDLog, LotW, QRZ.com, HamQTH, включить автоматическую загрузку QSO на сервисы eQSL и HRDLog)

·настроить связь с LotW для отправки и получения почты с этого сервиса.

·настроить печать некоторых сообщений при печати QSL

2. Меню "Настройки"

В этом меню находятся следующие основные опции по настройке лога:

· "Настройка программы"

- настройка управления трансивером (выбор программы управления ТРХ, настройки САТ-системы и РТТ)

- настройка раскладки клавиатуры и использования клавиши "ENTER"

- настройка управления антенной и других функций

·"Настройка журнала"

- настройка формата записи рабочей частоты

- настройка порядка редактирования полей оперативного окна

"Настройка интерфейса"

- в этой опции настраивается внешний вид интерфейса (цвет, шрифт, скины)

- вывод дополнительных информационных окон при старте программы

- загрузка информации из интернета

·"Установка "Горячих клавиш"

·"Получить информацию из интернета"

(устанавливаются автоматические обновления)

·"Настройка Кластера"

·настройка диапзонов в логе и кластерах (форма "Менеджер диапазонов")

·настройка управления модуляцией (форма "Редактор диапазонов и видов модуляции")

·Настройка конфигурации интерфейса лога (стандартный, нестандартный, многооконный)

·"Внешние программы"

в этой опции осуществляется настройка подключения внешних программ к логу

·другие функции

3. Меню "Просмотр"

В этом меню можно настроить:

·Подключение внутреннего справочника

·Подключение внешних баз позывных

4. Меню "Модули"

В этом меню можно:

·включить Цифровой модуль (опция "Цифровые моды")

·включить модуль "Контест CW-SSB"

5. Меню "Быстрый запуск"

В этом меню можно:

·настроить быстрый запуск других программ


Сохранение настроек лога

Настройка лога

Сохранение настроек лога

Чтобы исключить потерю информации и сохранить настройки журнала следует:

1. Использовать программу резервного копирования UR5EQF_BackUp (полное копирование настроек):

(UR5EQF_Backup v.3 - Программа архивирования и последующего восстановления основных настроек и журналов для аппаратного журнала радиолюбителя UR5EQF_log версий 3.хх.)

скачать утилиту UR5EQF_BackUp v.3

2. Сохранить, например: на флешке, следующие файлы с параметрами конфигурации (только макросы) из корневой папки лога:

ContestMacro - для Contest Модуля

MMVariMacro - для Цифрового модуля

MMVariMacroCATCMD - для Цифрового модуля

MMVariMacroContest - для Цифрового модуля в режиме Contest

MorseMacro - для Цифрового модуля в режиме CW


Сброс настроек лога к первоначальным настройкам

Настройка лога

Сброс настроек лога к первоначальным настройкам

19950: UA9JEC: Цитата:

Есть ли в программе что-то вроде сброса всех настроек на первоначальные?

в каталоге лога есть папка <Reg> в ней два файла с расширением .reg-

их запуск установит настройки лога по умолчанию...

как минимум, 1 файл должен быть...

После запуска reg-файла система сообщит, что:

Жмем "Да" и имеем следующее сообщение:

Жмем "ОК" - настройки лога сбросятся к первоначальным.


additionally

Enter topic text here.


"Территория (Страна)"

Меню "Настройки"

"Территория (Страна)"

Меню "Настройки" - "Территория (Страна)"

С помощью этой опции можно:

1. Вызвать "Менеджер базы префиксов"

2. Сохранить в файл "...\.zip" содержимое таблиц Менеджера базы префиксов


"Менеджер базы префиксов"

"Территория (Страна)"

"Менеджер базы префиксов"

Меню "Настройки" - "Территория (Страна)" - "Менеджер базы префиксов":

Процедура определения территории корреспондента осуществляется с учетом даты проведения QSO.

Таблица, для определения состоит из трех частей:

· Уникальные позывные – в большинстве случае это позывные экспедиций.

· Административные территории – деление на провинции (области).

· Территории (Страны).

Определение территорий производится в следующем порядке:

Уникальные позывные, если не определили, то Административные территории, если не определили, то – Территории (Страны).

Данная система позволяет определить территории, для всех, когда-либо существовавших позывных, например: что до распада СССР, что сейчас.

Эти таблицы синхронизируются через Интернет, для этого должен быть установлен флаг "Территории (Страны)" в форме "Получить информацию из интернета".

Для «правильного» определения территорий нужно соблюдать правила:

* У префиксов, действующих на сегодняшний день, не должно быть ни даты старта, ни даты окончания.

* Дата окончания действия обязательно должна быть у «старых» префиксов.

* Дата старта у «старых» префиксов может быть, а может и не быть.

"Кнопки для редактирования"

"Кнопки для связи с WEB сайтами"

"Обновить файл Cty.dat из интернета"


"Кнопки для редактирования"

Менеджер базы префиксов

Кнопки для редактирования:

1.Таблица "Уникальные позывные"

Редактирование можно осуществлять с помощью кнопок :

или можно вызвать вызвать меню для редактирования кликом правой кнопки мышки по строке формы:

Форма для редактирования:

2. Таблица "Территория (Страна):

Запись редактируется по кнопке "Изменить" либо вызывается меню кликом правой мышки (опция "Изменить"), откроется форма "Edit":

В этой форме можно осуществить необходимые корректировки. В среднем окне формы можно изменить

или добавить префиксы. В информационном окне приведены примеры и расшифровка записей среднего

окна формы.

Например: P[P-Y][1-9].* эта запись обозначает, что в префиксе Бразилии, начинающемся с литеры P в комбинации с ней могут быть литеры от P до Y в алфавитной последовательности. Во всех комбинациях

этих префиксов могут использоваться цифры от 1 до 9.

.* - обозначает, что после префикса могут использоваться любые цифры или буквы. Может быть и такой вариант - PR1AA2B - этот "позывной" будет определяться как Бразилия.

Если выделить строку и кликнуть по ней правой кнопкой мышки - появится выпадающее меню, в котором

можно выбрать необходимый вид действия:

Выбрав "Изменить" или "Добавить" - откроется форма "Input Box":

В поле "Prompt" можно откорректировать существующую запись или добавить новую. Например: добавить,

жмем ОК, запись добавлена:


"Кнопки для связи с WEB сайтами"

Менеджер базы префиксов

Кнопки для связи с WEB сайтами

кнопки со значком [image] предназначены для связи с соответствующими WEB-сайтами:

1 - Club Log

2 - Contest Country File Revision History

3 - The Daily DX & The Weekly DX - DXpedition Calendar (http://www.dailydx.com/calendar.html)

на этих сайтах можно найти необходимую информацию для ведения "Менеджера базы префиксов".


"Обновить файл Cty.dat из интернета"

Менеджер базы префиксов

Обновить файл Cty.dat из интернета

Обновить или загрузить файл Cty.dat в лог можно используя эту кнопку - [image] "Менеджера базы префиксов". Откроется форма "Get info from CTY.dat" - далее кликаем по значку "закрытая папка":

Файл cty.dat - это текстовый файл со списком стран и направлений азимута.

Используется в качестве дополнительной или контрольной информации при ведении менеджера базы префиксов. В инсталляционный пакет лога не входит.

Загрузить или обновить файл cty.dat можно по значку "закрытая папка" в форме "Get info from CTY.dat".

Всегда "свежий" cty.dat можно скачать и отсюда.. Затем поместить его в каталог лога.


Сохранить в файл "...\.zip"

"Территория (Страна)"

Сохранить в файл "...\.zip"

Меню "Настройки" - "Территория (Страна)" - "Менеджер базы префиксов":

Сохраненный файл countrylist.zip будет находиться в папке db каталога лога.

Форма для записи на FTP-Server - служебная, её закрываем не используя:


Копирование лога на другой диск

Обеспечение сохранности информации в логе

Копирование лога на другой диск

1. Можно скопировать всю папку с логом на другой диск, например, в корень диска: D:\UR5EQF_LOG3\ ... все будет работать 100%...

2. Можно скопировать программу лога на флешку:

Но на другом компьютере копия на флешке не запуститься, так как при инсталляции в каталог "\WINDOWS\system32\" записываются файлы MMVARI.ocx и ModCalcDll.dll, эти файлы должны быть зарегистрированы в системе. Без первого не будет работать цифровой модуль, без второго определение расстояний и прочее.

На компьютер, на который вы будете переносить данные, лог обязательно должен быть инсталлирован.

3.Скопировать лог с компьютера на компьютер можно с помощью утилиты резервного копирования.


"Проверить наличие обновлений"

Меню "Инфо"

Опция "Проверить наличие обновлений":

!Новых версий программы нет!

В ручном режиме проверка обновлений программы лога осуществляется двумя способами:

·Проверить обновление можно из программы (Меню "Инфо" - "Проверить обновление программы"):

При выборе этой опции:

- если нет обновлений появится сообщение:

- если есть обновление:

программа лога закрывается и вызывается диалоговое окно:

которе сообщает, что найдена новая версия и предлагает загрузку. Нажимаем клавишу "Yes":

далее проверка и установка обновления осуществляется аналогично проверке обновления в автоматическом режиме.

·Для проверки обновления так же можно запустить файл: "UR5EQF_updater.exe " в каталоге лога.

Процедура проверки аналогична проверке обновления в автоматическом режиме.


Автоматический поиск обновления версий

Меню "Инфо"

Автоматический поиск обновления версий - (в настоящее время поиск обновлений Лога не осуществляется, ввиду их отсутствия).

·В логе реализована функция автоматического обновления версий (для этого в Меню "Настройки" - "Получить информацию из интернета" необходимо установить флаг "Проверка обновления лога"):

Программа анализирует на сайте UR5EQF.COM наличие новых версий, если появилась новая версия, то при запуске лога выводится сообщение:

Далее нажимаем на кнопку "YES".
При этом программа лога закроется, а на экран монитора будет выведено сообщение
"Проверить обновление":

Нажать на кнопку "Проверить обновление", в открывшемся окне проверяем дату и номер версии ("Found version'"):

Если дата и номер найденной версии не отличаются от существующей, то выходим из процесса обновления нажав на кнопку [image] , если найдена новая версия, жмем на кнопку "Download? (Загрузить)". Начнется процесс загрузки файла обновления в ваш компьютер в папку лога tempUpdate:

После завершения загрузки выводится следующее сообщение:

После нажатия на кнопку "Install? (Установить)" выодится окно выбра языка интерфейса:

т.е. осуществляется процедура обновления установленной ранее версии.

Обновление можно установить по кнопке "Скачать" (форма "Получить информацию из интернета"):

Если обновления отсутствуют, выводится информационное сообщение:


Форма «Редактор QSO»

Выпадающее меню (окно "Журнал")

 Top Previous Next

Форма «Редактор QSO»

Форма "Редактор QSO" может вызываться из Главного меню: меню "Журнал" - "Редактировать QSO" или из выпадающего меню окна "Журнал":

Содержимое любой ячейки журнала можно откорректировать с помощью этой формы "Редактор QSO"


Интерфейс журнала UR5EQF_LOG или основное окно лога

 Top Previous

По умолчанию, после установки лога, загружается интерфейс журнала UR5EQF_LOG (основное окно) в следующей конфигурации (не стандартный интерфейс):


Отображение инфы о LOTW users

Окно «Карта мира»

 Top

2. Отображение инфы о LOTW users

П.8897: … внести опцию отображения LOTW users. Подсветка позывного или индикатор какой…

П.8898: Все это и многое другое отображается в окне карты, инфо берется из friends.ini,
редактируете, вносите свое, соблюдая синтаксис...

п.12329. RZ1OM: Цитата:

В прикрепленном файле список LoTW user по состоянию на 31.01.2010

В этом файле после каждого позывного - дата крайней загрузки лога на LoTW, а не дата регистрации... похоже, данные не совсем свежие, только за 31 января 2010 г... ИМХО, нет необходимости в этих датах, лишняя инфо в файле, быстро устаревает... вариант без этих дат ниже, можно скопировать данные и вставить в файл friends.ini... данные на 9 марта, 32475 позывных из 331 страны:

LoTW.rar (81.0 Кб)