ЛОКАЛЬНАЯ СЕТЬ

 Top Next

Введите здесь текст раздела.


Работа в локальной сети

 Top Previous

Работа в локальной сети

Top Previous Next

В программе предусмотрено ведение одного общего лога одновременно на нескольких компьютерах, подключенных к локальной сети. Этот режим очень удобен для работы в экспедициях с нескольких рабочих мест или в соревнованиях на коллективной радиостанции. При сохранении QSO на любом из компьютеров эта связь сохраняется на всех компьютерах, то есть ведется один общий лог. Еще одно преимущество такого режима - резервирование текущего аппаратного журнала, кратное числу компьютеров, подключенных в локальную сеть.

При удалении ошибочно введенной связи или группы связей их можно удалить из лога, при этом эта связь или группа связей также удаляется из других логов.

Сетевым адаптерам на каждом компьютере желательно присвоить статические IP-адреса, например, 192.168.0.1, 192.168.0.2 и т.д., маска подсети - 255.255.255.0.

Настройки сервера

Для включения сетевого режима на одном из компьютеров в сети запустите файл UR5EQF_server.exe из папки программы лога. Этот компьютер будет "сервером", то есть главным компьютером в сети.

Откроется окно, разделенное на три части: слева - "Active connect:", справа - "Working Stations:" и внизу - окно с информацией о подключениях:

В окне "Active connect:" выводятся имена находящихся в сети компьютеров, подключенных к серверу через LAN Client.

Чтобы активировать пользователя для совместной работы в программе лога, кликните кнопкой мышкой по выбранному названию компьютера, затем по верхнему значку стрелки [image] . Имя компьютера из окна "Active connect:" переместится в правое окно "Working Stations:" и этому пользователю будет доступна функция сохранения связей в общем логе.

Доступ к общему логу можно дать сразу всем подключенным пользователям, если кликнуть кнопкой мышки по стрелке [image] .

Таким же образом можно "деактивировать" пользователя, если выделить имя компьютера в правой части окна и кликнуть мышкой по значку стрелки [image] .

Настройки компьютеров

На всех компьютерах, в том числе и на сервере, в программе лога в меню "Установки", "Multi-User" поставьте галочку напротив пунктов "Multi-User Mode" и "Show connections".

На компьютере, который является "сервером", в окне "LAN Client" введите имя "LocalHost" (как показано ниже на левом скриншоте). Номер порта "5879" изменять не нужно.

На остальных компьютерах в окне "LAN Client" введите имя или IP-адрес сервера (выше на правом скриншоте). Например, в нашем случае IP-адрес сервера - "192.168.0.2".

Чтобы подключиться к серверу - нажмите на значок [image] . При успешном подключении в нижнем окне будет выведено сообщение:

Connection to (имя сервера или IP-адрес):5879

Connected.

Чтобы отключиться от сервера - еще раз нажмите на значок [image] .

Копирование связей по сети в общий лог

Предположим, возникла проблема с локальной сетью и нет связи с одним или несколькими компьютерами в сети. В этом случае можно отключиться от сети и продолжать работать и сохранять QSO в автономном режиме. Как только проблемы с сетью будут устранены, нужно скопировать связи в общий лог.

•

выделите группу связей или все связи в логе;

•

кликните правой кнопкой мышки по выделенным связям;

•

выберите в меню "Send to LAN".

Эти QSO будут скопированы в общий лог на все компьютеры, подключенные к сети и активированные на сервере в окне "Working Stations".

Старайтесь не копировать слишком большое количество связей одновременно. В программе установлено ограничение на синхронизацию примерно до тысячи QSO за один раз, это сделано для стабильной работы программы в сети. Если требуется перенести в другие логи очень большое количество связей, то лучше всего воспользоваться функцией экспорта/импорта файла формата ADIF.

Передача сообщений по локальной сети

Через программу лога можно обмениваться короткими сообщениями в сети, если компьютеры расположены в разных помещениях.

•

Введите сообщение в окно, как показано выше на правом скриншоте;

•

Нажмите клавиши CTRL + Enter или на значок [image] , сообщение будет отправлено всем пользователям в сети;

•

Пример принятого сообщения в нижнем окне на левом скриншоте;

•

Если установлена галочка в поле "Automatically to clear the window of message", то после отправки сообщения оно автоматически стирается.