Базы данных лога (состав и настройки)

 Top Next

Очередность поиска данных в базах лога

Внутренний справочник

Внешние базы позывных

Папки МAPS и Image (фотографии)

База QSL-менеджеров

Файлы friends.ini

LotW Users

eQSL Users

Карты мира (глобус), стран и территорий

Поиск информации в базах данных лога

Видеофайл - работа лога с внешними и внутренними базами - скачать


Очередность поиска данных в базах лога

Базы данных лога (состав и настройки)

 Top Previous Next

Очередность поиска данных в базах лога

Поиск данных работает с такой очередностью, пока не найдет:

1. Поиск в журнале (высший приоритет)

2. Поиск во внутреннем справочнике

3. QRZ_CD-ROM

4. RAC_CD

5. Справочники, созданные программой "CallBook Migration"

6. vf_softRAC

Алгоритм поиска данных построен следующим образом:

После ввода в поле "Позывной" CALL корреспондента, если программа лога находит в журнале либо в одном из перечисленных справочников, аналогичный позывной, а у него не заполнены какие-либо информационные поля (QTH, Name, Loc, State и т.д.), то программа продолжает поиск недостающей информации в других подключенных справочниках, в указанной выше последовательности.

При использовании всех внешних справочников, следует учесть такой момент:

т.к. кроме "VF-Soft Radio Amateur Callbook", информация по другим справочникам не обновляется, то данные в этих справочниках могут не соответствовать данным базы "VF-Soft Radio Amateur Callbook". Поэтому на форме "Внешние базы позывных" желательно снять все галочки, кроме "VF-Soft Radio Amateur Callbook".


База данных "Внутренний справочник"

Базы данных лога (состав и настройки)

 Top Previous Next

База данных "Внутренний справочник"

База данных "Внутренний справочник" находится в каталоге лога в папке db - файл DB.mdb. Если открыть файл DB.mdb с помощью ACCESS - это таблица Callbook.

Форма "Внутренний справочник" вызывается из главного Меню "Просмотр" - "Внутренний справочник" - "Внутренний справочник"(опция)

Ранее в инсталляционный пакет лога включался внутренний справочник, содержащий около 90 000 записей, периодически Сергей RM4Y (ex. RZ1OM) дополнял и обновлял его. Но в последствии автором лога было принято решение не включать в инсталляционный пакет лога внутренний справочник, поэтому после установки полной версии лога, он "пустой".

!!Теперь каждый сам, во время работы с логом дополняет и изменяет содержимое внутреннего справочника!!

П.8971: RZ1OM: в принципе, базу внутреннего справочника пополняет каждый пользователь, сохраняя QSO... если нет И-нета - тогда в комментарии можно вводить врукопашную услышанную инфо из эфира... с И-нетом проще - скопировал данные из окна поиска в интернете и пользуйся... и еще, пользователь должен заботится о точной и своевременной информации о себе на QRZ.COM, QRZ.RU и других базах... если сам не знает - пусть попросит знающих людей... тогда не будет путаницы и вся инфо будет, как на ладони... конечно, если есть Инет...

После каждой проведенной связи информация о корреспонденте, одновременно с записью ее в аппаратный журнал, записывается и во внутренний справочник.

Так же во внутренний справочник можно ввести информацию о корреспонденте (имя, QTH и другую информацию) без записи ее в аппаратный журнал.

Предположим, Вы услышали корреспондента, ввели все его данные, но связь не состоялась по каким-то причинам. Эти данные можно сохранить во внутреннем справочнике, кликнув левой кнопкой мышки по значку "коричневой дискеты" [image] в окне ввода позывного. В следующий раз, когда Вы введете этот позывной, вся ранее сохраненная информация о корреспонденте будет выведена из внутреннего справочника и будет отображаться в соответствующих полях.

Так же можно зайти в редактирование внутреннего справочника и там сделать нужные изменения...

меню "Просмотр", "Внутренний справочник", "Внутренний справочник"(опция)... затем введите нужный позывной в поле "Поиск", а в ниже расположенных полях, можно отредактировать всю информацию о данном позывном... только аккуратно, не нажмите ничего лишнего, т.к. при выходе из этого окна все изменения сохраняются...

Внутренний справочник лога из интернета не обновляется!

Внутренний справочник можно обновить непосредственно из аппаратного журнала.

См.ещё


Обновление базы данных "Внутренний справочник"

База данных "Внутренний справочник"

 Top Previous Next

Обновление базы данных "Внутренний справочник"

При сохранении QSO в аппаратный журнал информация о позывном, имени и QTH сохраняется во внутреннем справочнике позывных.

Можно иметь сколько угодно созданных аппаратных журналов в программе, но данные из них будут сохраняться в одном общем справочнике.

При вводе позывного в лог, если он уже есть в этом справочнике, автоматически заполняются поля "Имя"," QTH", "QSL via", QTH-локатора, Штата. Это повышает оперативность работы, ускоряет и облегчает процесс ввода данных в лог.

Рекомендуется после импорта аппаратного журнала сделать обновление внутреннего справочника позывных:

·в меню "Просмотр", "Внутренние справочники" выберите "Обновить внутренний справочник позывных из текущего журнала".

·внизу основного окна лога появится индикатор процесса обновления. Обновление может занять достаточно большое время, в зависимости от количества связей в текущем журнале и от производительности компьютера.

Индикатор выполнения процесса:

·данные из нового лога будут экспортированы во внутренний справочник позывных. Тогда и при работе с другими журналами, даже если этого позывного не было в текущем логе, при вводе позывного поля "Имя", "QTH" (и др.) будут заполнены информацией из этого справочника.

После импорта нового аппаратного журнала можно заполнить поля "Имя" (Name), "QTH", "Штат" (State), Менжеджер" (QSL via) и "Локатор" (Grid) в этом логе из внутреннего справочника позывных, для наиболее точного отражения статистики по дипломам:

·в меню "Журнал", "Операции с журналом" выберите опцию "Обновить ЛОГ из внутреннего справочника" из внутреннего справочника".

·в открывшемся окне поставьте галочки напротив тех полей (поля "Name", "QTH", "Stste", "QSL via" и "Grid"), которые Вы хотите заполнить в логе:

·нажмите ОК и дождитесь обновления данных в журнале (Cancel - прервать процесс):

Индикатор процесса:

обновление полей "Имя, QTH и т.д." может пригодится при импорте данных из других логов, где эта информация может отсутствовать...

По этой опции имеющаяся информация из внутреннего справочника переносится в текущий лог в соответствующие пустые (не заполненные) поля "Name", "QTH", "Stste", "QSL via" и "Grid".

Обновить информацию во внутреннем справочнике можно и в ручном режиме ввода.


Внешние базы позывных

Базы данных лога (состав и настройки)

 Top Previous Next

Внешние базы позывных

Платформа "Внешние базы позывных" вызывается из главного Меню "Просмотр" - "Внешние базы позывных"

Поиск и заполнение информационных полей окна QSO (после ввода позывного) из подключенных внешних баз осуществляется автоматически.

* Обновить внешние справочники из интернета

Подключение внешних баз

Вопросы по "Внешним базам позывных"


Обновить внешние справочники из интернета

Внешние базы позывных

Обновить внешние справочники из интернета

С помощью формы, вызываемой из Меню "Настройки" - "Получить информацию из интернета" можно скачать только один внешний справочник (Callbook, 18,5 Mb),если он отсутствует в директории лога. До недавнего времени этот файл был доступен для скачки на сайте UR5EQF.RU, но так как этот справочник никто не обновляет и информация в нем по этой причине не совсем достоверна, то этот файл был удален. Таким образом ставить проверку автообновления "Внешние базы позывных" нет смысла:

Для закачки нужно нажать кнопку "Скачать".

Внешний справочник будет размещен в директории лога - папка "Callbook":

В состав Callbook входят три справочника, созданных программой CallBookMigration:

- part1 - part3

- RAC

- RIC

Файлы из папки Callbook с расширением .dat будут отображаться в окне формы "Внешние базы позывных" (дата справа от файла - дата закачки с сервера):

При необходимости файл Callbook можно скачать здесь.

Как подключить справочник RIC.DAT.


Подключение внешних баз

Внешние базы позывных

Подключение внешних баз

Подключение внешних баз на CD-ROM или на жестком диске осуществляется из Меню "Просмотр", "Внешние базы позывных".

С помощью данной опции можно подключать следующие справочники (базы данных позывных):

База от RW6HS "VF-Soft Radio Amateur Callbook"

База QRZ CD-ROM

База "Radio Amateur Callbook"

Базы позывных, созданные программой CallBook Migration


База от RW6HS "VF-Soft Radio Amateur Callbook"

Содержит более 150 тыс. позывных России, СНГ и DX.
Эту базу можно приобрести у Василия RW6HS (об условиях приобретения можно прочитать на сайте Василия).

При инсталляции этой программы устанавливаются все необходимые компоненты для работы базы ("галка слетать" не будет!).

· в блоке "Callbooks [rw6hs@narod.ru]" установите флаг "VF-Soft Radio Amateur Callbook";

· укажите путь к базе на жестком диске:

Инструкция по инсталляции базы поставляется Василием вместе с базой.

Преимущества использования этой базы:

- постоянное обновление (для этого нужно оформить бесплатное получение на установку программы колбука VF-SOFT RAC и получение ежемесячного обновления у Василия RW6HS).

- можно самостоятельно добавлять новые позывные в базу.

Недостаток:

- колбук VF-SOFT RAC платный.


База QRZ CD-ROM

Подключение внешних баз

База QRZ CD-ROM

· устанавливается на любой диск в корневой раздел в созданную папку с названием callbk, например, D:\callbk\;

· в окне Callbooks" установите галочку в поле QRZ CD-ROM:

Диск, на который скопирована база, выбирается автоматически.


База "Radio Amateur Callbook"

Подключение внешних баз

База "Radio Amateur Callbook"

· базу RAC-2012 года (351 Мб, одним архивом) можно скачать по этой ссылке - http://knigi.tr200.net/v.php?id=1931498, на 19 июля 2016 года ссылка рабочая.

После разархивирования (разархивация производится дважды с помощью WinRar - т.к. скачаный заархивированный файл - образ диска):

· поставьте галочку в поле RAC CD, укажите путь к базе (на CD-диске или на жестком диске) с помощью иконки "открытая папка", например:

· кликните мышкой по кнопке "Тест";

Если база подключена правильно, Вы увидите сообщение:


Базы позывных, созданные программой CallBook Migration.

Подключение внешних баз

Базы позывных, созданные программой CallBook Migration

Подключение справочника, созданного программой "CallBook Migration" (файл с расширением .dat) рассмотрим на примере базы RIC:

Для подключения справочника, необходимо осуществить следующие действия:

1.Открыть форму "Внешние базы позывных":

2. Нажать кнопку "Добавить"

По этой кнопке вызывается следующая форма:

3. Кликаем мышкой по значку "Открытая папка" и с помощью формы "Список":

в поле "Callbook" прописываем путь к файлу RIC.DAT :

Поля Title и Callbook заполняться автоматически.

4. Нажимаем ОК, файл RIC.DAT будет внесен в левое окно формы "Внешние базы позывных":

Для того, чтобы программа лога могла обращаться к этим файлам, должен быть установлен флаг "Справочники, созданные программой "CallBook Migration".

Программа лога осуществляет поиск информации в подключенных файлах от верхнего к нижнему.

Расположение файлов в окне можно менять, перетаскивая их с помощью левой клавиши мышки:

Если нужно временно отключить какой-либо файл, не удаляя его, используем клавишу "Изменить" - в поле "Callbook" изменяем, например: имя жесткого диска.


Как подключить базу RIC

Внешние базы позывных

База позывных RIC

Russian Internet Callbook (RIC) - компьютерная версия. Всего в базе 63868 позывных. Колбук включает позывные радиолюбителей России и стран СНГ, содержит данные RDA "районов" России. База колбука для индивидуального использования пополняется еженедельно из Интернет-базы и всегда доступна для загрузки на сайте ric.cqham.ru.

Скачать:

База данных RIC - ric.zip 2.2mb (База данных RIC обновляется каждое воскресенье в 04:30 утра)

Разархивированный файл из формата DBF нужно преобразовать в формат DAT с помощью программы CallBook Migration.

Полученный файл RIC.DAT можно подключить используя опцию "Внешние базы позывных".

К логу можно подключить любой справочник, преобразованный в формат DAT с помощью программы CallBook Migration.


Программа "CallBook Migration"

Подключение внешних баз

Программа "CallBook Migration"

Справочники, созданные программой "CallBook Migration"

Любой справочник, с помощью программы CallBook Migration, можно преобразовать в формат, "понятный" для UR5EQF_log-а и соответственно его подключить (с помощью программы создается файл с расширением .dat).

Для чего нужна эта программа? Если Вы хотите что бы Ваш справочник позывных был не зависим от какой либо базы данных, вы можете с помощью этого инструмента перенести существующий справочник позывных с нескольких форматов баз данных в универсальную текстовую базу данных позывных (dbtext).

Справочник в текстовом формате не использует специальные средства для доступа такие как Borland Database Engine (BDE). База данных dbtext имеет компактный и понятный вид, данные представлены в текстовом виде, поля разделены запятыми. Благодаря индексации в dbtext поиск работает очень быстро, даже на больших базах данных 100-300 Мб. поиск нужного позывного займет меньше секунды (в зависимости от аппаратного уровня вашего компьютера).

Программа представляет собой модуль в виде подключаемой библиотеки (DLL) для работы со справочником в текстовом виде.

Скачать программу CallBook Migration

Программа CallBook Migration предполагает использование ключа. Сайт программы прекратил её поддержку несколько лет назад. Получить ключ негде.

В принципе программа работает и без ключа, но не корректно.


Вопросы по "Внешним базам позывных"

Внешние базы позывных

Вопросы по "Внешним базам позывных"

При вводе позывного вместо имени отображается QTH

Вместо имени в поле "Имя" заносится часть адреса

При вводе позывного в окне "имя"- появляются какие-то цифры, а в окне "QTH"- собственно имя.

Где можно cкачать внешние базы

Вопросы по базе QRZ CD-ROM


При вводе позывного вместо имени отображается QTH

Вопросы по "Внешним базам позывных"

При вводе позывного вместо имени отображается QTH

п.18002.RK3DWW: Скачал базу с адреса //rm4y.ru/ (как написано в Хелпе). Там три части, все три присоединил (тоже описано в хелпе).

После этого при вводе позывного вместо имени отображается QTH.

Например, при вводе RU3ARJ или RV3DGG ..

п.18003. RM4Y (ex. RZ1OM): Как вариант - отключите эту базу ... ее составлял не я, все претензии к тем, кто вводил данные... я лишь собрал все данные в одной базе... а если в полутора миллионов позывных искать такие "заморочки", то поверьте, жизни не хватит ...

Вариант гораздо лучше - измените данные в полях "Имя" и "QTH" на нужные, затем просто сохраните их во внутреннем справочнике лога... нажмите на значок "коричневой дискеты" в меню (6-й значок слева), связь в лог записана не будет, а данные будут внесены в базу... при повторном вводе этого позывного имя и QTH будут правильные... то же самое произойдет, если Вы сохраните QSO в лог...

См. ещё


Вместо имени в поле "Имя" заносится часть адреса

Вопросы по "Внешним базам позывных"

Вместо имени в поле "Имя" заносится часть адреса

п.16562, п.17230

Цитата:

Данные стали выбираться странно. Частенько вместо имени заносится кусок адреса.

.

Такая ситуация возникает при поиске информации в справочниках, созданных программой "CallBook Migration", например:

Эта ошибка подтягивается из справочника part2:

Выход - или удалить этот раздел справочника (part2.dat) по кнопке "Удалить" или в поле "Callbook" указать несуществующий адрес, например: "callbook_NEW1" (данное окно вызывается по кнопке "Изменить"):


При вводе позывного в окне "имя"- появляются какие-то цифры, а в окне "QTH"- собственно имя.

Вопросы по "Внешним базам позывных"

При вводе позывного в окне "имя"- появляются какие-то цифры, а в окне "QTH"- собственно имя

п.10980. п. 11539 UR5EQF: Цитата:

У меня что-то случилось с базой позывных и теперь при вводе позывного в окне "имя"- появляются какие-то цифры, а в окне "QTH"- собственно имя.

У Вас справочник QRZ CD-ROM.
Вы должны установить Флаг "QRZ CD-ROM",а вместо этого добавили в перечень справочников созданных программой....... Уберите его из этого перечня.


Где можно скачать внешние базы

Внешние базы позывных

Где можно скачать внешние базы

Базы, доступные для закачки:

- Russian Internet Callbook (RIC) на сайте RIC.CQHAM.RU

Name: ric.zip

Size: 2.2 mb.

(База данных RIC обновляется каждое воскресенье в 04:30 утра)

Download file: ric.zip

Подключить базу RIC

- Radio Amateur Callbook Winter 2012:

база RAC-2012 года (351 Мб, одним архивом)

скачать

Подключить базу RAC

- Внешний справочник "Callbook", созданный программой "CallBook Migration" :

файл Callbook можно скачать здесь (23.8Мб)

Подключить базу Callbook


Вопросы по базе QRZ CD-ROM

Вопросы по "Внешним базам позывных"

База QRZ CD-ROM

Ранее была доступна для скачивания на сайте QRZ.RU (файловый архив).

База QRZ CD-ROM... она должна быть только в определенном месте. Каком?

Не нашел возможности обращения к базе данных позывных находящихся на жестком диске компа


База QRZ.COM... она должна быть только в определенном месте. Каком?

База QRZ CD-ROM

База QRZ CD-ROM... она должна быть только в определенном месте. Каком?

База QRZ CD-ROM... может располагаться на любом диске.


Не нашел возможности обращения к базе данных позывных находящихся на жестком диске компа

База QRZ CD-ROM

Не нашел возможности обращения к базе данных позывных находящихся на жестком диске компа

Не нашел возможности обращения к базе данных позывных находящихся на жестком диске компа. Все сделано только для CD?

База QRZ CD-ROM должна находится в папке callbk в корневом каталоге любого диска... программа лога сама найдет к ней путь... нужно только поставить "галочку" в меню подключения внешнего справочника позывных...


Папки МAPS и Image (фотографии)

Базы данных лога (состав и настройки)

 Top Previous Next

Папки МAPS и Image (фотографии)

Папка "MAPS"

Папка "Image" (фотографии)


Папка "MAPS"

Папки МAPS и Image (фотографии)

 Top Previous Next

Папка "MAPS"

Карты не входят в пакет инсталляции, их нужно устанавливать самостоятельно.

Файл с радиолюбительскими картами можно скачать на Сайте поддержки UR5EQF Log.

Затем распаковать архив и поместить папку Maps в каталог лога.

Если нажать на кнопку "Показать эту территорию на карте", то при наличии в папке карты данной территории, она будет выведена в отдельное окно:

Лог ищет карты, где имя файла представляет собой префикс или префикс+суффикс, и с расширением *.gif(jpg). Например: для позывного RV9UAF лог ищет файл с именем ua9u.gif(jpg) или ua9.gif(jpg), в данном примере - ua9u.jpg (название файла можно увидеть слева вверхней части окна).

Если лог не может найти карту, то лог сообщает, какой файл он ищет:

Для позывного RV9UAF он ищет файл с именем ua9u.gif(jpg) или ua9.gif(jpg).

В папку Maps карты можно добавлять или изменять самостоятельно.


Папка "Image" (фотографии)

Папки МAPS и Image (фотографии)

 Top Previous Next

Папка "Image" (фотографии)

Папка "Image" (фотографии) - находится в каталоге лога, адрес папки прописывется в адресном поле справа от значка "открытая папка" в "Окне поиска информации о позывном в интернете":

Папка "Image" (фотографии) можно размещать на любом диске. Название папки ,при желании, можно изменить

Если в этом поле указать несуществующий путь к фотографиям, то они не будут показываться.

Формат фотографии

Для размещения фото на сайтах QRZ.RU, QRZ.COM...

Лучше всего, если размер фотографии будет примерно 400х300 пикселей (точек), тогда она точно поместится в размер окна...

Главное, чтобы файлы были в формате JPG, чтобы имя файла совпадало с позывным и было введено строчными буквами...

Процедура обновления базы фото

При вводе любого позывного или при появлении спота в telnet-кластере, когда открыто "Окно поиска информации о позывном в интернете", будет производиться поиск фотографий... сначала фотография ищется в базе на компьютере, а если ее там нет, тогда в базах QRZ.COM, QRZ.RU и т.д., и она сохраняется в указанной папке на компьютере... таким образом база постоянно пополняется...

В эту базу так же можно копировать любые файлы фотографий знакомых радиолюбителей (соблюдая вышеуказанный формат), если их нет на QRZ.COM...

Если на QRZ.COM... кто-то обновил фотку, то обновить ее можно, нажав кнопку поиска... иначе будет выводиться "старая" фотография, которая уже есть в базе на своем компьютере... а если фото в этой базе нет, то она скачивается с QRZ.COM в эту базу... так что база постоянно пополняется...

Так же в интернете можно скачать базы фотографий для пополнения собственной базы.

Вопросы по разделу "Папка "Image" (фотографии)"

Почему не выводится фотография?

Почему нестандартное фото полностью не загружается?


Папка "Image" (фотографии)

Почему не выводится фотография?

в имени файла должны быть строчные (маленькие) буквы, а сам файл фотографии должен иметь формат JPG...

9865. UA4PCA: Попробую пояснить ситуацию с выводом фотографий. Берем спот из кластера:
Смотрим на qrz.com:
Теперь попробуем кликнуть на фото правой кнопкой и сохранить изображение на диск:
Видим, что файл называется PB160291_1.jpg, т.е. название файла картинки не совпадает с позывным:

А если бы человек загрузил на qrz.com это фото под именем ua0zeo.jpg, ЛОГ бы ее показал.

На QRZ.com фотография может быть показана вне зависимости от ее названия, при вводе позывного идет обращение к базе данных, а так написано название картинки.
Из программы нет возможности обратиться к этой базе, этот сервис платный - $19, единственное, предполагаем, что название картинки совпадает с позывным, если это так, программа показывает картинку, более чем в 90% так и есть.


Почему нестандартное фото полностью не загружается?

Папка "Image" (фотографии)

 Top Previous Next

Почему нестандартное фото полностью не загружается?

п.10328. UR5EQF: Цитата:

НЕСТАНДАРТНОЕ фото не загрузится.

Размеры форм выбраны не случайно.
Высота, исходя из разрешения монитора, у большинства пользователей 1024*768

Ширина, исходя и разрешения монитора 1440*900 у кого такой есть, тогда форму с информацией о позывном можно разместить справа

Исследовав размеры фотографий на серверах, qrz.com, qrz.ru, cqham.ru, именно с этих серверов закачиваются фотографии, пришел к выводу, что большинство фотографий подходят под этот формат. А чьи не подходят - значит им не повезло.


База QSL-менеджеров

Базы данных лога (состав и настройки)

 Top Previous Next

База QSL-менеджеров

Меню "Настройки" - "База QSL менеджеров" - откроется форма "QSL Manager".

Сама База QSL-менеджеров находится в папке db - файл DB.mdb - таблица amgr. Информация в базе QSL-менеджеров может обновляться:

·автоматически из интернета

·самостоятельно


Обновление баз QSL-менеджеров из Интернета

База QSL-менеджеров

Обновление баз QSL-менеджеров из Интернета

как обновляться:

Для автоматического обновления всей базы при запуске программы лога поставьте галочку "QSL Менеджеры" в форме "Автопроверка обновления" (вызывается из Меню "Настройки" - "Получить информацию из интернета"), а так же установить галочку "Автозагрузка" (форма обновления менеджеров - скрин ниже)

Для ручного обновления базы менеджеров из интернета нужно зайти в форму "Автопроверка обновления" (вызывается из Меню "Настройки" - "Получить информацию из интернета") и нажать кнопку "Скачать" справа от надписи "QSL Менеджеры", появиться форма:

Жмем кнопку "Update the Manager...", после закачки из интернета появится индикатор импорта обновления в лог:

Файл будет импортирован в базу QSL-менеджеров.

Разархивированный файл из managerlist.zip - managerlist.xml сохраняется в папке db.


Файлы friends.ini

Базы данных лога (состав и настройки)

 Top Previous Next

Файлы friends.ini

Файл friends.ini не входит в инсталяционный пакет лога.

Файл friends.ini после разархивации устанавливается в корневой каталог программы UR5EQF_log.

Если по введенному позывному в файле friends.ini имеется информация, она может выводится в верхнем левом углу окна "Карта мира" или на глобусе в цифровом модуле:

Для вывода информации необходимо установить флаг в меню "Настройки" - "Загрузить информацию из файла "Friends.ini":

Цвет прозрачной подложки можно изменять, кликнув на ней правой кнопкой мышки - откроется форма "Цвет". Действия аналогичны подбору цвета фона журнала.

Информацию, содержащуюся в файле friends.ini, можно редактировать в любом текстовом редакторе.

Скачать файл friends.ini можно на сайте UR5EQF.RU

или здесь (в этих файлах удалена информация о LotW- и eQSL-users, т.к. Списки LotW- и eQSL-users, обновляются из интернета автоматически и не привязаны к файлу friends.ini, как было в ранних версиях лога):

1_friends.rar (706.9 Кб)

2_friends.rar (26.5 Mb)

Информация о LotW- и eQSL-users удалена, чтобы избежать задвоения данных:


LotW Users

Базы данных лога (состав и настройки)

 Top Previous Next

LotW Users

Информацию о пользователях LotW можно найти в файле ..\Download\LoTW_Data.txt.

Список пользователей LotW автоматически обновляется из Интернета.

Этой информацией можно пользоваться, если установить флаг "Загрузить информацию из файла "LotW_Data.txt (LotW Users)" в меню "Настройки".


eQSL Users

Базы данных лога (состав и настройки)

 Top Previous Next

eQSL Users

Информацию о пользователях eQSL можно найти в файле ..\Download\AGMemberList.txе.

Список пользователей eQSL автоматически обновляется из Интернета.

Этой информацией можно пользоваться, если установить флаг "Загрузить информацию из файла "AGMemberList.txt (eQSL Users)" в меню "Настройки".


Карты мира, стран и территорий

Базы данных лога (состав и настройки)

 Top Previous Next

Карты мира (глобус), стран и территорий

Карта мира (глобус)

По умолчанию, после инсталляции полной версии программы v.3.31-61, интерфейс лога отображается в конфигурации не стандартного интерфейса, а карта мира - в виде глобуса. Карту мира можно просматривать в виде глобуса или плоской проекции.

Карты стран и территорий

В отдельном окне можно вывести карту страны или территории, откуда работает текущий корреспондент:

Карты не входят в пакет инсталляции, их нужно устанавливать самостоятельно.

Файл с радиолюбительскими картами можно скачать на Сайте поддержки UR5EQF Log.

Затем распаковать архив и поместить папку Maps в каталог лога (...\ur5eqf_log3\Maps\).

Карты можно изготовить самому или найти и добавить недостающие файлы карт в папку Maps.

Имя графического файла территории должно содержать префикс территории по DXCC, например: 1s.gif (территория о. Спратли - префикс 1S).

Если имена графических файлов разные, например 3b6.gif и 3b8.gif, но указывают на одну и ту же территорию 3B8, то при вводе позывных 3B6 или 3B8 в лог будет открыта карта только этой территории по DXCC - 3B8.


Поиск информации в базах данных лога

Поиск информации и фотографий в Интернете

Поиск информации во внутренней базе лога

Поиск в базе QSL-менеджеров

Поиск во Внешних базах позывных


Поиск информации в Интернет

Поиск информации в базах данных лога

Поиск информации и фотографий в Интернете

Программа лога позволяет быстро находить информацию во Внешних базах позывных, если компьютер подключен к сети Интернет.

Для этого введите позывной корреспондента в поле "Позывной" и нажмите на значок [image] - Кнопку "Поиск позывного в Интернет", или выберите опцию в Меню "Просмотр" -"Поиск позывного в интернет", в результате откроется "Окно поиска информации о позывном в интернете":

Текстовая информация о корреспонденте ищется по адресам сайтов (напротив которых установлены галочки) сверху вниз пока не найдет:

1. qrz.ru

2. hamqth.com

3. qrz.com

4. ric.cqham.ru

5. uarl.com.ua

Если информация не находится, то выводится сообщение "Error" (в сообщении указывается так же адрес сервера, на котором завершился поиск):

и сообщение об отсутствии фотографии:

Порядок поиска фотографий в Инете соответствует порядку

поиска текстовой информации:

1. qrz.ru

2. hamqth.com

3. qrz.com

4. ric.cqham.ru

5. uarl.com.ua

Если снимаем флаг поиска текстовой информации с сервера ("поиск по адресу"), то на этом сервере не ищется и картинка.

Причем, если нажать кнопку "Поиск позывного в Интернет" [image] ,

то программа:

·если установлен флаг "Загружать фото из Инета" - вне зависимости от того, есть или нет фото на диске, производит поиск фотографии в инете.

·если флаг "Загружать фото из Инета" не установлен - программа производит поиск фотографий толька на диске, по адресу, установленному в этом поле:

, т.е. в данном случае на диске D в папке image

Для того, чтобы лог отображал информацию и фото с сайта QRZ.COM, нужно в Меню "Журнал" - "Конфигурации журнала" установить логин и пароль в поле QRZ.COM user.

Варианты отображения фотографий

Если поставить флаг "Показывать фото возле окна Споты":

то фото можно смотреть непосредственно в окне Tелнета - Закладка "Фото"

"Флаг "Если нет фото, показать предыдущее" :

1. Флаг "Если нет фото, показать предыдущее" установлен

В этом случае, если у корреспондента нет фото, то в окне выводится надпись: No picture available и остается фото предыдущего корреспондента:

2. Флаг "Если нет фото, показать предыдущее" не установлен

В этом случае, если у корреспондента нет фото, то в окно выводится только надпись: No picture available окно остается пустым:

Если "Окно поиска информации о позывном в интернете" открывается при запуске лога, то программа ищет в папке image фотографию корреспондента из нижней строки журнала. Если фотографии нет, то независимо от того, установлен или нет Флаг "Если нет фото, показать предыдущее", окно останется пустым и выводится только надпись "Error": No picture available. Например:

Отображение адреса загрузки фотографии в окне поиска позывного в инете

В заголовке видно откуда грузится картинка (в данном примере с QRZ.RU):

А, если в заголовке один позывной, то фотография загружена с диска:

Можно настроить показ фотографий в отдельном окне

Для этого достаточно нажать кнопку "Поиск позывного в Интернет" [image] и не выключать её

А чтобы "Окно поиска информации о позывном в интернете" постоянно открывалось при каждом запуске лога, нужно в меню "Настройки" - "Настройка интерфейса" - "При старте программы показать" установить флаг "Поиск позывного в интернет" и нажать "Значек синей дискеты", т.е. сохранить изменения.

Загрузка фото при повторной связи с корреспондентом

Если фотография есть в папке image, то она не будет загружаться из Инета повторно, а будет сразу выводиться в "Окне поиска информации о позывном в интернете", даже при выключенном Инете...

Показ фото можно отключить

Как такового отключения показа фото нет, но если снять флаг "Загружать фото из интернета", то поиск в интернет производится не будет, будут показаны фото, находящиеся на жестком диске. Если не хотите, что б и они показывались, укажите несуществующий путь к картинкам.

Если после поиска информации в Инете произошел разрыв с интернетом, см. здесь

Кнопка "PSKreporter"

По этой кнопке можно посмотреть местоположение корреспондента со спутника, если он работает цифровыми видами:

Кнопка "Открыть URL" будет активна, если у корреспондента есть домашняя страница в интернете. Клик по этой кнопке откроет домашнюю страницу корреспондента.

Кнопка "QRZCQ" - клик по этой кнопке откроет страницу корреспондента на сайте http://qrzcq.com, если о нем есть информация в этой базе позывных.

Кнопка "ClubLog" - что бы получать информацию о корреспонденте из этой базы позывных, нужно зарегистрироваться на этом сайте. После регистрации зайти в базу как пользователь. Теперь клик по этой конпке будет открывать страничку корреспондента с информацией

Нажатием на кнопку "Копировать все" можно сразу ввести данные из этого окна в окно ввода позывного.

Кнопка "Копир. коммент" не работает (в поле "Комментарий" заносится имя).

Данные из "Окна поиска информации о позывном в интернете" можно копировать вручную и переносить их в соответствующие поля.

При обращении лога к серсвису QRZ.RU в "Окне поиска информации о позывном в интернете" выводится следующая информация:

****************************************************************************
* ВНИМАНИЕ! *
* Вы используете устаревший интерфейс, который будет отключен в 2017 году. *
* Для доступа в QRZ.RU Callbook необходимо использовать XML API, *
* см. http://www.qrz.ru/help/api/xml *
****************************************************************************

Олег (US-E-12) написал Плагин - Callbook (05.03.2016) для работы Лога с базой QRZ.RU через новый XML API скачать, в нем сделана возможность обмена данными с Логом. Инструкция по подключению здесь.

Вопросы по разделу "Поиск информации в Интернет ":

...не ищет данные набранного позывного в интернете

При нажатии кнопки "Поиск позывного в интернет" выкидывает графы пустые без инфо

Поиск информации и фото на сайте QRZ.COM

Поиск информации о корреспонденте на http://hamqth.com/

Можно ли изменить размер окна для вывода фотографий?


...не ищет данные набранного позывного в интернете

Поиск информации и фотографий в Интернете

...не ищет данные набранного позывного в интернете

П.14168. UR5EQF: Цитата:

"Щелкаешь"мышкой по интернету вообще не тянет и не ищет данные набранного позывного ни по какой базе , только то что запомнило ранее.

1. Поиск в интернете будет производиться только, если открыто окно поиска в интернете, которое вызывается кликом мышки по иконке "Поиск позывного в Интернет"
Более подробно см. в разделе "Поиск информации в Интернет"

2. Для работы с Интернетом должен быть настроен обозреватель Internet Explorer, только он, не Опера, не Mozilla и т.д.
Если работает обозреватель Internet Explorer, то и лог будет работать.
Проверьте настройки Брандмаузэра Windows, может у Вас запрещен доступ из лога в Интернет.


При нажатии кнопки "Поиск позывного в интернет" выкидывает графы пустые без инфо

Поиск информации и фотографий в Интернете

При нажатии кнопки "Поиск позывного в интернет" [image] выкидывает графы пустые без инфо

П.16539. UR5EQF: Цитата:

"при нажатии кнопки "поиск позывного в интернет" выкидывает графы пустые без инфо по корреспонденту, как можно наладить?

Проблема с интернетом или с настройками Интернета на Вашем компе (должен работать Internet Explorer, остальные не в счет.....).

или проблемы с сетью, если она есть.


Поиск информации и фото на сайте QRZ.COM

Поиск информации и фотографий в Интернете

Поиск информации и фото на сайте QRZ.COM

Сайт QRZ.COM ограничил свободный доступ к базе данных позывных посредством аппартных журналов. Сайт QRZ.COM проводит политику ограничения бесплатного доступа к своей базе посредством аппаратных журналов.

Для доступа к базе данных необходима регистрация на сайте. Для зарегистрированных пользователей QRZ.COM информация, получаемая через лог, будет минимальна - название страны, имя и фотография корреспондента (если есть). Для получения большего объема информации о позывном необходима соответствующая оплата.

Для получения информации с сайта QRZ.COM зарегистрированному пользователю нужно ввести свой логин и пароль в поле "QRZ.com user" в опции "Конфигурация журнала" (вкладка "Сервисы"):

Далее в окне "Конфигурация журнала" выбираем вкладку "Сервисы":

в блоке "QRZ.com" вводим свой логин (CALL) и полученный при регистрации на QRZ.COM

пароль.

Для каждого лога свой пароль.

Для получения большей информации необходима оплата услуг сайта:

выбираем опцию QRZ Subscriptions:

и далее оплачиваем...


Поиск информации о корреспонденте на http://hamqth.com/

Поиск информации и фотографий в Интернете

Поиск информации о корреспонденте на http://hamqth.com/

В версии 3.30-7 добавлен поиск информации о корреспонденте на http://hamqth.com/

Для получения этой информации, Вы должны зарегистрироваться на этом сервере. Логин и пароль указываете в опции "Конфигурация журнала" (вкладка "Сервисы") в блоке "HamQTH".


Можно ли изменить размер окна для вывода фотографий?

Поиск информации и фотографий в Интернете

Можно ли изменить размер окна для вывода фотографий?

п.16261. UR5EQF: Изменять размер фотографии нельзя, но можно сдедать возможным показ фото в окне Tелнета - Закладка "Фото" (размер окна Телнета можно изменять).


Поиск во внутренней базе лога

Поиск информации в базах данных лога

Поиск информации во внутренней базе лога

Форма "Внутренний справочник" вызывается из главного Меню "Просмотр" - "Внутренний справочник" - "Внутренний справочник"

При проведении QSO и сохранении связей в лог данные записываются во внутренний справочник позывных. В эту базу также можно импортировать информацию из других логов или вручную водить данные из окна ввода позывного.

При вводе позывного корреспондента информация берется из этого справочника. Если данные в справочнике отсутствуют, тогда информация выводится из внешних баз позывных, при условии, что они подключены к логу.

В внутреннем справочнике позывных можно найти и отредактировать позывной, имя, QTH и другую необходимую информацию, а также ввести данные о новом позывном.

П.8969: RZ1OM: … очень просто, можно ввести свой позывной, всю информацию в поля "Локатор", "Штат", "QSL via", а также в поле "Комментарий" все остальное, затем нажать вверху над полем ввода позывного значок "коричневой дискеты"... все эти данные будут сохранены во внутренний справочник... при последующем вводе этого же позывного они автоматически будут выведены во все поля... так можно сохранять информацию о любом позывном, что я регулярно делаю... пусть не сработал с этим корреспондентом, а просто послушал его, затем ввел инфо и сохранил во внутренний справочник... может быть кому-то потом будет интересно, и в следующий раз, когда его услышу, уже буду иметь перед глазами всю инфо.


Поиск информации в базах данных лога

Поиск в базе QSL-менеджеров

Поле "MGR" заполняется автоматически из внутренней базы данных "QSL менеджеры", при наличии в ней информации по введенному в поле "Позывной" позывному корреспондента. Поле "MGR" подсветится салатным оттенком и заполнится позывным менеджера.

Если в базе данных "QSL менеджеры" по данному корреспонденту имеется другая информация, но нет QSL-менеджера, поле "QSL via" так же подсветится салатным оттенком. Кликнув по кнопке "Список QSL-менеджеров", можно вызвать форму "QSL менеджеры" и посмотреть имеющуюся информацию.

Поиск информации можно осуществлять вручную.

Вызовите форму "QSL менеджеры" нажатием кнопки "Список QSL менеджеров" или из главного Меню "Настройки" - "QSL менеджеры" - "База QSL менеджеров":

В поле напротив "Позывной" введите нужный позывной. Например: J68GS:

Чтобы вывести позывной QSL-менеджера в поле "QSL via", нужно дважды кликнуть левой кнопкой мышки по строке с информацией напротив выбранного позывного.


Поиск во Внешних базах позывных

Поиск информации в базах данных лога

Поиск во Внешних базах позывных

Если подключены внешние базы позывных, то лог автоматически ищет информацию по позывному, введенному в поле "Позывной".


additionally

Enter topic text here.


Каталог UR5EQF_Log3.1_2_2

1.Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Каталог UR5EQF_Log3.1

(Папки и файлы программы лога)

Пример установки лога на диск D:


"Обновить внутренний справочник из лога"

"Операции с журналом"

"Обновить внутренний справочник из Лога"

"Обновление внутреннего справочника из лога" рекомендуется делать после импорта

adif-файла из других логов для пополнения информации во внутреннем справочнике лога.


"Обновить ЛОГ из внутреннего справочника"

"Операции с журналом"

"Обновить ЛОГ из внутреннего справочника"

обновление полей "Имя, QTH и т.д." в текущем логе полезно выполнять при импорте данных из других логов, где эта информация может отсутствовать...


"Обновить в ЛОГе данные о "QSL Manager"

"Операции с журналом"

"Обновить в ЛОГе данные о "QSL Manager"

Добавлена возможность "Обновить поле "MGR" из таблицы менеджеров".

Данные обновляются во всех логах с индексом, равным индексу текущего лога. Если информация о менеджере уже была в журнале, то она не изменится, если не было - добавится.

индикатор процесса:


Импорт из 425DX News

Импорт информации в лог

Импорт из 425DX News

Вы можете самостоятельно постоянно пополнять базу данных QSL-менеджеров информацией из бюллетеней 425DX News с помощью формы "QSL менеджеры".

Форма "QSL менеджеры" вызывется нажатием кнопки "Список QSL менеджеров" или из главного Меню "Настройки" - "QSL менеджеры" - "База QSL менеджеров":

Управляющие иконки:

1 - "Добавить" (клик по этой иконке добавляет новую пустую строку)

2 - "Изменить" (клик по этой иконке позволяет изменять информацию в предварительно выделенной строке. Информацию изменяем в полях, расположенных внизу формы. Сохранить изменения - нажать ОК)

3 - "Импорт из файла" (Импорт баз 425DXNews в лог в "dbf - формате")

4 - "Загрузить из файла "...\.zip" (Импорт баз 425DXNews в лог в "zip - формате")

5 - "Удалить" (удалить выбранную строку или несколько строк)

6 - "Удалить все" (очистить базу менеджеров)

7 - "Обновить" (аналогично действию опции "Обновить в ЛОГе данные о QSL Manager" из Меню "Журнал" - "Операции с журналом")

8 - поле "Позывной" (поиск информации по введенному позывному)

Форма "QSL менеджеры" позволяет осуществлять обновление базы QSL-менеджеров из бюллетеней 425DX News в двух форматах:

·Бюллетени в формате баз данных DBF

Импорт DBF-файла осуществляется с помощью иконки 3.

·Бюллетени в формате ZIP

Импорт ZIP-файла осуществляется с помощью иконки 4, предварительно нужно:

- скачать файл managerlist.zip. Для удобства этот файл можно перенести в папку лога tmp

- в открытом окне базы данных QSL-менеджеров в верхней части окна выберите значок открытой папки 4:

- В открывшемся окне найдите папку с сохраненным файлом;

- Выберите этот файл, нажмите "Открыть";

- Индикатор внизу окна покажет процесс импорта файла.

Ручной ввод информации в базу QSL-менеджеров

Для ввода данных кликните кнопкой мышки по иконке 1 ("Добавить"), в верху формы добавится пустая строка. Информацию о позывном, менеджере и т.д. вводим в полях, расположенных внизу формы. Сохранить информацию - нажать ОК).


Вкладка "Фото"

Telnet DX кластер

Вкладка "Фото"

Если поставить флаг "Показывать фото возле окна Споты" ("Окно поиска информации о позывном в интернете"), включиться вкладка "Фото", тогда фото можно смотреть непосредственно в окне Telnet DX кластера, что удобно при небольших размерах экрана монитора:

После установки флага "Показывать фото возле окна Споты", форму поиска в Интернете можно закрыть. Если не закрыть, то при первой попытке отображения фотографии - это окно само закроется. При последующем запуске программы, фотография будет отображаться в кластере.

И еще одна особенность, если даже отключены все сервера для поиска инфо и фото, то в режиме "Показывать в кластере.......", поиск фотографии производится по всем серверам.

При снятии флага отображения фотографии в кластере, соответственно отключается вкладка «Фото».


После поиска позывного в интернете присзодит разрыв связи с интернетом

Настройка интернета

Происходит разрыв связи с интернетом после поиска позывного в интернете

п.14525. ...после использования функции "Поиск позывного в интернет" у меня стало разрывать связь с интернетом.

В настройках телнета ("Конфигурация") убрать флаг "Авторазрыв DialUp для DX кластера"

п.14526. Сейчас (версия v3.29-4) можно ещё и из меню "Настройки"- "SetUp Internet (Telnet)" войти в настройки Телнета.

п.10756. UR5EQF: Цитата:

Объясните PSE как это должно работать?

Это нужно, если вы работаете через обычное модемное соединение (DialUp) и трафик у Вас повременный.
Работает это так, получили данные и разорвали связь с Инетом.........

Если нужна постоянная связь, галочка убирается.


Поиск обновлений

1.Первоначальная установка, переустановка, запуск, обновление и деинсталляция лога

 Top Previous Next

Поиск обновлений

Для автопроверки поиска обновлений необходимо настроить форму в Меню "Настройки" - "Получить информацию из интернета":

Включить автопроверку - установит чек-бокс. Отключит ь автопроверку - снять чек-бокс.

При запуске Лога программа ищет в интернете те обновления, которые отмечены чекбоксом.

С помощью этой платформы осуществляется поиск следующих обновлений:

Проверка обновления Лога - в настоящее время поиск обновлений Лога не осуществляется.

Внешние базы позывных

Территория (Страна)

QSL Manager

Перечень дипломов

Список модуляций

Поиск обновлений LotW пользователей и eQSL пользователей

При установленном чекбоксе программа осуществляет поиск в интернете обновлений LotW и eQSL пользователей:

Чек-бокс "Автозагрузка" позволяет осуществлять загрузку в автоматическом режиме.

Можно заменить адрес сайта HB9BZA (http://www.hb9bza.net/lotw/lotw.txt) на адрес сайта WD5EAE (http://www.wd5eae.org/LoTW1.txt) - он оперативнее реагирует на обновление списка LoTW.


Главное меню

Меню "Настройки"

Меню "Просмотр"


Меню "Настройки"

Главное меню

Меню "Настройки"

Меню "Настройки" вызывается из Главного меню:

Опции меню "Настройки":

Получить информацию из интернета *

"QSL менеджеры"

"Загрузить информацию из файла "Friends.ini"

"Загрузить информацию из файла "LotW_Data.txt (LotW Users)"

"Загрузить информацию из файла "AGMemberList.txt (eQSLL Users)"


Получить информацию из интернета

Меню "Настройки"

Получить информацию из интернета

Меню "Настройки" - "Настройка программы"- "Получить информацию из интернета":

В этой форме две вкладки:

1. Получить информацию из интернета

В этой вкладке можно устанавливать автоматические обновления или скачивать их вручную по кнопке "Скачать", например, обновить список LotW-пользлвателей:

Если установить флаг "Автозагрузка" обновления будут происходить автоматически.

На вкладке "Получить информацию из интернета" можно создавать и свои загрузки, при наличии обновлений, этих файлов, будет произведена автоматическая загрузка, при запуске лога:

·кликом правой мышки вызываем меню:

·выбираем опцию "Добавить", в открывшемся окне прописываем свои реквизиты:

2. При старте программы показать

См.ещё


"QSL менеджеры"

Меню "Настройки"

"QSL менеджеры"

"База QSL менеджеров"

Загрузить из файла "...\.zip"

Сохранить в файл "...\.zip"

См.ещё


Загрузить из файла "...\.zip"

"QSL менеджеры"

Загрузить из файла "...\.zip"

Вызывается форма "Открыть", находим сохраненный файл:

по кнопке "Открыть" произойдет обновление базы QSL-менеджеров из этого файла:


Сохранить в файл "...\.zip"

"QSL менеджеры"

Сохранить в файл "...\.zip"

сохраненный файл managerlist.zip будет находиться в папке db каталога лога.

Форма для записи на FTP-Server - служебная, её закрываем не используя:


"Загрузить информацию из файла "Friends.ini"

Меню "Настройки"

"Загрузить информацию из файла "Friends.ini"

Если установить этот флаг:

то на "глобусе" можно увидеть более подробную информацию о корреспонденте:

Подробнее о файле "Friends.ini"


"Загрузить информацию из файла "LotW_Data.txt (LotW Users)"

Меню "Настройки"

"Загрузить информацию из файла "LotW_Data.txt (LotW Users)"

Если установить этот флаг, то информация о пользователях LotW будет отображаться в левом углу окна "Карта мира", в колонке "User" на вкладке "Споты" и окна www DX-кластера, на "СпотМастере", а также справа от поля "Позывной".


"Загрузить информацию из файла "AGMemberList.txt (eQSL Users)"

Меню "Настройки"

"Загрузить информацию из файла "AGMemberList.txt (eQSL Users)"

Если установить этот флаг, то информация о пользователях eQSL будет отображаться в левом углу окна "Карта мира", в колонке "User" на вкладке "Споты" и окна www DX-кластера, на "СпотМастере", а также справа от поля "Позывной".


Цвет фона окна "Журнал"

"Настройка интерфейса"

Цвет фона окна "Журнал"

После инсталляции лога, при первом его запуске цвет фона окна "Журнал" - белый.

Выбор цвета фона осуществляется в форме "Цвет", которая выводится на экран монитора после выбора опции "Цвет фона окна "Журнал":

Цвет фона можно выбрать щелчком мышки по одной из иконок поля "Основные цвета" и подобрать оттенок перемещением мышкой указателя (1) вверх-вниз, или устанавливая маркер (2) в любое место спектра цветов, подбирать оттенок аналогичным способом.

Выбранный цвет фона можно занести в поле "Дополнительные цвета" (Добавить в набор).

Таким способом можно "запомнить" несколько вариантов цвета фона окна "Журнал". Для этого необходимо выбрать мышкой следующую иконку:


При старте программы показать_2

"Настройка интерфейса"

При старте программы показать

При установке чек-бокса соответствующая форма будет загружаться на экран монитора автоматически при каждом запуске программы.

Значек синей дискеты - сохранить изменения

Стрелка - отмена выделения (до сохранения изменений).

Снять ранее сохраненный флаг - кликнуть мышкой по чек-боксу.


Меню "Просмотр"

Главное меню

Меню "Просмотр"

Опции меню "Просмотр":

"Поиск позывного в интернет" (данная опция дублирует

действия по одноименной кнопке)

"Внутренний справочник"

"Внешние базы позывных"


"Поиск позывного в интернет"

Меню "Просмотр"

Поиск позывного в интернет

Меню "Просмотр" -"Поиск позывного в интернет" - Данная опция вызывает "Окно поиска информации в интернете", аналогично клику по кнопке "Поиск позывного в Интернет":


"Внутренний справочник"

Меню "Просмотр"

"Внутренний справочник"

"Подключить внутренний справочник"

"Внутренний справочник"(опция)


Подключить внутренний справочник

"Внутренний справочник"

Подключить внутренний справочник

При установке соответствующего флага выполняется подключение справочников:

"Имена"

"Города"

"Внутренний справочник"(опция)

К справочникам "Имена" и "Города" доступа для корректирования непосредственно из лога нет.

В случае необходимости эти справочники можно откорректировать непосредственнов в файле базы данных BD (папка db): таблицы OperatorCity, OperatorName.

См. ещё


"Внутренний справочник" (опция)

"Внутренний справочник"

"Внутренний справочник" (опция)

Форма "Внутренний справочник" вызывается из главного Меню "Просмотр" - "Внутренний справочник" - "Внутренний справочник":

Управляющие иконки формы "Внутренний справочник"

1 - "Добавить"

2 - "Изменить"

3 - "Отмена"

4 - "Сохранить"

5 - "Удалить"

6 - "Обновить"

"Проверено"

Поиск информации во внутренней базе лога

См.ещё


"Проверено"

"Внутренний справочник"

"Проверено"

Учитывая, что во внутренний справочник попадает устаревшая или неточная информация, во внутреннем справочнике введена колонка "Checked", в которую можно ставить отметку, что информация по данному позывному проверена (из источников, заслуживающих доверия или во время радиосвязи) и соответствует действительности.

Для внесения этой отметки нужно произвести следующие действия:

1.Выбрать необходимый позывной.

2.Установить флаг "Проверено"

3.Нажать кнопку "Post" (Сохранить)

4.В колонке "Checked" появится соответствующая отметка:

При вводе такого позывного, слева от поля "Позывной" будет появляться желтый квадратик.


"Внешние базы позывных"(опция)

Меню "Просмотр"

"Внешние базы позывных"(опция)

Меню "Просмотр" - "Внешние базы" - Эта опция вызывает форму "Внешние базы позывных":

О работе данной опции см. раздел "Внешние базы позывных"


Оперативное окно

Стуктура "Интерфейса журнала UR5EQF_LOG или Основного окна лога"

 Top Previous Next

Оперативное окно

В состав оперативного окна входят:

·Кнопки оперативного управления

·Поле (окно) выбора текущего журнала

·Индикаторы времени

·Информационные поля (Окно ввода QSO)

·Управляющие чек-боксы

·Блок дополнительной информации

·Блок "Режим наблюдателя (SWL)"

·Кнопки управления поворотным устройством антенны

·В основное окно лога под кнопки управления частотой трансивера выведена индикация режимов работы трансивера - "TX", "RX" :

·можно выделять азимут другим цветом


Кнопки оперативного управления

Оперативное окно

Кнопки оперативного управления

Кнопка "Сохранить во внутренний справочник" - значок "коричневой дискеты"

Кнопка "Показать эту территорию на карте" ?

Кнопка "Поиск позывного в Интернет"


Кнопка "Сохранить во внутренний справочник" - значок "коричневой дискеты"

Кнопки оперативного управления

Кнопка "Сохранить во внутренний справочник" - значок "коричневой дискеты"

Используется для внесения данных в базу внутреннего справочника позывных всех данных, которые Вас интересуют, при повторном вводе позывного они будут выведены в соответствующие поля...

Для того, что бы эти данные из внутреннего справочника подтягивались, должен быть установлен флажок "Внутренний справочник".

Во внутренний справочник сохраняются следующие данные:

- позывной

- Имя

- QTH

- Штат

- локатор

- комментарии

- QSL-менеджер


Кнопка "Показать эту территорию на карте"

Кнопки оперативного управления

Кнопка "Показать эту территорию на карте"

По этой кнопке можно посмотреть карту страны (региона) корреспондента в отдельном окне. Для этого необходимо загрузить файл с радиолюбительскими картами в папку MAPS.


Кнопка "Поиск позывного в Интернет"

Кнопки оперативного управления

Кнопка "Поиск позывного в Интернет"

Клик мышки по этой иконке вызывает "Окно поиска информации о позывном в интернете", аналогично опции Меню "Просмотр" -"Поиск позывного в интернет":


Информационные поля (Окно ввода QSO)

Оперативное окно

Информационные поля (Окно ввода QSO)

Это окно содержит информационные поля для записи текущего QSO в журнал:

- Поле «Позывной»

- Поле "Дата"

- Поле "Диапазон"

- Поле "Мода"

- Поле "Время UTC"

- Поля "Имя", "QTH"

- Поля "RSTотп", "RSTпол"

- Поле "QSL via"

- Поле "Локатор" (ЛОК)

- Поле "Штат"(State)

- Поле "IOTA"

- Поле "MGR" и его кнопка

- Поля "Статистика 1" - "Статистика 4"

- Поле "Комментарий"


Поле «Позывной»

Информационные поля (Окно ввода QSO)

 Top Previous Next

Поле «Позывной»

Подсветка поля "Позывной" салатным цветом означает, что с данным кореспондентом уже были QSO.

Литеры LE справа от поля "Позывной" обозначают, что UA9CGL является пользователем как eQSL, так и LotW систем.

Слева от поля "Позывной" могут появляться такие квадратики:

Желтый квадратик - "Проверено" - это означает, что во внутреннем справочнике по этому позывному стоит отметка "Проверено".

Салатный квадратик - "новая территория на BM" (диапазон/модуляция), т.е. программа рекомендует провести связь с этой станцией.


Поля "Имя", "QTH"

Информационные поля (Окно ввода QSO)

 Top Previous Next

Поля "Имя", "QTH"

Эти поля заполняются в автоматическом режиме, если подключен внутренний справочник или внешние базы позывных.

В ручном режиме:

- в поля "Имя" и "QTH" с клавиатуры записывается принятый текст. Если подключены "Справочник имен" и "Справочник Города" во "Внутреннем справочнике", то при наборе первого символа в поле "Имя" или "QTH" появится выпадающий справочник имен или городов, из которых, при желании, можно выбрать необходимое имя или город, и двойным кликом мышки занести их в эти поля:

Чтобы при заполнении этих полей в ручном режиме не выводился в виде выпадающего списка, справочник имен или городов, уберите в "Меню просмотр" - "Внутренний справочник" - "Подключить справочники" - соответствующие галки.

п.17151. UR5EQF: Поиск города, имени и т.д. производится

в следующем порядке:

1. В повторных записях в журнале.

Поверяем только последнее проведенное QSO, город берем только, если позывные без дробей. Например:

UX3MZ - один населенный пункт,

UX3MZ/p - другой населенный пункт, опять

UX3MZ/p - и еще другой населенный пункт может быть.

Поэтому QTH подставляетсятолько из последней записи, и только, если позывной в последней записи без дробей, понятное дело, точно как и с вводимым позывным.

2. Ищем во внутреннем справочнике.

3. Во внешних справочниках.

Если внутренний и внешие справочники отключены, поиск производится только по записям в журнале.

См. ещё


Поле "MGR" и его кнопка

Информационные поля (Окно ввода QSO)

 Top Previous Next

Поле "MGR" и его кнопка

Заполнение поля "MGR":

Поле "MGR" заполняется автоматически из внутренней базы данных "QSL менеджеры", при

наличии в ней информации по введенному в поле "Позывной" позывному корреспондента. Поле "MGR" подсветится салатным оттенком и заполнится позывным менеджера.

Если в базе данных "QSL менеджеры" по данному корреспонденту имеется другая информация, но нет QSL-менеджера, поле "QSL via" так же подсветится салатным оттенком. Кликнув по кнопке "Список QSL-менеджеров", можно вызвать форму "QSL менеджеры" и посмотреть имеющуюся информацию.

(салатный цвет поля "Позывной" указывает на то, что с этим корреспондентом уже было QSO)

В Логе имеется возможность "Обновить в ЛОГе данные о QSL Manager" из таблицы менеджеров".

Добавлена возможность "Обновить поле QSL Manager из таблицы менеджеров". Данные обновляются во всех логах с индексом, равным индексу текущего лога. Если информация о менеджере уже была в журнале, то она не изменится, если не было - добавится.

См.еще


Поле "Комментарий"

Информационные поля (Окно ввода QSO)

 Top Previous Next

Поле "Комментарий"

В поле "Комментарий" (комментарий к QSO) можно ввести данные, полученные от корреспондента. Например, информацию об аппаратуре, о погоде, прохождении, личные наблюдения и т.д.

В комментарий можно внести данные из окна поиска информации в интернет.

Комментарий выводится в окне ввода позывного при повторной связи с корреспондентом. Эту информацию можно просмотреть в колонке "Комментарий" в окне "Журнал" в строке этого позывного,

При этом следует учитывать, что после изменения информации в поле "Комментарий" посредством Редактора QSO или опции группового редактирования, измененная информация будет отображаться при повторной связи с корреспондентом, только в том случае, если эти изменения были внесены во внутренний справочник:

См. ещё


Окно «Карта мира»

Стуктура "Интерфейса журнала UR5EQF_LOG или Основного окна лога"

 Top Previous Next

Окно «Карта мира»

Окно "Карта мира" имеет два режима отображения:

·глобус (установлен чек-бокс "Глобус", либо кликом правой кнопкой мышки по глобусу - off-Globe)

·карта (чек-бокс "Глобус" снят, либо кликом правой кнопкой мышки по глобусу - on-Globe)

(В поле подсказок отображаются координаты, азимут и название страны по местоположению курсора на карте/глобусе) или в отдельном окне (Меню "Настройки" - "Карта мира в отдельном окне"):

Переключение режимов "Карта" - "Глобус" в отдельном окне осуществляется кликом правой кнопки мышки (off-on Globe).

(В поле подсказок так же будут отображаются координаты, азимут и название страны по местоположению курсора на карте/глобусе).

Если кликнуть по территории страны левой кнопкой мышки, то она окрасится в желтый цвет, а в верхнем левом углу будет выведено название этой страны.

Масштаб глобуса/карты

·Если установлен чек-бокс "Глобус", комбо-бокс "Масштаб" будет активен. С помощью стрелок "вверх/вниз" можно изменять масштаб глобуса.

·Если чек-бокс "Глобус" снят, тогда комбо-бокс "Масштаб" не будет активен.

Масштаб глобуса/карты при неактивном комбо-боксе "Масштаб" (а так же в режиме "Карта мира в отдельном окне") можно изменять следующим способом (в сторону увеличения):

правой кнопкой мышки выделить на карте необходимый прямоугольник и левой кнопкой кликнуть внутри прямоугольника. Сбросить масштаб в исходное положение - переключить режим on-off-Globe.

·комбо-бокс "Масштаб" так же не будет активен, если установлен чек-бокс "Глобус/Стат."(полно-масштабное отображение окна "Карта мира" в режиме "Глобус"):

Чек-бокс "Глобус/Стат."(полно-масштабное отображение окна "Карта мира" в режиме "Глобус")

Этот чек-бокс становится активным, если в настройках Меню "Настройки" - "Показать на месте карты мира" установить флаг отличный от "Карта мира", например: "Панель статистика":

Если установить чек-бокс "Глобус/Стат.", то открытая Панель сворачивается и на ее место доразворачивается Глобус. Комбо-бокс "Масштаб" становится не активным.

Чек-бокс "Глобус/Карт."

Переключает режимы "Глобус/Карта".

Чек-бокс "Терминатор" (граница дня и ночи)

Поставив чек-бокс "Терминатор" на карте (глобусе) можно увидеть линию восхода и захода солнца.

Если Вы работаете с монитором, имеющим небольшой размер экрана, то окно "Карта мира" можно убрать, сняв галочку в управляющем чек-боксе "Карта" в окне ввода позывного:

Тогда на месте карты (глобуса) можно разместить основное окно журнала, а в дополнительном просматривать споты кластера и/или повторные связи.

Отображение информации о LOTW- и eQSL- users

В левом верхнем углу карты/глобуса может отображаться информация о LOTW- и eQSL- users.

Отображение информации из файла friends.ini

Если по введенному позывному в файле friends.ini имеется информация, она может выводится в верхнем левом углу окна "Карта мира"

Ввод позывного в поле "Позывной"

При вводе позывного в поле "Позывной" или при получении спота в telnet-кластере на глобусе будет отображаться позывной и территория, где находится корреспондент.


Комментарии к связи

Ввод, редактирование или удаление QSO

 Top Previous

Комментарии к связи

В поле "Комментарий" (комментарий к QSO) можно ввести данные, полученные от корреспондента. Например: информацию об аппаратуре, о погоде, прохождении, личные наблюдения и т.д.

В комментарий можно внести данные из окна поиска информации в интернет.

Комментарий выводится в окне ввода позывного при повторной связи с корреспондентом. Эту информацию можно просмотреть в колонке "Комментарий" в окне "Журнал" в строке с этим позывным, а также в Редакторе QSO.


Отображение инфы о LOTW users

Окно «Карта мира»

 Top

2. Отображение инфы о LOTW users

П.8897: … внести опцию отображения LOTW users. Подсветка позывного или индикатор какой…

П.8898: Все это и многое другое отображается в окне карты, инфо берется из friends.ini,
редактируете, вносите свое, соблюдая синтаксис...

п.12329. RZ1OM: Цитата:

В прикрепленном файле список LoTW user по состоянию на 31.01.2010

В этом файле после каждого позывного - дата крайней загрузки лога на LoTW, а не дата регистрации... похоже, данные не совсем свежие, только за 31 января 2010 г... ИМХО, нет необходимости в этих датах, лишняя инфо в файле, быстро устаревает... вариант без этих дат ниже, можно скопировать данные и вставить в файл friends.ini... данные на 9 марта, 32475 позывных из 331 страны:

LoTW.rar (81.0 Кб)