О программе

Программа аппаратного журнала UR5EQF LOG

( версия файла помощи от 26 октября 2008 г., автор Сергей RZ1OM )

 Top Next

Введение

UR5EQF LOG - это программа для ведения аппаратного журнала любительской радиостанции. Работает в операционной системе Windows (98/2000/XP/Vista). Имеет удобный интерфейс и большой набор инструментов. Многофункциональный лог, включающий в себя управление трансивером, работу цифровыми видами связи, работу с DX-кластером, обширную статистику по дипломам и многое другое. Может взаимодействовать с CwType, CwGet, TrueTTY, AAVoice, MixW2, MMVARI, MMSSTV, Band Master, DX Atlas и другими радиолюбительскими программами.

В UR5EQF LOG были взяты за основу базы данных аппаратного журнала AALog ver.2.47, которые в дальнейшем были значительно исправлены и дополнены.

Владимир UR5EQF постоянно работает над усовершенствованием программы. Все замечания и пожелания по работе лога приветствуются. С автором можно связаться по e-mail: ur5eqf@ur5eqf.com

Основные функции:

Ведение нескольких логов для одной станции как единого лога. Для примера, можно вести один лог для повседневной работы и несколько логов для различных контестов или экспедиций, при этом статистика по дипломам может может быть объединена.

Ведение логов разных радиостанций с описанием каждого лога. Если в Вашей семье больше одного радиолюбителя или программа используется в радиоклубе, то UR5EQF LOG позволит каждому из пользователей вести статистику по дипломам, независимо друг от друга.

Ведение логов для наблюдателей (SWL).

Поддержка сетевой версии - ведение общего лога одновременно на нескольких компьютерах в локальной сети (доступно с версии 2.18).

Возможности программы аппаратного журнала:

· Ввод связей как во время работы в эфире (время и дата подставляются автоматически), так и проведенных ранее связей;
· Ведение одного лога одновременно на нескольких компьютерах в локальной сети;
· Ведение логов для наблюдателей (SWL);
· Быстрая выгрузка журнала в он-лайновый лог на сайте в Интернет;
· Поиск предыдущих связей с корреспондентом;
· Расчет угла поворота антенны и расстояния до корреспондента, также поддержка Grid-локаторов;
· Встроенная карта мира;
· Групповое редактирование связей;
· Сортировка лога по дате, диапазону, виду излучения и позывным;
· Возможность наложения фильтров по любым полям;
· Статистика по спискам DXCC, WAZ, P-75-P, WAS, RDA, Russia, URDA, German DOK's и многим другим;
· Формирование заявок на дипломы;
· Управление различными марками трансиверов через Omni-Rig;
· Взаимодействие со многими популярными радиолюбительскими программами;
· Встроенный модуль работы цифровыми видами связи на "движке" MMVARI;
· Работа в режиме контеста в телеграфном режиме и в цифровых видах;
· Работа в режиме DX-pedition;
· Работа с DX кластером (telnet и www), голосовое и CW-оповещение о входящих спотах;
· Подключение базы данных QRZ.COM на CD или на жестком диске;
· Быстрый поиск позывного в логе;
· Быстрый поиск информации о позывном прямо из Интернета;
· Обновление внутреннего справочника позывных из Russian internet Callbook;
· Импорт данных из бюллетеней 425DX NEWS;
· Автоматическое переключение раскладки клавиатуры при вводе позывного;
· Подробный префикс лист с возможностью его редактирования;
· Быстрое копирование данных из одного лога в другой;
· Печать на QSL-карточках и наклейках;
· Печать аппаратного журнала;
· Подтверждение связей с сайта e-QSL;
· Подтверждение связей с сайта LoTW;
· Синхронизация часов компьютера через Интернет;
· Всемирная программа маяков на КВ;

Импорт/Экспорт данных:

· Экспорт в ADIF формат;
· Экспорт в Cabrillo формат;
· Экспорт связей в MixW2 лог;
· Экспорт связей на печать в QSL print;
· Экспорт связей в DX Atlas;
· Экспорт связей на e-QSL;
· Экспорт связей в он-лайновый лог;
· Импорт из ADIF формата;
· Импорт из текстового файла в ADIF-формат.

Поддержка цифровых видов и телеграфа:

Для цифровых видов связи Вы можете использовать встроенную программу на "движке" MMVARI или внешние программы TrueTTY, MixW2, MMSSTV и другие. В качестве цифрового голоса вашей радиостанции можно использовать программу AAVoice, для телеграфной манипуляции с клавиатуры - CwType, а для приема "морзянки" - CwGet.

Использование внешних баз данных:

UR5EQF LOG может использовать информацию из коллбуков QRZ CD-ROM и VF-Soft Radio Amateur Callbook, есть возможность импорта во внутренний справочник из базы Russian Internet Callbook, а также импорта во внутреннюю базу QSL-менеджеров из бюллетеней 425DX News.

Свежие версии программы, обновления документации и файлы с обновленным списком территорий вы можете найти в Интернете на странице автора: http://ur5eqf.com/ , тестовые версии здесь - http://files.ur5eqf.com/ .

Обсуждение программы лога на форуме - http://forum.qrz.ru/thread12480.html


Установка

 Top Previous Next

Установочный файл программы лога Вы можете найти и скачать на одной из страниц в Интернете по ссылке http://ur5eqf.com/ . Например, файл версии 2.34 имеет такое имя - ur5eqflogsetup34.EXE

· запустите файл установки, откроется окно:

· нажмите "Next". В следующем окне будет выведена информация о лицензионном соглашении. Прочитайте и опять нажмите "Next";

· если Вы не собираетесь изменять каталог программы и хотите установить программу по умолчанию на C:\ur5eqf_log, нажмите "Next". В противном случае нажмите "Browse" и укажите диск и каталог, куда Вы хотели бы установить программу лога;

· нажимайте кнопку "Next" до тех пор, пока не появится окно с кнопкой "Finish";
· нажмите на "Finish", программа будет установлена;
· после установки потребуется перезагрузка компьютера;

· нажмите "ОК", компьютер будет перезагружен;
· после перезагрузки операционной системы найдите на "Рабочем столе" значок "UR5EQF_log" и запустите программу. Программу лога можно также запустить из меню "Пуск", "Программы", "UR5EQF Log", "UR5EQF_Log";

· если при запуске программы меню отображается на английском языке, Вы можете переключить его на русский язык, для этого в меню "Settings" выберите "Program settings", далее - "Use language file" и выберите "Russian";

· сделайте настройки интерфейса программы лога по своему выбору.


Регистрация

Если Вы подключены к сети Интернет, то при запуске программы лога появится окно с просьбой зарегистрироваться, как пользователь.

Зарегистрируйтесь, пожалуйста! Регистрация программы ничем не обязывает, она полностью бесплатна и нужна только для статистики. Уделите, пожалуйста, внимание разработчику.

Вы можете зарегистрировать программу на любом числе компьютеров, но Ваш позывной в списке пользователей на http://www.cqrivne.com.ua/ur5eqf/files/reg/ будет указан только один раз.

Если у Вас отсутствует подключение к сети Интернет, то окно с напоминанием о регистрации появляться не будет. Но если Вы хотите, чтобы Ваш позывной был в списке зарегистрированных пользователей - обращайтесь к автору программы или к Сергею RZ1OM.

Порядок регистрации

· запустите программу аппаратного журнала;
· в меню "Помощь" выберите "Регистрация";
· введите позывной;
· кликните кнопкой мышки на "Регистрация";

Проверьте на сайте http://www.cqrivne.com.ua/ur5eqf/files/reg/, есть ли Ваш позывной в списке. Если да, то в дальнейшем окно с напоминанием о регистрации появляться не будет и кнопка "Регистрация" будет неактивна.


Фонд поддержки UR5EQF

Программа аппаратного журнала UR5EQF LOG распространяется бесплатно.

Для тех, кто желает оказать посильную финансовую помощь автору в благодарность за его труды, организован "Фонд поддержки" программы аппаратного журнала. Можно просто придти на почту и отправить деньги почтовым переводом:

ПОЧТОВЫЙ ПЕРЕВОД (Электронный) на ... руб. ... коп.

Куда: 106000, "Федеральный клиент", г. Москва, ООО "Алкор-М".

Кому: ООО "Алкор-М"

От кого: Ваши Фамилия, Имя, Отчество

Адрес: Ваш почтовый адрес

Сообщение: 4100194710341 Оплата по договору с Системой Яндекс.Деньги. Без НДС.

Назначение платежа: Пополнение кошелька Яндекс.Деньги через отделения Почты России

Прием наличных платежей осуществляется с комиссией 3% от суммы перевода (но не менее 7 рублей за перевод).

--------------------------------------------------------------------------------------------------------------------------------------

Также Вы можете перевести желаемую сумму, отправив SMS-сообщение на один из номеров, указанных по ссылке - http://ur5eqf.com/webmoney/webmoney.php . Например, для россиян нужно отправить SMS-сообщение со словом vsvova на номер 1151, 1161 или 1171... соответственно, с Вашего телефонного счета будет перечислена сумма, эквивалентная $1, $3 или $4.80.

"Виртуальные" (электронные) деньги:

Если у Вас есть электронный кошелек на Яндекс.Деньги или Интернет.Деньги, то можно перевести любую сумму на следующие реквизиты:

Яндекс.Деньги - желаемую сумму в рублях можно перевести на счет 4100194710341.

Интернет.Деньги - желаемую сумму в гривнах можно перевести на счет 410044277011 (для радиолюбителей Украины).

В сообщении укажите: "В поддержку UR5EQF LOG", а также имя и Ваш позывной. Анонимные переводы также принимаются :)

Также Вы можете воспользоваться сервисом WebMoney и перевести любую сумму на указанные ниже кошельки:

WMR 646400717832 - рубли

WMU 257978337266 - гривны
WMZ 425597819261 - доллары

WME 560083399073 - евро

-----------------------------------------------------------------------------------------------------------------------------------------

Перевод денежных средств является не обязательным, абсолютно добровольным, и не подразумевает какие-либо текущие или дальнейшие обязанности автора перед пользователями данной программы аппаратного журнала.


Журнал

Меню "Журнал"

Операции с журналом:

· открыть журнал;
· создать новый журнал;
· конфигурация журнала;
· обновить поле "Штат" из внутреннего справочника;
· переопределять территорию по позывному;
· проверка и восстановление базы данных;
· повторная индексация текущего журнала;
· переиндексация всех таблиц;
· очистить все связи в текущем журнале (все связи будут удалены!);
· сохранить в формате ADIF при выходе из программы.

Сервисы eQSL.cc и LoTW:

· загрузить входящую почту в ADIF-формате с eQSL.cc;
· подтвердить получение QSL в ADIF-формате с eQSL.cc;
· загрузить входящую почту в ADIF-формате с LoTW;
· подтвердить получение QSL в ADIF-формате с LoTW.

Экспорт связей из журнала в:

· MixW2 log;
· Cabrillo;
· формат ADIF, на eQSL.cc или DX Atlas;
· создание файлов для журналов, размещенных в сети Интернет.

Импорт данных в журнал из:

· формата ADIF;
· текстового файла.

Печать:

· распечатать аппаратный журнал, отсортированный по дате;
· распечатать аппаратный журнал, отсортированный по позывным;
· печать QSL;
· настройки печати QSL;
· редактирование файлов очереди печати.

Очистить окно ввода нового QSO;

Сохранить QSO;

Редактировать QSO;

Закрыть программу.


Установки

Меню "Установки"

Настройка программы:

· использовать для управления трансивером:
▪ Omni Rig
▪ ничего
· управление трансивером;
· связь компьютера с трансивером (вид модуляции);
· использовать клавишу "Enter":
▪ для работы в режиме pile-up
▪ для сохранения текущего QSO
▪ не использовать
· раскладка клавиатуры:
▪ для русскоязычных
▪ для англоязычных
· Интернет через прокси доступ;
· синхронизация времени через Интернет;
· русифицировать программу;
· разделитель целой и дробной части: ","

Настройка журнала:

· данные в журнале сортировать по:
▪ дата
▪ позывной
▪ частота
▪ вид
· формат записи рабочей частоты:
▪ 14.122.89
▪ 14.12289
▪ 14.122
▪ 14
▪ 14122.8
· порядок редактирования полей;
· расчет расстояния до корреспондента по QTH-локатору;
· перечень видов модуляции.

Настройка интерфейса:

· цвет фона окна ввода позывного;
· цвет шрифта окна ввода позывного;
· цвет фона окна журнала;
· шрифт окна журнала;
· цвет шрифта территории в окне ввода позывного;
· цвет шрифта повторной связи;
· единые настройки для всех логов;
· стандартный интерфейс;
· нестандартный интерфейс:
▪ вид 1 / вид 2
▪ классический интерфейс для вида 1
· стандартный интерфейс при работе цифрового модуля;

Многопользовательский режим

· подключиться к сети;
· показать подключения.

Менеджер диапазонов

Закладки:

· показывать закладку "www DX cluster";
· показывать закладку "telnet DX cluster";
· показывать закладку "Предыдущие контакты";
· показывать закладку "Статистика".

Показать в окне журнала:

· панель www DX кластера;
· панель telnet DX кластера;
· панель предыдущих контактов;
· панель статистики по дипломам;
· ничего;
· и панель www DX кластера;
· и панель telnet DX кластера.

Показать на месте карты мира:

· панель www DX кластера;
· панель telnet DX кластера;
· панель предыдущих контактов;
· панель статистики по дипломам;
· карту мира.

Показать карту мира в отдельном окне.

Внешние программы

При подключении внешней программы запустить:

· HamsCope
· MixW2
· DigiPan
· CwType
· TrueTTY
· MMSSTV
· ничего

UR5EQF_link

UR5EQF_link - это утилита, предназначена для организации обмена данными с некоторыми внешними программами.

Скачайте файл http://cqrivne.com.ua/ur5eqf/test/UR5EQF_link.dll и скопируйте его в корневой каталог программы.

Как установить связь, например:

· устанавливаете курсор «мышки» на поле позывной.
· нажимаете левую кнопку и, удерживая ее, перемещаете курсор к полю внешней программы, с которым нужно установить связь.
· отпускаете кнопку «мышки».
· если связь установлена, поле изменит свой цвет на серый. Справа от поля станет активной кнопка, нажатием на которую, можно «разорвать» связь.
· таким образом, при необходимости можно установить связи с другими полями.

После этих действий будет установлении связь с внешней программой и логом. При изменении соответствующих полей в логе, будут изменяться значения полей во внешней программе, и наоборот.
Сохранить QSO можно нажатием кнопки «Save QSO» или воспользоваться «горячей клавишей», в нашем примере Alt+S. Вы эту клавишу можете заменить на любую другую.


Просмотр

Меню "Просмотр"

Внутренние справочники:

· внутренние справочники;
· обновить внутренний справочник позывных из текущего журнала;
· обновить внутренний справочник позывных из RDA.dbf;
· обновить внутренний справочник позывных из RIC.dbf;
· искать в справочнике позывных:
▪ если позывной изменился;
▪ после перехода на другое поле.
· подключить справочники:
▪ имен;
▪ городов;
▪ внутренние справочники.

Внешние базы справочников позывных;

Поиск в справочнике позывных QRZ.COM;

Поиск позывного в журнале;

Дипломы:

· статистика по дипломам:
· статистика по дипломам;
· перечень дипломов;
· обновить статистику по всем дипломам.
· формирование заявок на дипломы;

Префиксы:

· редактирование списка префиксов;

SSTV:

· показать SSTV картинки;
· показать SSTV список позывных.

Omni-Rig:

· показать;
· ничего.

Расчет прохождения на КВ;

Маяки.


Модули

Меню "Модули"

Контест-модуль + Advanced CW machine;

Запуск контестового модуля и программы CW Type для телеграфной манипуляции.

Модуль цифровых видов связи.

Запуск встроенного модуля для цифровых видов связи - RTTY, PSK, MFSK.


Быстрый запуск

Меню "Быстрый запуск"

Band Master

Запуск программы Band Master. Ее можно скачать, кликнув мышкой по названию программы.

S.W. Listening

Список многих радиовещательных станций мира. Время указано по UTC. Синим цветом выделены радиостанции, работающие в текущий час.

Если кликнуть кнопкой мышкой по одной из частот напротив выбранной радиостанции - трансивер будет переключен на эту частоту (при условии, что трансивер соединен с компьютером при помощи интерфейса, CAT-системы).

Ham Cap

Запуск программы Ham Cap. Ее можно скачать, кликнув мышкой по названию программы.

Конфигурация.

В меню быстрого запуска можно указать путь к любым программам, включая не радиолюбительские.

· кликните мышкой по кнопке "Add";
· выберите путь к исполняемому файлу программы;
· введите название этой программы;
· если нужно, чтобы программа автоматически запускалась с программой лога, то в поле "Auto start" поставьте галочку;
· нажмите "ОК".

Любую из этих программ можно будет запустить из меню, созданного пользователем.


Помощь

Меню "Помощь"

"Файл помощи" - надеюсь, он будет Вам полезен и снимет многие лишние вопросы. Файл UR5EQF.chm должен находится в каталоге с программой журнала. По умолчанию - это C:\ur5eqf_log\.

Файл помощи может распространяться без каких-либо ограничений, при этом я не несу никакой ответственности за работу программы аппаратного журнала и за возможную потерю данных в логе.

Помните! Лучший способ сохранения информации - регулярное архивирование и резервное копирование всей папки программы аппаратного журнала на другой физический диск (HDD, DVD, CD, Flash-память и т.д).

Файл помощи написан для версии 2.35 от 01 октября 2008 г. и более поздних версий лога. Его можно скачать по этой ссылке - http://www.cqrivne.com.ua/425DXNews/rz1om/UR5EQF.chm Возможны небольшие различия в описании работы программы, так так программа аппаратного журнала постоянно совершенствуется. Соответственно, стараюсь по возможности регулярно делать изменения в файле помощи.

Критика приветствуется, только прошу учесть, что я не программист и это мой первый опыт в написании help-файла ("...не стреляйте в пианиста, он играет, как умеет...." :))

"Форум UR5EQF LOG" - на http://forum.qrz.ru/thread12480.html делимся впечатлениями о работе программы. Ваши предложения и замечания окажут неоценимую помощь в дальнейшей разработке и улучшении программы.

"Проверить обновление программы" - если компьютер подключен к сети Интернет, то можно узнать о наличии новой версии программы лога и сделанных изменениях и дополнениях, а также скачать обновление.

"О программе" - можно узнать дату и номер текущей версии аппаратного журнала.

"Регистрация" - Вы можете зарегистрироваться в списке пользователей программы аппаратного журнала.

Огромное спасибо автору - Владимиру UR5EQF - за отличную программу лога! За его бескорыстный труд, терпение и понимание.

Свежие версии программы, обновления документации и файлы с обновленным списком территорий вы можете найти в Интернете на странице автора: http://ur5eqf.com/ , тестовые версии здесь - http://files.ur5eqf.com/ .

Все вопросы, пожелания, дополнения и исправления по файлу помощи прошу присылать на e-mail: rz1om@yandex.ru, по ICQ #14297580, либо почтой на адрес:

Сергею Бушкову, а/я 389, г. Архангельск, 163000, Россия

тел. 8 909 556 26 58 (моб. Билайн)

73! de Serge RZ1OM


Создание нового журнала

Если Вы планируете работать с несколькими аппаратными журналами, тогда в папке logs можно создать папки с именами позывных. В этих папках будут храниться файлы для отдельных логов.

Например, нужно создать логи с позывными RZ1OM, RZ1OM/4, RZ1OM/9 и TEST. Путь к вновь созданным логам будет следующий:

C:\ur5eqf_log\logs\RZ1OM

C:\ur5eqf_log\logs\RZ1OM_4

C:\ur5eqf_log\logs\RZ1OM_9

C:\ur5eqf_log\logs\TEST

Обратите внимание, что в названии файлов и папок нельзя использовать знак "дроби", вместо него лучше использовать знак "подчеркивание".

Теперь нужно определиться, как будет вестись статистика по логам. Если статистика ведется по разным логам, тогда нужно устанавливать разные индексы для каждого лога. Если делать общую статистику по нескольким логам, то этим логам нужно присвоить один и тот же индекс. Откройте файл asets.dat, который находится в папке программы лога. Его можно отредактировать любым текстовым редактором. По умолчанию значения индексов - A, B, C, D (и т.д.), их названия можно изменить.

Например, я для своих логов отредактировал файл asets.dat таким образом:

RZ1OM

RZ1OM_9

TEST

Статистику по логам RZ1OM и RZ1OM/4 я планировал сделать общую, а по логам RZ1OM/9 и TEST - раздельную. Поэтому при создании журналов в поле "Индекс" для RZ1OM и RZ1OM/4 нужно указать индекс "RZ1OM", а для RZ1OM/9 и TEST - соответственно "RZ1OM_9" и "TEST" для каждого лога.

Если Вы ведете только один лог на свой позывной, то все, что описано выше, можно пропустить, а индекс для своего лога выбрать по умолчанию (например, "А")

Создание нового журнала

Переходим в меню "Журнал", "Операции с журналом", "Создать новый журнал".

В открывшемся окне напротив строки "Позывной" введите нужный позывной, далее введите данные QTH, имя, номера ITU и CQ зон, Grid-локатор или точные координаты своего QTH. Если не знаете точного локатора или координат, введите приблизительные. На работе программы это не скажется, но расстояние и азимут до корреспондента будут определяться с погрешностью введенных Вами координат.

В поле "Индекс" выберите нужный индекс.

В поле "Описание" можно сделать краткое описание лога, например "Мой основной лог", или оставить его по умолчанию, как есть.

В поле "Имя файла" нажмите на значок открытой папки и выберите каталог, где будет создана база данных журнала. По умолчанию - C:\ur5eqf_log\logs\.

Но если Вы планируете работать с несколькими логами, то лучше разместить их в разных папках, как описано выше. Выберите папку с именем нужного лога и в строке "Имя файла" введите позывной.

Нажмите на кнопку "Создать". Таким образом, можно создать несколько аппаратных журналов - для повседневной работы, для работы из других QTH или логи для соревнований.


Конфигурация журнала

В меню "Журнал", "Операции с журналом" выберите "Конфигурация журнала".

Выберите нужный лог, в нижней части таблицы отредактируйте данные, затем их сохраните.

Иногда может возникнуть ситуация, когда созданный ранее аппаратный журнал больше не нужен. Его можно удалить из списка, кликнув правой кнопкой мышки на выбранном журнале, затем выберите "Удалить журнал".

Журнал будет удален из списка, но база данных этого лога останется в каталоге C:\ur5eqf_log\logs\.... Лог можно восстановить, если правильно указать путь к его базе.

Если эта база больше не нужна, файлы можно удалить вручную.


Открытие текущего журнала

В меню "Журнал", "Операции с журналом", "Открыть журнал" выберите нужный лог из списка.

Или просто нажмите на строку с названием текущего журнала и выберите нужный лог.


Порядок редактирования полей

Здесь можно установить очередность перехода из одного поля в другое при нажатии клавиш Enter или TAB.

Например, после ввода позывного нужно перейти в поле переданного RST, затем в поле принятого RST, затем в поля "Имя", "QTH".

Для этого зайдите в меню "Установки", "Настройка журнала", "Порядок редактирования полей".

· В открывшемся окне поставьте галочки только в тех полях, где нужно делать ввод данных и какие-то изменения.
· Удерживая левой кнопкой мышки нужное поле, перетащите его на нужную позицию, вверх или вниз.
· После редактирования списка нажмите ОК.

Для примера:

Сейчас при нажатии на клавишу Enter или TAB будем переходить в нужные поля в такой очередности, как мы указали. Из последнего поля опять попадаем на первое и так по "кругу".

Если клавиша Enter задействована для сохранения QSO, то после прохода "по кругу" при очередном нажатии на Enter текущая связь будет записана в лог.


Ввод записи для SWL

В программе лога также предусмотрен ввод QSO для наблюдателей (SWL).

· В окне ввода позывного нажмите на значок swl , откроется дополнительное окно.

· Введите в этом окне позывной и данные одного из услышанных корреспондентов.
· Введите в основном окне позывной и данные другого корреспондента.
· Нажмите на значок save в верхней левой части окна ввода позывного или нажмите на клавиатуре ALT+S. Оба позывных будут записаны в лог.


Очистка всех полей

Быстро очистить информацию во всех полях в окне ввода позывного можно нажатием на клавишу "Pause/Break", либо нажатием на значок clear в левом верхнем углу окна, ниже главного меню.

Можно добавить еще одну кнопку очистки полей из меню "Установки", "Установка "горячих клавиш".

· нажмите на кнопку "Edit" напротив поля "Clear new QSO";
· установите курсор в поле "Clear new QSO";
· нажмите нужную Вам клавишу (или сочетание клавиш) на клавиатуре;
· нажмите кнопку "Save".


Сохранение QSO

Сохранить текущую связь можно нажатием клавиш Alt+S, либо нажать на значок save в верхней левой части окна ввода позывного. Данные QSO будут записаны в лог.

В меню "Установки", "Установка "горячих клавиш" можно изменить сочетание клавиш для записи QSO, используемых по умолчанию.

· нажмите на кнопку "Edit" напротив поля "Save QSO";
· установите курсор в поле "Save QSO";
· нажмите одну из клавиш ALT, CTRL или SHIFT, и удерживая ее, нужную Вам клавишу на клавиатуре;
· нажмите кнопку "Save".

Внимание! Некоторые сочетания клавиш используются операционной системой и переназначение их может привести к ошибкам.

Текущую связь можно сохранять нажатием на клавишу Enter, для этого в меню "Установки", "Настройки программы", "Использовать клавишу Enter", далее выбрать один из трех пунктов:

· для работы в режиме pile-ip. В этом случае связь будет записана при вводе позывного и нажатии на клавишу Enter. Никакой другой информации вводить не требуется. Этот режим предназначен специально для работы в экспедициях.
· для сохранения текущего QSO. В этом режиме после ввода позывного курсор будет перемещаться при каждом нажатии на клавишу Enter в поля, определенные в порядке редактирования полей. Можно вводить или изменять информацию в этих полях. При возвращении курсора в поле "Позывной" и нажатии на Enter связь будет записана в лог.
· ничего. Клавиша Enter не будет использоваться для сохранения текущей связи.

Предусмотрена автоматическая запись в лог при работе телеграфом и в режиме цифровых видов связи при завершении QSO, для этого нужно использовать соответствующие макрокоманды для CW и "цифры".


Редактирование QSO

Выберите строку с позывным в логе.

Дважды кликните на ней левой кнопкой мышки, либо в меню "Журнал" выберите "Редактировать QSO".

Измените данные в нужных полях и сохраните QSO, кликнув мышкой по кнопке "Закрыть".


Копирование связей в другой лог

Выделите группу связей в логе. Для этого выделите начальную строку, затем нажмите клавишу Shift и удерживая ее, клавишей управления курсора (вверх или вниз) выделите нужное количество связей. Если нужно выделить большое количество связей, то вместо клавиши курсора можно использовать клавиши PageUp или PageDown.

Кликните правой кнопкой мышки на выделенных связях;

В открывшемся меню выберите "Копировать в другой лог";

В окне "Копировать в другой журнал" выберите лог, в который нужно скопировать выделенную группу связей;

Нажмите ОК.

На запрос "Copy ... records to ... log?" ответить "Yes";

Индикатор в нижней части окна покажет процесс копирования связей в другой журнал.

После этого необходимо обновить статистику по дипломам в том логе, куда были скопированы связи.


Сортировка связей в логе

Для удобства просмотра можно отсортировать связи в логе по следующим параметрам:

· по дате и времени (Ctrl+D);
· по диапазону (Ctrl+B);
· по виду излучения (Ctrl+M);
· по позывному;
· по имени;
· по названию QTH;
· по полю "Штат";
· по полю "Комментарий"

Сортировку также можно выполнить, кликнув левой кнопкой мыши на заголовке любой из колонок в логе. Соответственно, сортировка в окне журнала будет сделана по одному из этих параметров.


Окно предыдущих контактов

При вводе позывного в лог и открытой закладке "Предыдущие контакты" в окне лога отображается список ранее проведенных связей с текущим позывным.

Для удобства это окно можно разделить с основным окном журнала и одновременно просматривать текущие и предыдущие контакты на одном экране.

В этом окне можно также редактировать связи, копировать их в другой журнал, ставить в очередь на печать, делать отметки о получении QSL.

Чтобы подробнее узнать о различном расположении окон программы лога, кликните мышкой по этой ссылке.


Удаление QSO из лога

Чтобы удалить одну или несколько записей в аппаратном журнале, сначала выделите их, затем кликните правой кнопкой мышки и в открывшемся меню выберите "Удалить запись" или нажмите кнопку Del на клавиатуре.

Перед удалением будет выведен запрос. Если нажать "Yes", то связь или группа связей будут удалены.

Помните! Удаленные записи не восстанавливаются!


Очистка и удаление журнала

Очистка журнала может пригодится для временного лога, например контестового или экспедиционного. Сделано для того, чтобы после копирования связей в другой лог не удалять этот журнал и затем не создавать его заново для других контестов или экспедиций.

Выберите в меню "Журнал", "Операции с журналом", "Очистить текущий журнал".

Появится окно с запросом на очистку журнала - "Clear log...?"

Внимание!!! Если нажать на "Yes", то все связи в текущем логе будут удалены без возможности восстановления!!!


Маяки

NCDXF в сотрудничестве с IARU создали всемирную сеть радио маяков на 14.100, 18.110, 21.150, 24.930, и 28.200 Мгц. Эти маяки помогают как любительским, так и коммерческим радиостанциям оценивать текущие условия прохождения и состояние ионосферы.

Можно просто слушать частоты маяков и принимать их позывные, чтобы вычислить, в каком направлении в данное время открыта трасса.

Поскольку маяки передают сигналы строго в определенное время, то легко можно легко узнать, какой маяк работает в текущее время.

Каждый маяк работает ровно 10 секунд. Маяк передает свой позывной телеграфом максимальной мощностью в 100 ватт и использует на передачу вертикальную антенну. Затем в течении нескольких секунд идет нажатие поочередно мощностью 100 ватт, 10 ватт, 1 ватт и 0.1 ватт. После этого он прекращает передачу и начинает работу следующий маяк.

Очередность работы маяков:

1. 4U1UN

2. VE8AT

3. W6WX

4. KH6WO

5. ZL6B

6. VK6RBP

7. JA2IGY

8. RR9O

9. VR2B

10. 4S7B

11. ZS6DN

12. 5Z4B

13. 4X6TU

14. OH2B

15. CS3B

16. LU4AA

17. OA4B

18. YV5B

Время передачи синхронизировано по эталонным часам.

Можно сделать так, чтобы при запуске программы маяков время часов в Вашем компьютере автоматически синхронизировалось по эталонному времени, но для этого необходимо, чтобы компьютер был подключен к сети Интернет.

В меню "Установки", "Настройка программы", "Синхронизация времени" поставить галочку в поле "Синхронизация времени".

Из списка серверов времени можно выбрать любой и кликнуть мышкой на кнопку "Тест". Если сервер в данное время доступен, то слева напротив адреса сервера появится зеленая "галочка". Если сервер не доступен - то красный "крестик".


Поиск позывного в логе

Быстрый поиск позывного

Находясь в основном окне аппаратного журнала, введите с клавиатуры любой позывной. Клавиатура должна быть переключена в латинский регистр. Автоматически откроется небольшое окошко, где будут отображаться введенные символы:

В окне лога будет найдена первая QSO с этим позывным.

Поиск позывного в журнале

Из меню "Просмотр", "Поиск позывного в журнале" (или нажатием клавиш ALT и F)

Введите позывной и кликните мышкой на "Искать". Все связи с этим позывным будут выведены в окне.

Поиск позывного можно производить по маске %, поставив галочку впереди или сзади поля позывного (или обе галочки сразу).

Выше показан пример поиска QSO по маске:

· Если убрать обе галочки и набрать R1ANF, то будут найдены связи только с этим позывным.
· Если поставить галочку только впереди поля позывного, то при поиске R1ANF будут выведены связи с R1ANF и LU/R1ANF.
· Если поставить галочку только позади поля позывного, то будут выведены связи с R1ANF и R1ANF/P.
· Если поставлены обе галочки, то в окне выводятся связи с LU/R1ANF, R1ANF, R1ANF/P.


Поиск предыдущих QSO

· ведите позывной в поле "Позывной";.
· выберите закладку "Предыдущие контакты" внизу окна журнала;
· в окне лога будут отображены все проведенные ранее контакты с этим корреспондентом, если даже он работал дробным позывным из другого QTH;
· для удобства поиска можно разделить окно на две части и просматривать предыдущие QSO в дополнительном окне;
· предыдущие связи можно искать, воспользовавшись поиском по фильтру.


Поиск во внутренней базе лога

Меню "Просмотр", "Внутренние справочники".

При проведении QSO и сохранении связей в лог данные записываются во внутренний справочник позывных. В эту базу также можно импортировать информацию из других логов или данные из баз RIC, RDA, и URDA, а также вручную водить данные из окна ввода позывного.

При вводе позывного корреспондента информация берется из этого справочника. Если данные в справочнике отсутствуют, тогда информация выводится из базы QRZ.COM при условии, что она подключена к логу.

В внутреннем справочнике позывных можно найти и отредактировать позывной, имя, QTH и другую необходимую информацию, а также ввести данные о новом позывном.


Поиск в базе QRZ.COM

Если подключена база позывных QRZ.COM на CD-ROM или на жестком диске, то можно ввести позывной, нажать на "Search" и получить информацию о позывном, если данные есть в этой базе.


Поиск по фильтрам

Кликните левой кнопкой мышки по значку filters в окне ввода позывного, ниже строки "Азимут". Откроется окно фильтров, с помощью которых можно найти и отсортировать нужные связи.

Одновременно можно производить поиск по многим параметрам.

· Поставьте "галочки" в нужных полях.
· Введите или выберите необходимые данные.
· Нажмите ОК.

В окне лога будут выведены все QSO, соответствующие заданному фильтру.

Если поставить галочку напротив поля "Количество уникальных записей" и нажать "Вкл", то в этом поле будет выведено количество позывных в логе без учета повторных связей.

Если поставить галочку напротив поля "Количество повторений QSO", ввести любое число (от 1 до 20) и нажать "Вкл", то в окне лога будут выведены все связи с позывными, встречающимися в логе указанное число раз.

Реализована возможность находить подстроки в искомой строке. В качестве условия используются групповые символы, которые могут соответствовать чему-нибудь. Имеются два типа групповых символов:

Символ подчеркивания ( _ ) замещает любой одиночный символ. Например, b_t будет соответствовать словам bat или bit, но не будет соответствовать brat.

Знак процента (%) замещает последовательность любого числа символов (включая символы нуля).

Например %p%t будет соответствовать словам put, posit, или opt, но не spite.

%p будет соответствовать словам, заканчивающимся на букву p.

%p% будет соответствовать словам, содержащим на букву p.

p% будет соответствовать словам, начинающимся с буквы p.

Например, нужно найти в логе все связи с японскими радиолюбителями из первого района, которые содержат в позывном символы J*1***.

Поставьте галочку в поле DXCC и выберите страну JA, чтобы в окно лога не попали позывные с префиксами JT, JW, JD и других стран.

Поставьте галочку в поле "Callsign mask", наберите в строке J_1_%, или J_1%, или J%1%, затем нажмите ОК.


telnet DX кластер

Компьютер должен быть подключен к сети Интернет и должны быть сделаны настройки подключения к Интернет в логе.

Чтобы подключиться к Telnet кластеру, нужно выбрать закладку Telnet DX cluster и кликнуть по значку tenetdxon в левом верхнем углу окна.

На скриншоте показано подключение к telnet-кластеру в узле RN6BN. Данные об узлах содержатся в в файле nodelist.dat, который можно отредактировать любым текстовым редактором.

При подключении, в зависимости от настроек кластера, выводится приветствие, а также прогноз прохождения на текущее время и другие данные.

Споты выводятся ниже приветствия в этом же окне.

Вверху этого окна можно перейти на закладку "Споты". Откроется окно со спотами кластера.

Это окно дублирует предыдущее, но в нем отображаются только те споты, которые указаны в настройках кластера. То есть, если убраны галочки с ненужных Вам диапазонов и видов модуляции, то в этом окне не будет отображаться лишняя информация.

При условии, что компьютер соединен с трансивером при помощи интерфейса, можно мгновенно перейти на частоту DX, кликнув дважды левой кнопкой мышки по выбранному споту.

На следующей закладке - "Прохождение" - отображается информация о текущем прохождении на КВ.

WWV: SFI=69 A=2 K=1 NO STORMS ; NO STORMS 8/21/2007 12:00Z

SFI - солнечная активность (чем больше число, тем больше вероятность прохождения радиоволн на более высоких КВ-диапазонах);

А - коэффициент поглощения в ионосфере за прошедшие сутки;

К - коэффициент поглощения за текущее время (чем меньше - тем лучше);

далее в строке - наличие возмущений, магнитных бурь, и.т.д.;

На закладке "Сообщения" выводится различные сообщения, оповещения от других пользователей сети кластера, предназначенные для всех.

На закладке "Приват" - сообщения, которые приходят Вам лично через сеть кластера. Как отправить сообщение другому корреспонденту - можно посмотреть здесь.

На закладке "Setup Telnet" можно ввести информацию, которая будет выводиться по умолчанию в каждом споте. Это полезно для работы в контестах, где нужно быстро дать спот, не затрачивая времени на ввод одних и тех же данных.

Отправка спота из telnet DX кластера

· В окне ввода позывного введите позывной DX-а.
· В окне telnet DX кластера кликните по значку tenetDXs.
· В открывшемся меню выберите "Отправить спот telnet" или "Отправить спот telnet без диалога"
· Если выберете "...без диалога" - спот будет немедленно отправлен.
· Если первое - то откроется окно:

В этом окне можно откорректировать частоту, на которой работает DX, и в строке "Info" ввести дополнительную информацию, например о QSL-менеджере, слышимости DX-а и прочее.

Кликните мышкой по кнопке "Send" или нажмите на клавишу Enter. Спот будет отправлен и эта информация будет доступна всем пользователям сети кластера. Вы можете проконтролировать отправленный Вами спот, он должен отобразиться в окне telnet DX кластера.

Быстрая отправка спота в telnet-кластере

При введенном позывном в логе нажмите клавиши CTRL + ALT + ENTER, будет отправлен спот с информацией, которая указана в строке "Enabled Spot Info" на закладке "Setup Telnet".

Голосовое и CW оповещение

В нижней части окна telnet-кластера поставьте галочку в поле напротив "Voice info" или "CW info". При появлении спота в кластере позывной DX-а будет воспроизводиться либо голосом, либо телеграфом. Скорость "морзянки" регулируется клавишами PageUp или PageDown в цифровом модуле, в режиме CW.

При снятых галочках в полях Only "DXCC", "BM" или "From file" оповещение выводится по всем спотам подряд.

Соответственно, при установленных флагах в полях:

· "DXCC" - оповещение производится по спотам с новой территорией по DXCC;
· "BM" - по новому диапазону или новому виду модуляции ("B" - band, диапазон, "M" - mode, вид модуляции );
· "From file" - по списку позывных в файле.

При первом открытии значка папки напротив поля "From file" программа предложит создать текстовый файл. В этот файл введите нужные позывные (без каких либо дробей) в колонку сверху вниз и сохраните его. Этот файл можно редактировать. Очень удобная функция для отслеживания каких-то экспедиций или отдельных позывных в кластере.


Отправка спотов в DX кластер

Отправка спотов в www DX кластер описана тут.

Более удобный способ отправки спотов - через telnet DX кластер.


Отправка сообщений через кластер

Иногда возникает необходимость дать сообщение корреспонденту, подключенному к кластерной сети.

Если отправить сообщение через кластер как спот, то оно будет доступно всем. Но чтобы не загружать кластер лишней информацией, которая предназначается конкретному корреспонденту, можно отправить сообщение, которое будет доступно только ему.

Нужно знать, к какому узлу кластера подключен нужный корреспондент. Если к тому же узлу, что и Вы, тогда выполните следующее:

Самый простой способ - нажмите на клавиатуре сочетание клавиш Alt+T.

(Либо в окне telnet DX кластера кликните по значку tenetDXs и в открывшемся меню выберите "Отправить команду")

Откроется окно:

В строке "Command" наберите t или talk, затем пробел и позывной корреспондента.

В нижней строке введите информацию, обязательно латинским шрифтом.

Нажмите на клавишу Enter или кликните мышкой по кнопке "Send" - информация будет отправлена.

Если корреспондент так же использует программу UR5EQF LOG, то полученная информация сразу отобразится в строке, в самом низу окна ввода позывного. Это позволит не пропустить сообщение, если даже Вы не просматриваете кластер.

Все пришедшие Вам сообщения сохраняются в окне на закладке "Приват" в окне telnet-кластера. Их можно так же просмотреть в любое время, до выхода из программы лога.

Пример использования команд для общения по кластеру можно просмотреть по этой ссылке.


Меню "Вид"

В этом меню можно изменить вид модуляции. В программе предусмотрены несколько видов - GMSK, FSK, FSK-W, BPSK-J, BPSK, RTTY-L, RTTY-U, MFSK-L, MFSK-U.

Вид модуляции можно переключить еще одним способом, описанным здесь.

Скорость обмена данными в цифровых режимах устанавливается в поле "Скорость". Например, чтобы принимать или передавать в режиме BPSK63 или BPSK125, выберите режим BPSK, а в поле "Скорость" выберите соответственно значение 62.5 или 125.

Ниже на скриншоте показаны установки для BPSK125:


Меню "Опции"

Для настройки выходного каскада передатчика из меню "Опции" включается и выключается тональный сигнал на передачу.

Эту же операцию можно сделать, нажав на кнопки [image] (настройка передачи) и [image] (завершение настройки).


Настройка модуля

В модуле цифровых видов связи откройте меню "Конфигурация", "Режим соревнований".

· установите галочку в в поле "Режим соревнований";
· поставьте галочку в поле "Общий номер", если предполагается сквозной порядковый номер для всех видов модуляции или снимите галочку, если для каждого вида модуляции свой порядковый номер связи;
· установите временной интервал в минутах в нужных полях, если в правилах соревнований предусмотрено ограничение на переход на другой диапазон или вид модуляции;
· сохраните изменения.

· кликните кнопкой мышки по значку state и выберите название контеста;
· кликните кнопкой мышки по значку find и еще раз внимательно ознакомьтесь с правилами соревнований;
· перейдите на закладку "Обмен" и введите необходимые данные для обмена контрольными номерами в контесте в соответствии с правилами соревнований;
· сохраните изменения и закройте окно;
· в окне цифрового модуля напротив поля <NR> кликните кнопкой мышки по значку edit1 и отредактируйте макрокоманду для контеста - передаваемый контрольный номер.
· напротив поля "Save to log" кликните кнопкой мышки по значку edit1 и отредактируйте макрокоманду для контеста - записываемый в лог контрольный номер при сохранении связи;


Работа на общий вызов

· для работы на общий вызов в окне контестового модуля поставьте галочки в полях напротив полей "CQ/Find" и "Телеграф";
· курсор должен быть установлен в поле позывной;
· нажмите клавишу "Enter", начнется передача макрокоманды, записанной в F1, например:

СQ RZ1OM RZ1OM TEST

· после окончания передачи трансивер переключится в режим приема. Если вызова не последовало, опять нажмите клавишу "Enter" для передачи общего вызова;
· предположим, Вас кто-то услышал и вызывает. Введите его позывной в поле "Позывной" и нажмите клавишу "Enter". Будет передаваться макрос, записанный в F2, например:

UA3MQM 599 001

· курсор перемещается в поле ввода контрольного номера;
· введите контрольный номер, переданный корреспондентом и нажмите на "Enter". Начнется передача макроса, записанного в F3, например:

QSL TU

· связь автоматически записывается в лог.
· если Вы не приняли контрольный номер корреспондента и это поле пустое, то при нажатии на клавишу "Enter" опять передается макрос, записанный в поле F2.
· можно запрограммировать на одну из функциональных клавиш (например, на F8) отдельный макрос с просьбой повторить контрольный номер (NR? AGN). Тогда при нажатии на F8 начнется передача этого сообщения:

NR? AGN

· если QSO с корреспондентом уже было, то при нажатии "Enter" автоматически передается макрос, записанный в F4, например:

UA3MQM QSO B4 de RZ1OM


Работа на поиск

· для работы на поиск в окне контестового модуля снимите галочку в поле напротив поля "CQ/Find" и оставьте в поле "Телеграф", при этом изменяются названия некоторых кнопок и назначение макросов для этого режима;
· установите курсор поле "Позывной";
· введите позывной корреспондента, которого Вы хотите вызвать и нажмите "Enter". Будет передаваться макрос, записанный в поле F1, например:

RZ1OM

· курсор автоматически перемещается в поле контрольного номера;

если корреспондент Вас не услышал, то при нажатии на клавишу "Enter" опять передается макрос из F1.

· предположим, корреспондент Вас услышал, передает свой контрольный номер. Введите этот номер и нажмите "Enter". Будет передан свой контрольный номер, записанный в макросе F2, например:

RZ1OM 599 005

· можно запрограммировать на одну из функциональных клавиш (например, на F7) отдельный макрос с повторением своего контрольного номера. Если корреспондент не смог принять Ваш контрольный номер с первого раза, то можно нажать на F7, начнется передача:

599 005

· наконец корреспондент принял Ваш контрольный номер и дальше дает общий вызов. Нажмите на клавишу "Enter", связь будет записана в аппаратный журнал.


Добавление контеста в список

Окно с описанием правил для контестов можно открыть из меню "Модули", "Контест-модуль + Advanced CW machine", нажать на значок stat напротив названия контеста.

Это же самое окно можно открыть из меню "Модули", "Модуль цифровых видов связи", в меню "Конфигурация" выбрать "Режим соревнований", поставить галочку в поле "Режим соревнований" и нажать ОК. Напротив названия контеста нажать на значок find .

Добавление нового контеста в список

· Меню "Модуль", "Контест модуль + Advansed CW machine";
· Напротив строки с названием контеста кликните по значку "Правила соревнований";
· Напротив строки с названием контеста кликните по значку с зеленым плюсом;
· На вопрос "Add new rules" ответьте "Yes";
· Введите имя контеста;
· На закладке "Обмен" выберите формат контрольного номера;
· На закладке "Правила" - введите информацию о контесте, можно скопировать данные из раздела "Соревнования" на http://www.qrz.ru/contest/;
· Сохраните изменения.


из аппаратного журнала

Обновление из аппаратного журнала

При сохранении QSO в аппаратный журнал информация о позывном, имени и QTH сохраняется во внутреннем справочнике позывных.

Можно иметь сколько угодно созданных аппаратных журналов в программе, но данные из них будет сохраняться в одном общем справочнике.

При вводе позывного в лог, если он уже есть в этом справочнике, автоматически заполняются поля "Имя"," QTH", "QSL via", QTH-локатора, Штата. Это повышает оперативность работы, ускоряет и облегчает процесс ввода данных в лог.

Рекомендуется после импорта аппаратного журнала сделать обновление внутреннего справочника позывных.

· в меню "Просмотр", "Внутренние справочники" выберите "Обновить внутренний справочник позывных из текущего журнала".

· внизу основного окна лога появится индикатор процесса обновления. Обновление может занять достаточно большое время, в зависимости от количества связей в текущем журнале и от производительности компьютера.

· данные из нового лога будут экспортированы во внутренний справочник позывных. Тогда и при работе с другими журналами, даже если этого позывного не было в текущем логе, при вводе позывного поля "Имя", "QTH" (и др.) будут заполнены информацией из внутреннего справочника.

После импорта нового аппаратного журнала можно заполнить поля "Штат", "Имя", "QTH", Менжеджер" и "Grid" в этом логе из внутреннего справочника позывных, для наиболее точного отражения статистики по дипломам.

· в меню "Журнал", "Операции с журналом" выберите "Обновить поля "Штат", "Имя", "QTH", Менжеджер" и "Grid" из внутреннего справочника".
· в открывшемся окне поставьте галочки напротив тех полей, которые Вы хотите заполнить в логе.

· нажмите ОК и дождитесь обновления данных в журнале.

Также во внутренний справочник можно ввести информацию о корреспонденте без записи ее в аппаратный журнал.

Предположим, Вы услышали корреспондента, ввели все его данные, но связь не состоялась по каким-то причинам. Эти данные можно сохранить во внутреннем справочнике, кликнув левой кнопкой мышки по значку save1 в окне ввода позывного. В следующий раз, когда Вы введете этот позывной, вся ранее сохраненная информация о корреспонденте будет будет выведена из внутреннего справочника и будет отображаться в соответствующих полях.


из базы RDA/URDA

Обновление из базы RDA/URDA

Полезно пополнить внутренний справочник позывных данными из баз RDA и URDA.

Базы в формате zip можно загрузить по этим ссылкам:

· RDA;
· URDA.

Если ссылки не работают - обращайтесь к Сергею RZ1OM, постараюсь помочь.

Также обновления можно регулярно отслеживать на сайте http://www.cqrivne.com.ua/425DXNews/rz1om/ , особая благодарность Игорю UR5KCC за предоставленное место на ftp-сервере.

· В меню "Просмотр", "Внутренние справочники" выберите "Обновить внутренний справочник позывных из RDA.DBF"
· Внизу основного окна лога появится индикатор процесса обновления. Обновление может занять какое-то время, в зависимости от количества позывных в базе RDA и от производительности компьютера.
· При вводе российского или украинского позывного в поле "Штат" будет автоматически введен номер по RDA из внутреннего справочника позывных, разумеется, если информация о позывном и номере по RDA (URDA) есть в этом справочнике.
· Рекомендуется после обновления внутреннего справочника позывных сделать обновление статистики по дипломам.


из базы Russian Internet Callbook

Обновление из базы Russian Internet Callbook

В программе аппаратного журнала есть возможность обновлять базу данных из Russian Internet Callbook.

· базу можно загрузить по этой ссылке, файл в формате zip размером около 2 Мб;
· в меню "Просмотр", "Внутренние справочники" выбрать "Обновить внутренний справочник позывных из RIC.DBF";
· внизу основного окна лога появится индикатор процесса обновления. Обновление может занять какое-то время, в зависимости от количества позывных в базе RIC и от производительности компьютера;
· рекомендуется после обновления внутреннего справочника позывных сделать обновление статистики по дипломам.

Если вдруг вместо имен и названий QTH отображаются значки #####, значит проблема с кодировкой шрифтов. Один из простых способов это исправить - скачайте рабочую базу по этой ссылке, разархивируйте файл. В нем содержится инструкция, как скопировать базы в папку с программой лога.

К сожалению, хоть база и обновляется регулярно, но в ней много устаревшей и неправильной информации. Поэтому в настоящее время я рекомендовал бы не делать обновление из RIC. Практически вся информация уже есть в базах по этой ссылке, а также в инсталляционном пакете программы лога.


Создание дипломов для текущей статистики

В окне перечня дипломов можно создать условия дипломов, по которым будет отображаться текущая статистика при вводе позывного в лог.

Можно показать это на примере простого диплома "EPC Members Award" ("Работал с членами клуба "European PSK Club"):

· возьмите с официального сайта клуба EPC список позывных - членов клуба;
· отредактируйте его в текстовом редакторе так, чтобы файл имел следующий формат:

MM0DFV,,EPC#001

GM0WRR,,EPC#002

RZ1OM,,EPC#003

G3SEM,,EPC#004

PA0MIR,,EPC#005

и так далее - позывной, запятая, значение поля "Code", запятая, членский номер в клубе. Для данного диплома поле "Code" пустое, но для других дипломов в этом поле может стоять префикс, название района и т.д. Примеры приведены ниже;

· сохраните файл, присвоив ему расширение .stc1 (например, EPC.stc1);
· в центре окна "Перечень дипломов" кликните кнопкой мышки по кнопке "Новый", чтобы добавить запись о новом дипломе;
· в строке "Описание" введите название диплома (например, EPCMA "EPC Members Award");
· выберите в "Поле для статистики" значение Call-Sign (Позывной);
· выберите в поле "Тип диплома" - OTHER (Другой);
· если при вводе позывного нужно будет показывать текущую статистику по этому диплому, поставьте галочку в поле "Show in statistics on the entered call-sign" ("Показать статистику по введенному позывному");
· в полях "Допустимые значения" (по DXCC и префиксам) оставьте пустые значения либо очистите эти поля, так как членами клуба EPC могут быть радиолюбители всего мира и на этот диплом может быть засчитан любой позывной;
· в полях "Символ" и "Длина" можно оставить нулевые значения;
· в центре окна кликните мышкой по кнопке "Принять", название вновь созданного диплома появится в списке дипломов;
· кликните кнопкой мышкой по строке "Создать новый файл";
· в открывшемся окне введите имя файла (например EPC) и нажмите ОК;
· в строке "Файл диплома" появится название файла (например EPC.db);
· кликните мышкой по кнопке "Импорт" в нижней части окна;
· укажите путь к текстовому файлу EPC.stc1 и нажмите "Открыть". Текстовый файл будет импортирован в базу диплома;
· закройте окно;
· обновите статистику по дипломам из меню "Просмотр", "Дипломы", "Статистика по дипломам".

Таким образом, начиная с создания простых дипломов, можно научиться создавать файлы статистики для более сложных условий дипломов.

Пример для диплома RDA:

AB-01,UA8V,"Агинский р-н"

AB-02,UA8V,"Дульдургинский р-н"

AB-03,UA8V,"Могойтуйский р-н"

AD-01,UA6Y,Майкоп

AD-02,UA6Y,Адыгейск

AD-03,UA6Y,"Гиагинский р-н"

..........

Пример для диплома "Worked All Ukraine":

UR1A,SU,Сумы

UR1B,TE,Тернополь

UR1C,CH,Черкассы

UR1D,ZA,Закарпатье

UR1E,DN,Днепропетровск

..........

Экспорт условий диплома в текстовый файл

· кликните кнопкой мышки по выбранному диплому;
· в нижней части окна нажмите на кнопку "Экспорт";
· сохраните файл. По умолчанию его имя будет такое же, как у файла базы диплома, а расширение - .stc1;

Файл можно открыть любым текстовым редактором. В дальнейшем файл можно отправить коллегам для того, чтобы они могли сделать импорт этого диплома в свою базу.


Статистика по дипломам

Запускается из главного меню "Просмотр", "Дипломы", "Статистика по дипломам".

В процессе работы с аппаратным журналом ведется постоянная статистика по основным дипломам, перечень которых можно редактировать.

По умолчанию при запуске "Статистики по дипломам" отображается статистика по диплому DXCC и всем видам модуляции. Результаты статистики отображаются в правом верхнем углу.

В поле "Статистика" можно выбрать любой из дипломов в списке: WPX, DOK, DXCC, RDA, RUSSIA, URDA, P-75-P, WAZ, IOTA, WAS и множество других, которые Вы можете добавить в этот список.

Можно вывести статистику по отдельным видам модуляции. Поставьте галочки напротив выбранных видов и кликните мышкой по кнопке "Обновить".

Можно изменить цветовую гамму, которой обозначается отправка QSL и подтверждение связей, для этого кликните правой кнопкой мышки по выбранному полю внизу окна и подберите подходящий цвет. На скриншоте выше выбран цвет, которым в логе по умолчанию отмечается учет QSL-почты и подтверждение QSO.

Также засчитываются подтверждения с сайтов LoTW и e-QSL.

Кликнув дважды левой кнопкой мышки по названию территории в правой части окна, Вы можете вывести в окне лога все связи с этой территорией.

Если кликнуть мышкой по прямоугольнику в пересечении названия территории и диапазона, то в окне лога будут выведены все связи с этой территорией на выбранном диапазоне.

Если статистика по выбранному диплому в "Статистике по дипломам" и при формировании заявки на диплом отличается, то можно перейти на главу "Решение проблем".


Обновление статистики

После импорта других логов в формате ADIF, а также баз RDA, URDA или Russian Internet Callbook обязательно проверьте, нет ли в логе связей с неизвестными территориями, для чего воспользуйтесь поиском по фильтрам.

Если такие связи в логе есть, то в окне редактирования QSO присвойте им территорию по DXCC согласно префикса, чтобы эти QSO вошли в статистику. Это также можно выполнить из меню "Просмотр", "Префиксы", "Переопределять территорию по позывному", тогда всем связям в логе будет присвоена территория по DXCC, согласно их префикса.

Затем обновите статистику по дипломам из меню "Просмотр", "Дипломы", "Статистика по дипломам".

Статистику в логе по наиболее популярным дипломам (DXCC, IOTA, WAZ, P-75-P, RDA, URDA и др.) можно посмотреть в "Статистике по дипломам".

Окно текущей статистики

В режиме ввода позывного можно посмотреть статистику по любому диплому, выбранному в "Перечне дипломов".

· кликните мышкой по значку stat в окне ввода позывного (значок будет неактивен, если окно статистики уже открыто);

Если поставить галочку в поле "Не показывать, если подтвержден", то не будет выведена статистика по тем дипломам, по которым связь с этой территорией уже подтверждена.

Если поставить галочку в поле "Не показывать, если работал", то не будет выведена статистика по тем дипломам, по которым связь с этой территорией уже была проведена.

Можно убрать или добавить список дипломов, статистика по которым будет отображаться в этом окне.


Обработка входящей/исходящей QSL почты

Входящая почта

Для удобства проверки входящей почты можно расположить окна так, чтобы бы открыто окно предыдущих контактов.

Введите позывной с полученной QSL-карточки.

Данные о связи будут отображаться в окне лога. Если было несколько связей с этим корреспондентом, даже если он работал дробным позывным из другого QTH, все они будут выведены в окне.

После сверки данных о связи на QSL выберите строку с этой QSO.

· кликните правой кнопкой мышки на выбранной связи и из выпадающего меню выберите "QSL получена".
· либо дважды кликните левой кнопкой мышки на этой строке, в открывшемся окне напротив поля "Получена" нажмите "Now".

(фрагмент окна)

Автоматически будет поставлена текущая дата и отметка о получении QSL. Если QSL от корреспондента была получена, но Ваша карточка еще не была отправлена, то в логе эта связь будет подсвечена розовым цветом. Если QSL уже была отправлена и получена - тогда светло-зеленым.

Если связь подтверждена через e-QSL, то в поле "Received from eQSL.cc" будет стоять галочка и поле позывного будет подсвечено желтым цветом.

Подтверждение связи с сервиса LoTW отображается в логе светло-зеленым цветом и засчитывается на дипломы точно также, как и получение обычной бумажной QSL карточки.

Исходящая почта

Отметка об отправке QSL ставится автоматически, если пользоваться сервисом печати QSL или наклеек.

Делать отметки об отправке можно вручную, для этого:

· В окне лога дважды кликните левой кнопкой мышки по нужному позывному.
· Напротив поля "Отправлена" нажмите "Now".

Автоматически будет поставлена текущая дата и отметка об отправке QSL. В логе эта связь будет подсвечена голубым цветом, если QSL еще не была получена, либо светло-зеленым, если QSL уже была получена.


Подтверждение e-QSL

Перед использованием сервиса выгрузки и подтверждения связей нужно зарегистрироваться на http://www.eqsl.cc/

Выгрузка проведенных связей из программы лога на e-QSL :

· В меню "Журнал" выберите "Экспорт данных из журнала в..."
· выберите "формат AIDF, на eQSL.cc или DX Atlas".

Откроется окно:

· Выберите интервал дат выгружаемых связей. Не ставьте слишком большой интервал дат, так как загрузка нескольких тысяч связей может занять продолжительное время;
· Поставьте галочку в поле "BPSK to PSK". Если Вы используете для работы в "цифре" режимы BPSK63 и BPSK125, то галочку лучше поставить. При экспорте файла на e-QSL вид модуляции будет преобразован в PSK63 и PSK125 и будет корректно восприниматься сервером eQSL.cc;
· Поставьте галочку в поле "Send to eQSL.cc" и нажмите ОК;

· В открывшемся окне введите логин и пароль для входа на сайт eQSL.cc.
· Если Вы ведете несколько аппаратных журналов, то будьте внимательны при загрузке другого лога, иначе по ошибке Вы можете загрузить на e-QSL связи из одного своего лога в другой. Для каждого Вашего позывного пароль и логин для входа на сайт могут отличаться.
· Нажмите ОК. Данные о связях будут выгружены на eQSL.cc.

Загрузка архива подтвержденных связей из e-QSL в аппаратный журнал:

· В меню "Журнал" выберите "Загрузить архив подтвержденных QSL из eQSL в формате ADIF"
· В открывшемся окне введите логин, нажмите ОК, далее пароль и ОК.
· Откроется окно Internet Explorer (или другого браузера, используемого Вами). Фрагмент можно посмотреть ниже:

· Кликните кнопкой мышки по ссылке ".ADI file". Сохраните файл в выбранной Вами папке на диске.
· Закройте окно Internet Explorer.
· В меню "Журнал", "Сервисы eQSL.cc и LoTW" выберите "Подтвердить получение QSL в ADIF-формате из eQSL.cc"
· Перейдите в папку, где находится сохраненный Вами файл в формате ADIF, выберите этот файл и нажмите "Открыть".
· Индикатор внизу окна лога будет показывать процесс подтверждения связей в логе, обязательно дождитесь его окончания.
· После окончания импорта у подтвержденных связей поля позывных в окне аппаратного журнала будут подсвечиваться желтым фоном.


Подтверждение на LoTW

LoTW - это, условно говоpя, огромный сервер, принадлежащий ARRL, на который радиолюбители могут скачивать информацию о проведенных связях. Пpогpаммное обеспечение, находящееся на сервере, сможет сравнивать информацию о связях, поступивших от разных радиолюбителей и, в случае совпадения данных, "засчитывать" эти связи как подтвержденные. Поскольку эта огромная база данных организована и принадлежит ARRL, подтвердившиеся связи будут засчитываться на выдаваемые ARRL дипломы, например такие, как DXCC, WAS.

Во избежание возможных фальсификаций система LoTW достаточно серьезно защищена. Для того, чтобы разместить в системе данные о своих связях, радиолюбитель должен представить ARRL доказательства того, что именно он является владельцем того или иного позывного. В США для этих целей используется официальная база данных FCC, а иностранные радиолюбители должны представить подтверждающие документы по почте. Участник программы, представивший необходимую информацию, получает "сертификат", т.е. цифровую подпись, которой будет заверяться каждая размещенная в системе LoTW связь.

Вся информация по подключению к этому сервису и получению сертификата есть, например, на этой странице - http://ur7iwz.qrz.ru/ham/lotw.php

Как выполнить выгрузку проведенных QSO на сайт LoTW?

Будем считать, что Вы уже установили программное обеспечение с сайта http://www.arrl.org/lotw и получили сертификат.

· выгрузите файл за нужный период в формат ADIF или Cabrillo.
· запустите программу TQSL.
· в меню "File" выберите "Sign existing ADIF or Cabrillo file" (подписать созданный файл в формате ADIF или Cabrillo)

· выберите из списка (если несколько разных позывных или QTH) нужный позывной и нажмите "OK".
· найдите путь к выгруженному файлу в формате ADIF или Cabrillo и нажмите "Открыть".
· нажмите "Сохранить", откроется окно:

· Файл будет подписан используя данные о позывном и стране по DXCC;
· убедитесь, что все верно и на запрос ответьте "Да". Откроется окно:

Если Вам нужно загрузить данные из ADIF или Cabrillo файла за определенный период, но Вы не помните дат, за какой период ранее были загружены предыдущие связи, то введите в верхней строке начальную дату, а в нижней строке – конечную дату. Данные только за указанный период будут взяты из этого файла и подписаны электронной подписью.

Если вы знаете последнюю дату загруженных связей на LoTW, а выгруженный файл в формате ADIF или Cabrillo начинается со следующей даты, то по умолчанию можно оставить поля пустыми и нажать "Ок".

· Далее – откроется окно, в котором введите пароль. Это тот пароль, который Вы сами вводили при создании своего сертификата (а не присланный Вам с сайта ARRL, он используется только для входа на сайт LoTW). Нажмите «Ок».

· Будет производиться конвертация файла из формата ADIF или Cabrillo в специальный формат с шифрованием и использованием Вашей цифровой подписи для загрузки его на LoTW. Во время конвертации в окне будет отображаться количество подписанных файлов.

· В процессе конвертации может возникнуть ошибка, если формат файла ADIF или Cabrillo содержит "неправильные" данные. Например, для загрузки на LoTW вида модуляции BPSK может появиться ошибка:

Формат ADIF или Cabrillo должен иметь вид модуляции PSK вместо BPSK. Только такой формат поддерживается на LoTW. Это можно легко сделать, указав при выгрузке ADIF-файла преобразование BPSK в PSK или исправить ADIF-файл в любом текстовом редакторе, заменив сразу все связи BPSK на PSK.

Можно выполнять конвертирование видов модуляции в самой программе T-QSL. В меню "File" выбрать "Preferences", закладку "ADIF modes" и ввести вид модуляции, который указан в Вашем логе. Затем сопоставить ему вид модуляции, указанный в программе T-QSL. Тогда при обработке выгруженных из лога файлов в формате ADIF никакой дополнительной правки не потребуется.

На скриншоте показана "подстановка" вида модуляции PSK вместо BPSK:

Если проигнорировать ошибку, то связь подписана не будет, а конвертация продолжиться дальше. Но это делать не рекомендуется, лучше сделать все исправления в ADIF или Cabrillo и заново повторить процедуру подписи файла.

Ниже показано окно с информацией об ошибке при конвертации:

Если файл был сконвертирован без ошибок, то будет выведено окно:

· При этом в каталоге с файлом ADIF или Cabrillo будет создан файл с таким же именем, но с расширением .tq8 (например, rz1om.tq8). Далее:
· зайдите на сайт https://p1k.arrl.org/lotwuser/default, введите логин (свой позывной) и пароль (присланный Вам из ARRL) и выберите «Log On»:
· выберите в меню «Upload File»
· нажмите кнопку «Обзор» и укажите путь к файлу с расширением .tq8
· нажмите «Upload file»
· после окончания загрузки будет выведено сообщение: File диск:\путь_к_файлу\имя_файла.tq8 queued for processing. Также вместо загрузки на https://p1k.arrl.org/lotwuser/default можно отправить созданный файл с расширением .tq8 по электронной почте на адрес lotw-logs@arrl.org

Размещение связей в системе никакой оплаты не тpебует. Оплата потpебуется, если появится желание получить тот или иной диплом, наклейку и пp. На пеpвый взгляд услуги довольно доpоги. Однако если подсчитать стоимость печатания бумажных каpточек, пpиобpетения конвеpтов, оплаты отсылки конвеpта, а также стоимость оплаты обpатной пеpесылки (к пpимеpу, купона IRC), то становится понятно, что услуга достаточно недоpога.

Но все же не стоит забывать, что LOTW (как и eQSL) не заменяет тpадиционный обмен бумажными QSL-каpточками, а наобоpот, только дополняет этот механизм.

Загрузка архива подтвержденных связей из LoTW :

· в меню "Журнал" выберите "Загрузить архив подтвержденных QSL из LoTW в формате ADIF"
· в открывшемся окне введите логин, нажмите ОК, далее пароль и ОК.
· откроется окно Interner Explorer (или другого браузера, используемого Вами).
· в меню кликните левой кнопкой мышки по кнопке "Your QSOs".
· в открывшемся окне кликните левой кнопкой мышки по "Download Report".
· в строке "Show QSLs received since:" установите дату, с какой нужно загрузить подтвержденные QSO.
· можно поставить "галочку" в поле "Include QSL detail: ", если нужны полные данные о связи. Иначе в ADIF будут выгружены только позывной, дата, время, диапазон и вид модуляции. Хотя этого уже достаточно для подтверждения связей.
· в строке "Your Call Sign:" выберите позывной того лога, связи в котором нужно подтвердить.
· нажмите на "Download Report". Откроется окно загрузки файлов, в котором выберите "Сохранить".
· имя файла по умолчанию - lotwreport.adi, его можно оставить, либо изменить на свой позывной, например, rz1om.adi

Подтверждение связей с сайта LoTW в аппаратном журнале

· в меню "Журнал", "Сервисы eQSL.cc и LoTW" выберите "Подтвердить получение QSL в ADIF-формате c LoTW";
· в открывшемся окне выберите файл, загруженный с сайта LoTW и нажмите "Открыть";
· в нижней части лога индикатор покажет процесс загрузки данных в аппаратный журнал.

Все связи в логе будут подтверждены также, как полученные бумажные QSL-карточки. Открыв окно редактирования связи, можно проконтролировать подтверждение в строке "Received from LoTW". Дата подтверждения связи - это дата импорта файла из LoTW, принцип такой же, как и отметка о получении обычной бумажной QSL.


Постановка в очередь на печать

Что бы поместить QSO из лога в список для дальнейшей печати QSL, кликните правой кнопкой мышки на строке нужного позывного или выделенной группы позывных и в открывшемся меню выберите "Поставить QSO в очередь на печать". Строки с позывными в окне журнала будут выделены темно-зеленым цветом.

Точно также, если Вы получили QSL от корреспондента, Вы можете сделать отметку о получении QSL и одновременно поставить эту связь в очередь на печать, чтобы отправить ответную карточку.

Кликните правой кнопкой мышки на строке нужного позывного или выделенной группы позывных и в открывшемся меню выберите "QSL получена + поставить QSO в очередь на печать". Строки с позывными в окне журнала будут выделены темно-зеленым цветом.

Как только Вы решите печатать QSL или наклейки, нужно сделать экспорт поставленных на печать QSO.


Экспорт связей на печать

Меню "Журнал", "Печать", "Печать QSL"

Сканирование текущего журнала можно отслеживать по индикатору в самом низу окна лога и все отмеченные на печать (темно-зеленым цветом в логе) связи будут экспортированы в папку PrintQueue.

Созданные файлы имеют тип XXX-YYYYYY.qpq, где XXX – префикс страны, YYYYYY – позывной корреспондента.

например: UA3L-UA3LMR-P.qpq

Содержимое файла:

RZ1OM;UA3LMR/P;20070822135800;;;;14000000;0;;SSB;59;59;;;Вячеслав;Угранский р-н;TNX for QSO! BEST 73!           RDA AR-35;SM-25;;Russia, Smolenskaya obl;;;;;;;;;;;;;

Вы можете просмотреть все файлы, экспортированные на печать, и отредактировать их при необходимости.

Если получатель карточки имеет менеджера и включена опция "Сортировать по менеджерам", то формат файла XXX – префикс страны менеджера, YYYYYY – позывной корреспондента.

Карточки будут распечатываться в алфавитном порядке по префиксам, с учетом менеджеров, и вам не надо будет дополнительно сортировать отпечатанные для отправки QSL.

Отобранные в очередь для распечатки связи автоматически будут помечены в журнале как отправленные.

После завершения сканирования журнала и отправки QSL в очередь на печать запустится программа QSLprint.


Редактирование файлов очереди на печать

Редактирование файлов очереди печати

После экспорта связей на печать можно просмотреть данные о каждой QSO, чтобы убедиться, что информация в них соответствует действительности.

· откройте меню "Журнал", "Печать", "Редактирование файлов очереди печати";
· кликните кнопкой мышки по любому файлу в окне;
· в средней части окна будут выведены строки с данными связей по выбранному позывному;

· если требуется, в нижней части окна введите информацию о районе, из которого Вы работали, а также позывной QSL-менеджера корреспондента и комментарий;
· нажмите "Save to file", чтобы записать данные в файл и закройте окно;
· теперь можно распечатать QSL или наклейки.


Печать журнала

Аппаратный журнал можно распечатать на принтере из меню "Журнал", "Печать", с сортировкой по дате или позывному.

На скриншоте показан фрагмент распечатки журнала с сортировкой по дате.


Импорт из ADIF

В меню "Журнал" выберите "Импорт данных в журнал из...", далее - "формата ADIF".

Откроется окно:

Ко всем импортируемым записям можно добавить комментарий, который будет отображаться в журнале напротив этих связей.

В нижней части окна кликните кнопкой мышки по значку открытой папки, выберите нужный файл в формате ADIF, затем нажмите ОК.

В программе предусмотрен импорт файлов из аппаратного журнала DX4WIN версии 5.03. Для этого нужно поставить галочку в поле напротив Dx4win v 5.03.

При импорте связей из ADIF-файла, сформированного некоторыми программами аппаратных журналов, не всегда правильно определяется территория, откуда работал корреспондент. Соответственно, эти связи не попадают в статистику по дипломам. Перед импортом файла ADIF можно поставить галочку в поле "Переопределять территорию по позывному", тогда все связи будут импортированы в лог соответственно их префиксам.


Импорт из 425DX News

Вы можете постоянно пополнять базу данных QSL-менеджеров информацией из бюллетеней 425DX News.

Бюллетени в формате баз данных DBF

Откройте сайт http://cqrivne.com.ua/425DXNews/, здесь можно скачать бюллетени в формате баз данных DBF. Импорт DBF-файла будет выполняться со значительно с большей скоростью, чем HTML-файл.

Бюллетени в формате HTML

· откройте страницу в Интернет - http://www.425dxn.org/425/indbulle.html;
· выберите нужный бюллетень;
· сохраните его в формате "Веб-страница, только HTML", указав папку для сохранения файла. Имя файла можно оставить по умолчанию.

Импорт баз 425DXNews в лог

· запустите программу аппаратного журнала;
· в окне ввода позывного нажмите на значок напротив поля "QSL via", откроется окно базы данных QSL-менеджеров;

· В зависимости формата сохраненного файла в верхней части окна выберите значок открытой папки open1:

Для файла "html" - левый значок, для файла "dbf" - правый;

· В открывшемся окне найдите папку с сохраненным файлом;
· Выберите этот файл, нажмите "Открыть";
· Индикатор внизу окна покажет процесс импорта файла.

Ручной ввод информации в базу QSL-менеджеров

Для ввода данных кликните кнопкой мышки по значку new, в открывшемся окне введите информацию о позывном, менеджере и т.д. и нажмите ОК. Для редактирования - нажмите на значок edit, измените информацию и нажмите "ОК".

Чтобы удалить строку с позывным и QSL-информацией - выделите ее и нажмите на значок delete.

Если нужно очистить всю таблицу с базой менеджеров - нажмите на значок [image].


Импорт из текстового файла в ADIF

Форматирование текстового файла

К примеру, нужно импортировать в лог текстовый файл, содержащий следующую информацию:

11-04-2006 09:25 RA9CKM  SSB 14 59  57  Илья Волчанск

15-08-2006 11:26 RW0AW CW 7 599 589 Сергей Канск

17-09-2006 16:31 UN7LN BPSK31 3.5 599 559 Валерий Кустанай

Сначала его нужно отформатировать примерно так, чтобы выровнять все строки:

11-04-2006 09:25 RA9CKM      SSB     14   59  57  Илья       Волчанск

15-08-2006 11:26 RW0AW       CW      7    599 589 Сергей     Канск

17-09-2006 16:31 UN7LN       BPSK31  3.5  599 559 Валерий    Кустанай

Лучше это сделать, применив моноширинный шрифт, в котором все символы имеют одинаковую ширину (типа Courier).

Для позывного желательно оставить до 13 знаков (вместе с "пробелами"), чтобы могли импортироваться "длинные" позывные, например, через дробь. Для вида модуляции достаточно 7-8 знаков, учитывая "пробелы". Для имени и QTH - по Вашему выбору, до 10-20 знаков, но достаточные для того, чтобы импортированные названия не были обрезаны.

Сохраните файл (например, с именем import1.txt).

На примере приведенного выше отформатированного файла видно, что:

· первые 10 знаков от начала строки занимает формат даты;
· 11-й знак в строке занимает "пробел";
· с 12-го по 16-й - занимает формат времени;
· 17-й - знак "пробела";
· с 18-го по 29-й - позывной, включая пробелы;
· с 30-го по 37-й - вид модуляции, включая пробелы;
· с 38-го по 42-й - частота в Мгц, включая пробелы;
· с 43-го по 46-й - RS(T) принятый, включая пробелы;
· с 47-го по 50-й - RS(T) переданный, включая пробелы;
· c 51-го по 61-й - имя, включая пробелы;
· с 62-го по 82-й - QTH, включая пробелы.

Затем нужно создать шаблон согласно этого описания.

Создание шаблона

· в меню "Журнал" выберите "Импорт данных в журнал из...", далее - "текстового файла";
· нажмите на значок открытой папки напротив поля "Файл" и выберите путь к текстовому файлу;
· нажмите "Загрузить файл";
· кликните мышкой по кнопке "Новый шаблон", введите имя файла и сохраните создаваемый шаблон (например, template1.pos)

· в окне загруженного файла выберите любую строку с данными, выделите нужное поле, выберите соответствующее название поля и его формат. На скриншоте показана выделенная дата, соответствующее ей название поля и формат даты.
· поочередно выделите остальные поля, от начала поля до начала следующего, включая пробелы, а также выберите соответствующие названия полей и их формат.
· если в процессе формирования шаблона поле было введено ошибочно, то его можно удалить, нажав клавиши "CTRL + DEL".

В итоге должна получиться примерно такая таблица с данными:

Кликните мышкой по кнопке "Экспорт в Adif file". В той же папке с текстовым файлом будет создан файл в формате ADIF, например, import1_txt_0711190931.adi, который можно затем импортировать в лог.


Экспорт в ADIF

ADIF формат является универсальным стандартом. Его принимают практически все программы аппаратных журналов.

Экспорт файлов в ADIF формат может быть нужен для загрузки в другой лог, для резервного копирования или восстановления базы в случае потери данных.

В меню "Журнал", "Экспорт данных из журнала в...", далее выберите "формат ADIF, на eQSL.cc или DX Atlas".

Откроется окно, в котором выберите период выгрузки данных:

Если Вы пользуетесь сервисом электронных подтверждений на e-QSL и LoTW, то для корректной загрузки файла ADIF на эти сервера лучше вместо BPSK подставить вид модуляции PSK. Значение скорости обмена данными останется прежним (например, вместо BPSK63 - PSK63).

По умолчанию - "Все записи" - будут экспортироваться в файл ADIF все QSO из текущего журнала.

Если установить "Выбрать интервал" и выбрать период дат - будут экспортироваться связи только за этот период.

Если поставить галочку напротив "Выбрать контакты" и нажать на значок filters, откроется окно фильтров, в котором можно задать необходимые параметры и нажать ОК. В окне лога будут отображены все выбранные QSO. Далее - в окне экспорта нажать ОК и сохранить файл.

Если поставить галочку "Показать в DX Atlas" - данные будут экспортированы в DX Atlas.

Можно экспортировать в ADIF группу связей из лога. Выделите необходимые связи в окне лога, кликните правой кнопкой мышки и в открывшемся меню выберите "Экспорт выделенных связей в ADIF", как показано на этом скриншоте. Затем сохраните файл.


Экспорт в Cabrillo

Формат Cabrillo обычно используется для отправки отчетов о соревнованиях.

В меню "Журнал", "Экспорт данных из журнала в..." выберите "Cabrillo".

· в этом окне введите все данные и кликните мышкой по кнопке "Создать";
· индикатор внизу окна покажет процесс создания файла;
· в открывшемся окне выберите название файла и нажмите "Сохранить";
· отчет в формате Cabrillo будет сформирован. Теперь отправьте его по электронному адресу, указанному в правилах соревнований.


Экспорт в MixW2 log

Если для работы в цифровых видах связи вы используете программу MixW2, то можно выгрузить в нее ADIF-файл из UR5EQF LOG:

· в меню "Журнал", "Экспорт данных из журнала в..." выберите "MixW2.log"
· в открывшемся окне выберите имя файла (по умолчанию MixW2.log) и нажмите "Сохранить".
· индикатор внизу основного окна лога покажет процесс выгрузки файла.
· этот файл можно импортировать в программу MixW2.


Экспорт в DX Atlas

Перед тем, как делать экспорт в программу DX Atlas, нужно проверить, установлена ли эта программа на компьютере.

· в меню Журнал", "Экспорт данных из журнала в..." выберите "формат ADIF, на eQSL.cc или DX Atlas".
· установите период, за который нужно вывести данные на карту или глобус. Не задавайте слишком большой период, так как большое количество позывных все равно не уместится на карте.
· поставьте галочку в поле "Показать в DX Atlas" и нажмите ОК.
· запустится программа DX Atlas и в зависимости от установки программы, на глобусе или плоской проекции будут отображаться позывные из лога.

Если навести курсор мышкой на какой-нибудь позывной на карте или глобусе, то в окне "Предыдущие контакты" будут отображаться все связи с этим корреспондентом.


Экспорт в он-лайновый лог

В последние несколько лет стало "модным" иметь свой он-лайновый лог в Интернет. Особенно это актуально для различных экспедиций. Введя свой позывной в такой он-лайновый журнал, любой корреспондент может посмотреть, действительно ли была проведена QSO с этой экспедицией.

Программа аппаратного журнала UR5EQF LOG позволяет выгружать файлы для такого лога и сразу же отправлять их через ftp-сервер на выбранный сайт. Требуется только сделать простые настройки и подключиться к Интернет. Экспорт лога и загрузка его на сайт занимает мало времени и очень оперативна.

Здесь рассматривается загрузка в он-лайновые логи, один из которых создан на уже устаревшем апплете Java, а другой - на более современном PHP-скрипте.

Лог на апплете JAVA

Рассмотрим он-лайновый лог на апплете Java, он сделан известным радиолюбителем G4ZFE. Для запуска апплета на стороне клиента предварительно необходимо инсталлировать бесплатный пакет Java Runtime Environment (~15 Mb), который может быть загружен с сайта разработчика технологии Java(tm) - компании SUN Microsystems - http://java.com . При очередном экспорте в он-лайновый лог добавляются только измененные файлы, что значительно сокращает трафик. Например, при количестве связей в логе примерно около 3-х с половиной тысяч и GPRS-соединении через мобильный телефон, экспорт полного лога на сайт занимает около 1-2 минут, при этом трафик составляет примерно 100 Кб.

Скачайте файл logsearch.zip по этой ссылке - http://www.hamsoft.ru/logs/logsearch.zip, распакуйте его, получив апплет Logsearch.class;

Создайте в любом текстовом редакторе html-страницу с именем logsearch.html, как описано ниже:

Пример простого скрипта для одновременного размещения трех аппаратных журналов, доработанный Владимиром UR5EQF, который может использоваться с минимальными изменениями:

<html>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=windows-1251">

<title>Untitled Document</title>

<style type="text/css">

<!--

.style2 {

color: #0000FF;

font-size: 36px;

}

-->

</style>

</head>

<body>

<div align="center">

<p class="style2">RK1OZM Log Search Page

</p>

<table width="100%" border="0" align="center">

<tr>

<th height="76" scope="col"> <iframe src="rk1ozm/logupdated.html" width=580 height=22 marginwidth=0 marginheight=0 scrolling=no frameborder=1></iframe>

<p align="center">

<APPLET CODE="Logsearch.class" WIDTH=580 HEIGHT=320>

<param name="fileExtn" value="log">

<param name="rowsHead" value="3">

<param name="logName1" value="RK1OZM (AR-03)">

<param name="logName2" value="RK1OZM/P (EU-153)">

<param name="logName3" value="RK1OZM/P (AR-10)">

<param name="URLName1" value="http://rk1ozm.narod.ru/logs/rk1ozm/">

<param name="URLName2" value="http://rk1ozm.narod.ru/logs/rk1ozm_p/">

<param name="URLName3" value="http://rk1ozm.narod.ru/logs/rk1ozm__p/">

<EM>Search applet requires a Java aware browser. Please install Java Runtime Environment from http://java.com</EM>

</APPLET>

</p></th>

</tr>

</table>

<p class="style2">&nbsp; </p>

</div>

</body>

</html>

Нужно скопировать этот скрипт в любой текстовый редактор и отредактировать его - вместо позывного RK1OZM подставить свой позывной. В строке <param name="URLName1" value="http://rk1ozm.narod.ru/logs/rk1ozm/"> указать путь к файлам на своем ftp-сервере.

Если у Вас всего один лог, тогда строки с параметрами "logName2", "logName3" и "URLName2", "URLName3" можно убрать, а в строке с параметром "rowsHead" value="3" поставить "единицу" вместо "тройки".

Затем сохранить этот файл с именем logsearch.html.

В данном примере при вызове апплета ему передаются следующие параметры param name= :
- fileExtn - определяет расширение текстовых лог-файлов;
- rowsHead - устанавливает количество строк в заголовке формы;
- logName1, logName2, logName3 - используются для обозначения checkboxes на форме вывода данных. Предусмотрено использование до 10 checkboxes (каждый из которых определяет один из логов пользователя);
- URLName1, URLName2, URLName3 - определяют ссылки на директории, где размещены текстовые файлы 1.log - z.log

Создайте на вашем сайте http://www.my_test_site.com директорию logs и в ней поддиректории с именами Ваших логов, все в нижнем регистре. Например, rk1ozm, rk1ozm_p, rk1ozm__p.

Поместите в директорию /logs сайта http://www.my_test_site.com следующие файлы:
logsearch.html
Logsearch.class
Регистр имен файлов должен соответствовать приведенному выше.

Каждый аппаратный журнал, который вы планируете разместить, должен быть разделен на несколько текстовых файлов - от 1.log до z.log, для этого в программе аппратного журнала UR5EQF LOG, начиная с версии 2.0.0.8b от 18.01.2007, есть функция автоматического разделения. Каждый файл должен содержать записи начинающиеся с символа, аналогичному имени файла (без расширения).

Пример файла r.log:

R1ANT 24-09-2005 7 RTTY

R2MWO 28-03-2003 14 CW QSLSent QSLRec

RK4WWF 17-06-2002 21 SSB

...

Пример файла 3.log:

3V8BB 01-05-2000 1.8 CW QSLSent

3W4KZ 19-12-2004 10.1 CW

3Z4PZK 17-06-2002 7 PSK31

...

Позывной в каждой строке должен стоять на первом месте и занимать не более первых 12-ти знакомест.

Выберите в меню "Файл", "Экспорт данных из лога в...", "он-лайновый лог и загрузка его на сайт в Интернет".

В появившемся окне введите параметры Вашего ftp-сервера, порт, логин и пароль для доступа к ftp-серверу.

Если Вы подключены к сети Интернет через прокси-сервер в локальной сети, то может потребоваться ввод IP-адреса прокси-сервера и номера порта, а также аутентификация с вводом имени и пароля доступа к прокси-серверу. Для обычного соединения эти поля нужно оставить пустыми. Эти параметры нужно ввести всего один раз, программа их "запомнит".

В строке "Папка на FTP" укажите папку, куда будут загружаться файлы. Обратите внимание, значок дроби, разделяющий названия папок, должен быть "прямой", а не обратный (например, logs/rk1ozm/). Для выгрузки каждого лога не забудьте изменить путь к папке соответствующего лога.

Нажав на значок открытой папки, выберите (или создайте) каталог, куда нужно экспортировать журнал. Затем кликните мышкой по кнопке "Создать файлы в папке". Внизу окна будут отображаться формируемые для выгрузки файлы, с именами от 1.log до z.log.

Далее - подключитесь к ftp-серверу, кликнув мышкой по кнопке "Подключить". Внизу окна при успешном соединении появится надпись "Connected" и кнопка "Загрузить файлы на FTP-сервер" станет активной.

Кликните мышкой по кнопке "Загрузить файлы на FTP-сервер", сформированные файлы начнут загружаться на сервер. Автоматически будет создан файл logupdated.html, который будет скопирован в папку лога на ftp-сервере.

После окончания загрузки в окне появится сообщение об успешной загрузке - "Data Transfer Complete", а внизу окна - сообщение "Disconnected", программа автоматически отключится от сервера.

Нажмите на кнопку "Выход", окно будет закрыто.

В браузере откройте свою страницу http://www.my_test_site.com/logs/logsearch.html, введите любой позывной для проверки.

Окно будет выглядеть примерно так (показан фрагмент):

В окне под заголовком отображается дата последней загрузки журнала на ftp-сервер, данные берутся из файла logupdated.html. Также напротив связей выводятся данные об отправленных и полученных QSL-карточках.

Можно снять галочку напротив любого из трех позывных, тогда поиск в базе напротив этого позывного производиться не будет.

Примечание.

Список параметров для инициализации апплета:

<param name="rowsHead" value="1"> - число строк в заголовке апплета, где отображается перечень логов.
По умолчанию value="1". При большом количестве логов целесообразно увеличить это значение для размещения наименований логов в заголовке.

<param name="fileExtn" value="log"> - расширения текстовых лог-файлов.
По умолчанию: value="log".
Другие варианты: value="txt", value="prn".

<param name="logName1" value="RK1OZM (AR-03)"> - наименование лога.
value может быть присвоено любое значение которое и отображается на форме диалога как наименование лога.
name могут быть присвоены значения: "logName1", "logName2", ... "logName10"

<param name="URLName1" value="http://www.my_test_site.com/logs/rk1ozm/"> - наименование URL директории с файлами данных 1.log - z.log
name могут быть присвоены значения: "URLName1", "URLName2", ... "URLName10"

(часть информации взята с сайта http://www.hamsoft.ru/ , спасибо Дмитрию RW4WM)

Лог на PHP-скрипте

Еще более удобный и современный он-лайновый лог. Не требует пред-установки каких-либо других программ на компьютере пользователя. Здесь производится выгрузка только последних проведенных связей в формате ADIF, что до минимума сокращает трафик и время загрузки на сайт. Информация о связях выводится в таблице, с указанием номера района по RDA (URDA, штата, провинции и.т.д.), откуда Вы проводили связи. Страница поиска выглядит примерно так:

Сначала перейдите на http://www.cqrivne.com.ua/logs/, внимательно ознакомьтесь с инструкцией по регистрации и прочитайте FAQ, затем зарегистрируйтесь.

· в программе лога откройте меню "Журнал", "Экспорт данных из журнала в....";
· выберите "формат ADIF, на eQSL.cc или DX Atlas";
· в открывшемся окне выберите интервал дат, за который нужно выгрузить связи;

· поставьте галочку в поле "Send to Online Log";
· введите логин и пароль, которые Вы вводили при регистрации на сайте, затем нажмите "ОК";
· в открывшемся окне будет выведена информация о количестве связей, загруженных в он-лайновый лог. Вы можете проверить правильность загрузки на основной странице он-лайновых логов.

Выгрузку в он-лайновый лог можно сделать и вручную, если сначала экспортировать лог в формат ADIF, а затем загрузить его на сайт http://www.cqrivne.com.ua/logs/.

(отдельное спасибо Владимиру UA3LPF за разработку скрипта он-лайнового лога и Игорю UR5KCC за размещение скрипта на своем сайте).


CW Type

Для работы телеграфом с клавиатуры можно подключить терминальную программу CwType.

Она позволяет передавать как с клавиатуры, так и с манипулятора, подключенного к игровому или параллельному порту. Управление трансивером осуществляется через последовательный или параллельный порт. При работе с манипулятора программа поддерживает ямбический режим и память элемента знака.

Подробное описание программы можно найти на сайте http://www.dxsoft.com/ru/products/cwtype/. С этого же сайта можно загрузить программу.

Схему интерфейса для подключения к трансиверу и полный список макрокоманд Вы найдете в файле помощи к CwType.

При проведении QSO происходит обмен данными между программой CwType и аппаратным журналом UR5EQF LOG. По окончанию QSO информация в лог может записываться автоматически (в зависимости от установленных макрокоманд).


Работа цифровыми видами с внешними программами

Программа лога позволяет подключать внешние программы для работы цифровыми видами. Например, можно использовать MixW2, TrueTTY, MMTTY, MMVARI, MMSSTV и другие.

Подробное описание работы этих программ Вы можете найти в соответствующих файлах помощи к каждой программе.

При работе внешних программ с программой UR5EQF LOG происходит обмен данными между программами и информация при проведении QSO автоматически записывается в аппаратный журнал (при выполнении соответствующих макрокоманд).


Цифровой магнитофон

В верхней части окна расположены значки цифрового магнитофона - recorder.

Чтобы активировать эту опцию, запустите программу из меню "Пуск", "Программы", "UR5EQF LOG", "Audio recorder". Программа будет запущена и в нижнем правом углу в трее появится значок кассеты.

Чтобы открыть Audio recorder, кликните правой кнопкой мышки по этому значку и выберите "Show". В дальнейшем, чтобы цифровой магнитофон запускался автоматически при запуске компьютера, в меню "Configure" поставьте галочку в поле "Auto start on show Windows". Если это не нужно - галочку можно убрать.

Окно цифрового магнитофона:

· в этом окне выберите звуковую карту (если их несколько в компьютере) и параметры, с каким качеством Вы хотите сделать запись.
· для записи из эфира достаточно выбрать значения "8000Hz 8bit Mono", в этом случае записанный файл продолжительностью 1 мин будет занимать объем примерно 500 Кб. При записи с более высоким качеством и в "стерео" режиме, например, "11025Hz 16bit Stereo" записанный файл продолжительностью 1 мин будет занимать объем примерно 2500 Кб. Т.е., чем выше битрейт, тем больший объем занимает записываемый файл.
· чтобы сохранить записанный файл, нужно в меню "Files" выберите "Save as", введите имя файла и нажмите "Сохранить". По умолчанию файл сохраняется в папке с программой лога и имеет название "Record.wav".
· чтобы воспроизвести текущий записанный файл, нажмите "Play".
· для воспроизведения ранее записанного файла с другим именем выберите в меню "Files", "Open file", найдите путь к нужному файлу и нажмите "Открыть".
· Записать аудиопоток и воспроизвести его можно также при помощи значков цифрового магнитофона.

recorder1 | запись
recorder3 | остановка записи
recorder2 | воспроизведение текущей записи
recorder4 | пауза воспроизведения
recorder5 | отмена воспроизведения

При каждом нажатии на кнопку записи ранее записанные данные не сохраняются, они "затираются" новыми данными. Записать текущий звуковой файл в формате "wav" можно только из окна цифрового магнитофона.


Настройка размера шрифтов

Настройка цвета окон и размера шрифтов в логе

В меню "Установки", "Настройка интерфейса", можно выбрать цвета окна ввода позывного и журнала, размер и тип шрифта, цвет шрифта повторной связи.


Внешние базы данных

Подключение внешних баз на CD-ROM или на жестком диске.

Меню "Просмотр", "Внешние базы справочников позывных".

База QRZ.COM

Ее можно скачать по этой ссылке (объем примерно 105 Мб в архиве);

· разархивируйте и скопируйте базу на любой диск в корневой раздел в созданную папку с названием callbk, например, D:\callbk\;
· в окне "Внешние базы справочников позывных" установите галочку в поле QRZ.com CD, а выберите диск, на который скопирована база.

База "Radio Amateur Callbook"

· базу RAC2008 года (331 Мб, в архиве из 6 частей) можно скачать по этой ссылке - http://ifolder.ru/f198327, на 10 марта 2008 года ссылка была рабочая.
· поставьте галочку в поле RAC CD, укажите путь к базе (на CD-диске или на жестком диске);
· кликните мышкой по кнопке "Тест";

Если база подключена правильно, Вы увидите сообщение:

База позывных от RW6HS

Эту базу можно приобрести у Василия RW6HS.

· в окне "Внешние базы справочников позывных" установите галочку в поле "VF-Soft Radio Amateur Callbook";
· укажите путь к базе на CD или на жестком диске.


Настройка Интернет

Подключившись к сети Интернет, Вы можете принимать и передавать споты через DX-кластер, осуществлять поиск информации в он-лайновых базах. Всегда перед глазами оперативная и очень полезная информация.

Настройки соединения

Откройте меню "Установки", "Настройки программы", "Интернет через прокси доступ".

Если Вы подключены через прокси-сервер в локальной сети, нужно сделать следующие настройки:

· В поле "Прокси-сервер" введите IP-адрес прокси-сервера в локальной сети.
· В поле "Порт" введите номер порта прокси-сервера.
· В поле "Логин" введите имя пользователя, под которым Вы подключаетесь к прокси-серверу.
· В поле "Пароль" введите свой пароль для доступа к прокси-серверу.

Например, так:

Если у вас прямое соединение, например, через модем или выделенную линию, то убедитесь, что поля "Прокси сервер", "Порт", "Логин" и "Пароль" в этом окне пустые.

Можно поставить галочки в нужных полях поиска из он-лайновых баз позывных. Тогда при поиске информации будет выведено отдельное окно с данными о корреспонденте.

После ввода данных сохраните настройки и перезапустите программу аппаратного журнала.


Калибровка звуковой карты

Процесс калибровки с помощью различных программ подробно описан здесь - http://www.hamradio.cmw.ru/digital/soundcalibr.htm.

Ниже описан один из простых и удобных способов калибровки при помощи программы MMVARI.

Калибровка приемной части

· скачайте, установите и запустите программу MMVARI.
· установите одну из частот - 4995, 9995 или 14995 Кгц в режиме USB.
· дождитесь, когда будут передаваться временные метки с частотой повторения 10 Гц, в это время по экрану пойдут тонкие полосы. Подождите, пока полосы займут большую часть экрана, чтобы было видно куда они наклонены.
· кликните левой кнопкой мышки по центру полосы в верхней части экрана, опустите ее до нижней части экрана так, чтобы протянутая линия была строго параллельна белой полоске и опять кликните левой кнопкой мышки, чтобы сделать корректировку (или правой кнопкой мышки, чтобы отменить корректировку). Повторите эту операцию несколько раз.
· когда полосы будут строго вертикальны - нажмите OK.
· зайдите в меню "Options" > "Setup MMVARI". Выберите закладку "Misc", в нижнем левом углу есть меню "Clock". Там вы увидите скорректированное значение. При необходимости установите корректировку "TxOffset", если частоты приема и передачи на вашей звуковой карте не совпадают.

Калибровка пeредающей части и устранение несовпадения частот

· звуковая карта должна быть дуплексной. Сделайте шнур, чтобы соединить вход и выход звуковой карты.
· зайдите в меню "Options" > "Setup MMVARI" > "TX" и установите галочку в "LoopBack" > "External" (full-duplex).
· кнопки AFC и ATC должны быть нажаты, NET - выключена. Частоты RX, TX должны изначально совпадать. Включите передачу в режиме BPSK и подождите пока значения в окне "TIMING" (ppm) не установятся.
· зайдите в меню "Options" > "Setup MMVARI" > "MISC". Здесь в окне "TXOFFSET" Вы можете установить поправку частоты в Гц.
· проделайте эту операцию несколько раз, пока не получите значение 0 ppm.


Управление трансивером

Управление трансивером осуществляется при помощи интерфейса, соединяющего компьютер и трансивер, и программы Omni-Rig. Ее можно загрузить с сайта http://www.dxatlas.com/omnirig/

Эта программа позволяет одновременно управлять двумя трансиверами даже из разных программ. Omni-Rig достаточно установить один раз и настроить. Она будет автоматически запускаться при загрузке компьютера.

Окно программы Omni-Rig

В программе Omni-Rig можно подключить два трансивера (приемника). Если поставить галочку напротив Rig1\Rig2 - можно управлять первым трансивером, если снять галочку - то вторым трансивером.

Настройки Omni-Rig

· кликните кнопкой мышки по значку [image] в окне программы Omni-Rig (на скриншоте вверху) и выберите "Omni rig setup";
· на закладке "RIG 1" в поле "Rig type" выберите марку используемого трансивера;
· в поле "Port" выберите номер порта, а также в остальных полях установите параметры для для управления частотой. Для каждого типа трансивера настройки можно посмотреть в инструкции по эксплуатации в разделе "Управление трансивером";
· если используется второй трансивер, таким же образом установите параметры для этого типа трансивера на закладке "RIG 2".

Для примера в этом окне на закладке "RIG 1" показаны настройки для трансивера Yaesu FT-2000. Номер COM-порта может быть другим, но остальные параметры изменять не нужно.

В программе лога не забудьте установить галочку в меню "Установки", "Настройка программы", "Связь компьютера с трансивером", иначе не будет переключаться вид модуляции.

Настройки для трансиверов ICOM

· запустите цифровой модуль;
· откройте меню "Конфигурация", "Настройки звукового устройства";
· как показано на скриншоте ниже, в поле "ICOM Rig ID" нужно ввести идентификационный номер трансивера, для каждой марки трансивера ICOM он различный. Список ID-номеров можно посмотреть тут - http://www.plicht.de/ekki/civ/civ-p31.html , номера приведены в шестнадцатиричном виде. То есть, если указан номер, например $5E или 5EH, то нужно ввести 5E.

· на показанном скриншоте поле ввода ID номера не активное. Оно станет активным, если в списке трансиверов в Omni-Rig выбрать трансивер фирмы ICOM;
· если при вращении валкодера частота в программе лога изменяется рывками и с задержкой, то следует в Omni-Rig в полях "Poll int." и "Timeout" поменять значения на 100 (можно поэкспериментировать с другими числами).


Настройка интерфейса

Для управления различными марками трансиверов могут применяться как самодельные, так и фирменные интерфейсы.

Один из сравнительно недорогих распространенных интерфейсов в заводском исполнении - MixW RigExpert Tiny. В функции устройства входят последовательный CAT-порт (управление трансивером), второй последовательный порт с выходами PTT (переключение на передачу) и CW (телеграфная манипуляция), а также соединение трансивера со звуковой платой компьютера.

Подключение к трансиверу - напрямую, входящими в комплект интерфейса кабелями. При соединении с компьютером используется его USB-шина, что освобождает разъемы последовательных (COM) портов, которые теперь могут быть задействованы для подключения других устройств. Отдельный источник питания при этом не требуется. Светодиоды на верхней панели позволяют контролировать работу устройства, во многом помогая при настройке программного обеспечения.

Интерфейс полностью совместим со всеми радиолюбительскими программами, работающими в среде Windows 98/ME/2000/XP/2003 - UR5EQF LOG в связке с Omni-Rig, MixW2, MMTTY, MMSSTV, MMVARI и десятками других.

Подключение интерфейса очень простое. Нужно всего лишь вставить разъемы интерфейса в соответствующие входы и выходы на трансивере и компьютере, а также установить программу драйвера для управления интерфейсом.

Процедура установки драйвера подробно описана в инструкции, присылаемой вместе с интерфейсом (файл находится на дискете с программой драйвера). При установке драйвера будут созданы два виртуальных последовательных порта. Через один из них при помощи программы Omni-Rig можно управлять частотой трансивера, а через другой порт осуществляется манипуляция PTT и CW.

При использовании этого интерфейса для цифровых видов связи необходимо сделать настройки в цифровом модуле программы UR5EQF LOG.

Настройки интерфейса со встроенным модулем CW

Для работы телеграфом запустите цифровой модуль и в меню "Конфигурация" снимите галочку с пункта "Use CWType". Настройки в цифровом модуле должны быть следующие:

· в меню "Конфигурация", "Настройки PTT" должен быть выбран номер порта для управления приемом-передачей и манипуляцией.
· в поле "PTT pins" выберите RTS.
· в поле "CW KEY" выберите DTR.

Настройки интерфейса с внешней программой CWType

Для работы с программой CWType настройки могут быть такими, например:

Номер COM-порта в обоих случаях может быть другим, в зависимости от того, через какой порт интерфейса MixW RigExpert Tiny осуществляется манипуляция.


Список "горячих" клавиш

ALT+T | окно Telnet Command (отправить команду в telnet кластере)
ALT+F | поиск позывного
ALT+L | перечень дипломов
ALT+N | окно статистики
ALT+M | окно статистики по дипломам
ALT+S | сохранение QSO
CTRL+T | переключение интерфейса "Вид1/Вид2"
CTRL+G | переключение интерфейса для "Вид1"
CTRL+F | переключение интерфейса в стандартный/нестандартный режимы
CTRL+D | сортировка в окне лога по дате
CTRL+B | сортировка в окне лога по частоте (диапазону)
CTRL+M | сортировка в окне лога по виду модуляции
CTRL+A | выделение всех связей в логе
CTRL+ALT+ENTER | отправка спота без диалога из окна Telnet


Назначение файлов в программе

Здесь описано, какие файлы в программе отвечают за ту или иную функцию. Многие файлы можно отредактировать в любом текстовом редакторе (Блокнот, WordPad и др.).

Программа по умолчанию устанавливается в каталог C:\ur5eqf_log\ . Ее можно установить на другой диск или в другую папку, по желанию пользователя.

Файлы в каталоге ur5eqf_log:

Наименование | Описание
awards | каталог с файлами (база по дипломам)
BACKUP | каталог с файлами (резерв после обновления программы)
db | каталог с файлами (конфигурация логов, база данных по QSL-менеджерам, префиксам и территориям по DXCC, городам, именам, а также внутренний справочник позывных с данными)
Disk1 | каталог с файлами (драйверы ввода-вывода данных в порты)
logs | каталог с файлами (базы данных аппаратных журналов)
Maps | каталог с файлами (графические файлы карт территорий)
PrintQueue | каталог с файлами (файлы очереди на печать)
RxLog | каталог с файлами (при работе в цифровых видах информация из окна приема записывается в файлы RxLogXXXXXXXX.log, имеющих текстовый формат данных)
TutilNew | каталог с файлами (утилита для исправления и индексации таблиц баз данных лога)
asets.dat | данные поля "Индекс" (в текстовом формате). Присваивается пользователем при создании журнала. Для каждого лога может быть отдельный индекс, тогда статистика по этим логам будет вестись раздельно. Если индекс одинаковый - статистика по этим журналам будет общая.
AudioRecorder.exe | программа цифрового магнитофона для записи аудиосигналов из эфира и воспроизведения звуковых файлов.
awards.ini, awardsEx.ini | файлы статистики по дипломам
bands.dat | формат диапазонов в Мгц (в текстовом формате)
Bands.ini | данные для управления трансивером из кластера на переключение вида модуляции в зависимости от частотного распределения по диапазонам
CabrilloMode.dat | конвертирование видов модуляции в формат Cabrillo
Contest.adi |
Contest.txt | порядок управления функциональными клавишами F1-F8 при работе в контестах
ContestMacro.INI | макросы для режима контеста
DxClaster.dat | последние скачанные данные www DX кластера
friends.ini | текстовый файл в формате "Позывной"="информация". При вводе позывного в окно ввода данные о текущем корреспонденте будут выведены в дополнительной строке синего цвета.
INSTALL.LOG | служебная информация при установке программы лога
LanguageFile | файл русификации, редактируется любым текстовым редактором. Меню лога также можно сделать на любом языке.
lptwdmio.sys | драйвер ввода вывода в порты
Master.txt | список позывных для контроля в контестах
MMvariMacro.INI | файл макросов для работы в цифровых видах
MMvariMacroContest.INI | файл макросов для работы в цифровых видах в контестах
ModCalcDll.dll | файл библиотеки программы
modes.dat | формат видов модуляции (в текстовом формате)
MorseMacro.ini | файл макросов для работы телеграфом
nodelist.dat | информация об узлах telnet кластера (в текстовом формате)
Prefix.lst | данные префиксов стран и территорий
printer.def | файл установок принтера для программы печати QSLPrint
qrz32.dll | файл библиотеки программы
QSLDemo.qsl | образец создания QSL-карточки
QslPrint.exe | программа печати QSL-карточек и наклеек
QslPrint.ini | файл инициализации программы печати и настройки принтера
raccd32a.dll | файл библиотеки программы для работы с внешней базой Radio Amateur Callbook
SWL.dat | данные по радиовещательным станциям (в текстовом формате)
TelnetCommand.txt | команды telnet кластера
UNWISE.EXE | удаление программы лога
UR5EQF.chm | файл помощи
UR5EQF_Log.exe | файл запуска программы лога
UR5EQF_Log.INI | файл инициализации программы
UR5EQF_server.exe | файл запуска многопользовательского режима, для работы в локальной сети
world.bmp, world.lyr, world.lyr.md | файлы карты мира
wwv.txt |
wwwclasterspot.dat | url-адреса www DX кластера

Файлы в каталоге awards (по умолчанию):

Наименование файла | Описание
DOK.db, DOK.px | база по диплому DOK
DXCC.DB, DXCC.PX | база по диплому DXCC
IOTA.db, Iota.px | база по диплому IOTA
P-75-P.db, P-75-p.px | база по диплому P-75-P
RDA.db, RDA.px | база по диплому Russian District Award
Russia.DB, Russia.PX | база по диплому RUSSIA
Statistic.DB, Statistic.MB, Statistic.PX | база по дипломам для вывода текущей статистики
URDA.db, URDA.PX | база по диплому Ukraine District Award
W28MA.db, W28MA.PX | база по диплому Worked 28 Meridian Award
WAS.DB, WAS.PX | база по диплому WAS
WAU.db, WAU.px | база по диплому Worked All Ukraine
WAZ.DB, WAZ.PX | база по диплому WAZ
WPX.db, Wpx.px | база по диплому WPX

Файлы в каталоге db:

Наименование файла | Описание
Aconfig.DB, Aconfig.PX | файлы конфигурации журнала. Описание расположения каждой базы лога на диске, информация о своем позывном, имени, QTH, координатах, часовом поясе и т.д. (отдельно для каждого созданного лога). При создании нового лога информация заносится в этот файл. Если их удалить - все логи нужно будет создавать заново, указав пути к соответствующим базам.
Amgr.DB, Amgr.PX, Amgr.XG0, Amgr.XG1, Amgr.YG0, Amgr.YG1 | база данных QSL-менеджеров.
Aprefix.DB, Aprefix.PX, Aprefix.XG0, Aprefix.XG1, Aprefix.YG0, Aprefix.YG1 | база данных префиксов по территориям
Callbook.DB, Callbook.MB, Callbook.PX, Callbook.XG0, Callbook.YG0 | база данных внутреннего справочника позывных
City.DB, City.PX, City.XG0, City.YG0 | база данных по названиям городов мира
condtest.DB, condtest.MB, condtest.PX | база данных по контестам
Dxcc.DB, Dxcc.PX | база данных префиксов по DXCC
ImageTable.db, ImageTable.MB, ImageTable.PX |
Names.DB, Names.PX, Names.XG0, Names.YG0 | база данных по названиям имен
Prefix.DB, Prefix.PX, Prefix.XG0, Prefix.XG1, Prefix.YG0, Prefix.YG1 | база данных по префиксам, с названиями и координатами территорий.


Советы автора программы

 Top Previous

Если у Вас начинает "барахлить" программа

Часто причиной является нарушение целостности таблиц баз данных. Это может произойти при некорректном завершении работы программы, принудительном завершении обновления статистики по дипломам, импорта связей в лог и т.д.

Есть несколько способов исправить ошибки:

1. Переиндексация таблиц баз данных

из меню "Журнал", "Операции с журналом", "Повторная переиндексация текущего журнала". После этой процедуры нужно перезапустить программу лога.

Если после переиндексации связи в логе вдруг исчезли с экрана и новый позывной не вводится вообще - не беспокойтесь, лог не пропал, он находится в папке logs. Попробуйте сделать так:

· закройте программу;
· сделайте резервную копию файлов Вашего лога, по умолчанию: C:\ur5eqf_log\logs.

Журнал состоит из множества файлов, объединенных одним именем, например:

UR5EQF.db
UR5EQF.MB
UR5EQF.PX
UR5EQF.XG0
UR5EQF.XG1

· в первых двух, «имя_файла_лога.db» и «имя_файла_лога.MB», хранятся сами данные, а остальные – индексные файлы, они нужны для быстрого поиска по журналу;
· оставьте только два файла *.db и *.MB, остальные удалите;
· если у Вас несколько журналов – работайте только с файлами проблемного журнала;
· запустите программу и выполните повторно индексацию. Удаленные файлы будут восстановлены. Если не помогло с первого раза - выполните переиндексацию еще раз.

2. Переиндексация всех таблиц

из меню "Журнал", "Операции с журналом", "Переиндексация всех таблиц" можно сделать переиндексацию таблиц внутреннего справочника позывных, префиксов, менеджеров, статистики, а также справочника имен и городов.

· откроется окно, кликните мышкой по кнопке "Переиндексация всех таблиц";
· кликните по кнопке "ОК";
· дождитесь окончания процесса переиндексации, затем перезапустите программу лога.

3. Проверка и восстановление баз данных

В новых версиях лога имеется встроенная проверка и восстановление баз данных.

· из меню "Журнал", "Операции с журналом", выберите "Проверка и восстановление базы данных".
· появится окно с предложением перезапустить программу, нажмите "ОК".
· при следующем запуске программы лога базы будут проверены и при наличии ошибок автоматически исправлены.

4. Если это не помогло:

· в каталоге программы \ur5eqf_log\ удалите папку "awards";
· в папке "DB" оставьте только файлы "Aconfig.db" и "Aconfig.px", в этих файлах хранится информация о Ваших логах;
· папку "logs" не удаляйте, в ней хранятся сами логи;
· выполните полную инсталляцию программы. Новую полную инсталляционную версию всегда можно найти на сайте автора - http://ur5eqf.com/.

5. Если и это не помогло, то по всей видимости серьезно повреждена таблица с Вашим логом.

· выполните процедуру, описанную в пункте 3;
· создайте новый лог из меню "Журнал", "Операции с журналом", "Создать новый журнал". Обратите внимание на значение в поле "Индекс", оно должно быть отличным от "Индекса" Вашего лога;
· произведите копирование данных из Вашего лога со вновь созданный, для этого:
· в окне журнала выделите все записи;
· правым кликом мышки по окну журнала вызовите меню;
· выберите пункт "Копировать в другой журнал";
· в появившемся окне выберите созданный лог и нажмите кнопку "Ок".

6. Неправильно отражается статистика в логе.

Если статистика по выбранному диплому в "Статистике по дипломам" и при формировании заявки на диплом отличается, то можно попробовать решить эту проблему следующим образом:

· посмотрите в конфигурации лога, какое значение "Индекс" присвоено Вашему текущему логу при создании журнала (перечень индексов есть в файле "asets.dat");
· закройте программу аппаратного журнала;
· найдите в \ur5eqf_log\awards\ папку, одноименную с индексом (например \ur5eqf_log\awards\A\ );
· удалите эту папку (внимание!!! никакие файлы в каталоге \ur5eqf_log\awards\ не удалять!!!);
· запустите программу аппаратного журнала (папка с названием "индекса" будет создана автоматически);
· обновите статистику из меню "Журнал".

Если и в этом случае статистика различается, тогда сравните данные по выбранному диплому в "Перечне дипломов" и в файле awards.ini. Иногда выявляются несовпадения или ошибки, в этом случае придется отредактировать данные вручную, затем обновить статистику.

7. При вводе QSO не определяется или неправильно определяется территория по DXCC

Если при вводе позывного в аппаратный журнал по каким-то причинам территория по DXCC не определилась, то в "Статистике по дипломам" в верхней части таблицы может появиться "пустая" строка, в которой будут отображаться такие QSO как проведенные или подтвержденные. В подавляющем большинстве случаев это может случиться из-за того, что префикс позывного отсутствует в списке префиксов (например, очень редкий, специальный и т.д.) и при записи QSO в лог вместо территории по DXCC будет записано "пустое" значение.

Чтобы быстро найти такие позывные в логе, можно воспользоваться поиском по фильтрам. Поставьте галочку в поле напротив "Неизвестные территории" и нажмите ОК. В окне лога появится список позывных с неопознанными территориями. Отредактируйте и присвойте страну по списку DXCC каждому позывному. При необходимости можно отредактировать список префиксов и внести в него изменения. Затем обновите статистику по дипломам. Если сделать все правильно, то "пустой" строки в "Статистике по дипломам" не появится и эти связи в логе будут корректно отражаться в статистике.

8. Критическая ошибка системы при первом запуске программы

При первом запуске программа или вызывала критическую ошибку системы, или отображалось окно программы, но она была практически не работоспособной, или не отображалось содержимого лога, на ввод позывного не было никакой реакции. Причиной оказалась старая версия BDE, установленная ранее программы лога.
Первым признаком старой версии BDE есть отсутствие ярлыка "BDE Administrator" на панели управления. В некоторых случаях BDE устанавливается в каталог: "C:\Program Files\Borland\Common Files\BDE" (не всегда так). Запустите исполняемый файл bdeadmin.exe. Посмотрите пункт меню "Help", "About", версия должна быть не менее 5.01.

Если версия ниже, чем 5.01:

· сохраните имеющуюся конфигурацию: "Object", "Save as Configuration….";
· переименуйте каталог с BDE;
· перезапустите компьютер;
· выполните полную инсталляцию лога;
· на панели управления должен появится ярлык: "BDE Administrator";
· запустите администратор;
· объедините вновь созданную конфигурацию с сохраненной: "Object", "Merge Configuration….".

Такая ситуация возникала, если на компьютере была установлена программа Slog, "Карта города" и т.д.

9. Восстановление "водопада" в цифровом модуле

Если Вы случайно сдвинули границы "водопада" в цифровом модуле так, что их невозможно восстановить вручную обратно, проделайте следующее:

· закройте программу лога;
· найдите файл UR5EQF_LOG.INI в папке C:\WINDOWS\;
· откройте его любым текстовым редактором;
· найдите раздел [TfmMMvari];
· ниже найдите следующие строки:

Panel8_Height=330

Panel1_Height=364

Panel7_Height=50

· значения напротив Panel8_Heigh и Panel1_Height будут другими, отредактируйте их так, как показано на примере;
· сохраните файл;
· запустите программу лога и цифровой модуль, окно "водопада" должно быть восстановлено.

10. При вводе позывного в лог программа "зависает"

Если возникла такая ситуация, значит повреждена таблица с базами данных внутреннего справочника позывных или таблица префиксов. Кроме перечисленных выше, могу предложить еще один выход из этой ситуации:

· по этой ссылке http://www.cqrivne.com.ua/425DXNews/rz1om/base.rar можно скачать рабочие файлы баз данных внутреннего справочника позывных, а также таблиц префиксов и QSL-менеджеров. Это рабочие базы из моего лога (RZ1OM).
· разархивируйте файл, в нем есть описание, какие файлы и в какую папку нужно скопировать.

11. Если программа лога очень долго запускается или закрывается

Причиной этого является работа антивирусной программы.

В свойствах антивирусной программы отмените проверку файлов в папке C:\ur5eqf_log\, а также файла UR5EQF_LOG.INI в папке C:\Windows\ .

Обратите внимание, диск C:\ указан по умолчанию, у Вас может быть другая буква диска, на который Вы установили операционную систему, или другое имя папки, где установлена программа лога.